[SOLVED] TL-MR6400. LEDE snapshot - inbound connections problems

I successfully flashed a TL-MR6400 with LEDE snapshot.

First of all, of course I know how to setup port forwards!

It ran very good until I needed to set up port forwards for connecting remotely to my services, mostly OpenVPN and SSH, like I had before in the stock firmware.

After a massive headache I finally found that inbound connections seem to never reach the WAN interface of the device (router side, not the LTE)

This device has an integrated LTE module that runs on android and have a DHCP server...
WAN interface on LEDE is a normal DHCP client by default and connects normally, internet outgoing connections also work normally.

The problem lies on the incoming connections that seem to never reach the WAN interface of LEDE system, I could clearly see it running tcpdump on that interface (usb0=WAN)

If I run tcpdump via adb shell (it's integrated and will run directly on the LTE module firmware) I can see all inbound connections, but they seem to never be forward to the WAN ip of router
As I understand something on the LTE module side is blocking these connections, but I'm not really sure.

I had to revert to OEM firmware, port forwards work normally as before (before trying LEDE on this device).

Maybe the stock firmware make changes in the LTE firmware side (firewall rules maybe??) that LEDE is not doing?

With this post I hope other MR6400 users could give some feedback about running LEDE on these devices.

Thank you for taking the time.

Check WAN IP on router side. Similar router Archer MR200 v1 have modem with DMZ set to IP
Try set the same Router WAN IP like in OEM firmware.

Thanks for your response.

That's probably it. LTE module uses by default, router side uses by default, so, modem will probably have DMZ set to, TP-Link's firmware automatically changes modem address subnet in case you change it in the router side, and probably also set DMZ accordingly.
So, if I maybe set WAN to static IP on the router side it will may work?? :confused:

WAN in MR6400 running LEDE is a DHCP client by default and gets IP in range.

Maybe should LEDE be able to set the DMZ IP? Shouldn't be to hard I think, via adb shell maybe...

I don't have much time now to re-test this, I need the router up and running, but I will eventually, as always any help and clarifications will be appreciated.

Tony did you find a solution to this issues?

No, I didn't found a solution at the time of testing. I've reverted to original firmware and never had time to re-test LEDE/OpenWRT on this device again.

Do you have the same problems, or what kind of problems you have?

Just a follow up so that other TL-MR6400 users can have more feedback for this device running OpenWrt(/LEDE)

I finally had time to reflash OpenWrt snapshot again on the MR6400 and no problems this time.
I mean, with the the default configuration the same problem described in the first post happens.

But after ...

adb shell
iptables -t nat -L

from the output, it's clear that the modem will DMZ to
So, I just set WAN (router side) to that static ip and everything works.

By the way, I also successfully used shared storage from LTE Module as extroot.
It's a free 60MB of space you can use for pretty much everything, so you can install much more packages.

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.