[Solved] The opkg update command failed with code 1

Errors
Failed to send request: Operation not permitted
Collected errors:

This is the error, I can't update it, will you help me?
I use Xiaomi mi 4a gigabit 2021

This is telling you that there isn't proper network connectivity. Is this device performing as a router or a dumb AP? Let's see the config.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
type or paste code here
```` "kernel": "5.15.132",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "Xiaomi Mi Router 4A Gigabit Edition",
        "board_name": "xiaomi,mi-router-4a-gigabit",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.0-rc4",
                "revision": "r23482-7fe85ce1f2",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.0-rc4 r23482-7fe85ce1f2"



config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd93:f195:e57f::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'



config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd93:f195:e57f::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'





config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'





config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   I deleted here
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  I deleted here
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          I deleted here
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   I deleted here
#       option src_mac  I deleted here
#       option src_port 80
#       option dest             wan
#       option dest_ip  I deleted here
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   I deleted here
#       option src_mac  I deleted here
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  I deleted here
#       option dest_port        120
#       option proto    tcp

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'`

what is the output of:

ping 8.8.8.8
ping 168.119.138.211
ping downloads.openwrt.org

ping 8.8.8.8
ping 8.8.8.8 64 bytes from 8.8.8.8: seq=30 ttl=54 time=21.472 ms
64 bytes from 8.8.8.8: seq=31 ttl=54 time=20.122 ms
64 bytes from 8.8.8.8: seq=32 ttl=54 time=20.149 ms
64 bytes from 8.8.8.8: seq=33 ttl=54 time=20.219 ms
64 bytes from 8.8.8.8: seq=34 ttl=54 time=19.974 ms
64 bytes from 8.8.8.8: seq=35 ttl=54 time=19.984 ms
64 bytes from 8.8.8.8: seq=36 ttl=54 time=19.989 ms
64 bytes from 8.8.8.8: seq=37 ttl=54 time=20.017 ms
64 bytes from 8.8.8.8: seq=38 ttl=54 time=20.119 ms
ping 168.119.138.211
64 bytes from 8.8.8.8: seq=105 ttl=54 time=3005.232 ms
64 bytes from 8.8.8.8: seq=106 ttl=54 time=2005.162 ms
64 bytes from 8.8.8.8: seq=107 ttl=54 time=1005.046 ms
64 bytes from 8.8.8.8: seq=108 ttl=54 time=20.205 ms
64 bytes from 8.8.8.8: seq=109 ttl=54 time=19.996 ms
64 bytes from 8.8.8.8: seq=110 ttl=54 time=20.004 ms
64 bytes from 8.8.8.8: seq=111 ttl=54 time=20.048 ms
64 bytes from 8.8.8.8: seq=112 ttl=54 time=20.117 ms
64 bytes from 8.8.8.8: seq=113 ttl=54 time=20.086 ms
64 bytes from 8.8.8.8: seq=114 ttl=54 time=20.074 ms

ping downloads.openwrt.org
64 bytes from 8.8.8.8: seq=186 ttl=54 time=67.922 ms
64 bytes from 8.8.8.8: seq=187 ttl=54 time=20.060 ms
64 bytes from 8.8.8.8: seq=188 ttl=54 time=20.033 ms
64 bytes from 8.8.8.8: seq=189 ttl=54 time=20.038 ms
64 bytes from 8.8.8.8: seq=190 ttl=54 time=20.127 ms

this doesn't look right ...

what if you do nslookup downloads.openwrt.org 8.8.8.8

nslookup downloads.openwrt.org 8.8.8.8
64 bytes from 8.8.8.8: seq=440 ttl=54 time=2012.979 ms
64 bytes from 8.8.8.8: seq=441 ttl=54 time=1013.896 ms
64 bytes from 8.8.8.8: seq=442 ttl=54 time=20.628 ms
64 bytes from 8.8.8.8: seq=443 ttl=54 time=20.053 ms
64 bytes from 8.8.8.8: seq=444 ttl=54 time=20.275 ms
64 bytes from 8.8.8.8: seq=445 ttl=54 time=20.228 ms
64 bytes from 8.8.8.8: seq=446 ttl=54 time=20.219 ms

Something is wrong if lookup causes ping results to show up. Did you stop the pings first?

1 Like

how do i stop it

Usually control+c

I stopped it, now what should I ping?

Run this command.

;; connection timed out; no servers could be reached

what does cat /tmp/resolv.conf.d/resolv.conf.auto say ?

Interface lan

nameserver 8.8.8.8
nameserver 8.8.4.4

Interface wan

nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 192.168.1.1
search local

Interface wan6

nameserver fe80::1%wan

Let’s try this one again.

64 bytes from 168.119.138.211: seq=26 ttl=52 time=1010.280 ms
64 bytes from 168.119.138.211: seq=27 ttl=52 time=59.787 ms
64 bytes from 168.119.138.211: seq=28 ttl=52 time=48.593 ms
64 bytes from 168.119.138.211: seq=29 ttl=52 time=48.487 ms
64 bytes from 168.119.138.211: seq=30 ttl=52 time=48.268 ms
64 bytes from 168.119.138.211: seq=31 ttl=52 time=48.751 ms
64 bytes from 168.119.138.211: seq=32 ttl=52 time=48.586 ms
64 bytes from 168.119.138.211: seq=33 ttl=52 time=49.003 ms
64 bytes from 168.119.138.211: seq=34 ttl=52 time=48.763 ms

and please use the </> button (on top of the message window) when pasting cli output.

OK sorry :slight_smile:

And now this one again. (Be sure the previous ping has been stopped)