[SOLVED] Sysupgrade image for BCM63xx/AGPF-S0

Hi everyone. I've built lede images using these instructions and this config file.
In menuconfig I selected all possible target images (except ext4), that are:

  • ramdisk
  • cpio.gz
  • tar.gz
  • squashfs

After compilation, in targets directory I got the files:

  • config.seed
  • lede-brcm63xx-generic-rootfs.cpio.gz
  • lede-brcm63xx-generic-AGPF-S0-initramfs.elf * *
  • lede-imagebuilder-brcm63xx-generic.Linux-x86_64.tar.xz
  • lede-brcm63xx-generic-AGPF-S0-squashfs-cfe.bin
  • packages
  • lede-brcm63xx-generic-device-agpf-s0.manifest
  • sha256sums

but apparently no sysupgrade image. Are sysupgrade images generated only for some devices in presence of some kind of profile or there is something wrong with my config?

You most likely selected too many packages to be included, so the resulting image got too large. You'll see the error messages if you bump up the build verbosity (make -j1 V=s).

You think could be this even if squashfs-cfe.bin (the factory image, right?) is only 3.5 mb large?

If I delete .config file and redo the steps in the instructions without selecting anything else than target config (I've selected almost anything previously anyway) and without doing make clean, sysupgrade should be built even if there is no sysupgrade in official repos?

EDIT: used default .config. Now squashfs-cfe.bin is 3.3mb large and no sysupgrade image being generated.

no one can help me?

There is no sysupgrade image for this device.

Its building is something simple as changing parameters in a template and recompile?

You simply use lede-17.01.4-brcm63xx-generic-AGPF-S0-squashfs-cfe.bin for factory install and sysupgrade.

Is this all documented anywhere? I have looked and haven't found details I need.

Will sysupgrade lede-17.01.4-brcm63xx-generic-AGPF-S0-squashfs-cfe.bin work the same as if the image was a sysupgrade image? It's not clear to me.

What is the difference besides that it doesn't have sysupgrade in the name?

I looked at platform.sh but that wasn't enough for me to tell the difference.

Thank you @Blarty_Runfaster for summing up my doubts.
If I broke cfe there's no chance I could get back without jtag.

@tallero I take the conservative approach unless I really don't care about the device.

But I still would like to know answers to those questions I posted above because the device I want to try I do care about.

Difference between factory/sysupgrade images:


I think that part I had clear already. Can I run this command over a current LEDE or an older Openwrt?

sysupgrade lede-17.01.4-brcm63xx-generic-AGPF-S0-squashfs-cfe.bin

Or do these images, without sysupgrade in the name, only work over a factory stock firmware?

Just want to be clear on this and not being too idiotic (I think).

I guess I need to squashfs mount one of these and take a look inside.

@tmomas @Blarty_Runfaster from what I've found on openWRT wiki when there is no sysupgrade image we first have to convert .bin image to .trx as described here, then use the image created through LuCI, sysupgrade tool or mtd (how to find the name of the partition?), am I right?

The image conversion you linked is for bcm47xx, while the AGPF-S0 is brcm63xx.
I couldn't find any mention of converting images on https://wiki.openwrt.org/doc/hardware/soc/soc.broadcom.bcm63xx

Finally, the guide you mentioned in your first posting is about ar71xx.
Seems you are mixing up the targets a bit.

I just want to know how to upgrade lede without using cfe commands and breaking the router. Apparently not so much routers support sysupgrade and many non-standard ways to upgrade exist, depending on router model. You know what is the recommended way to upgrade AGPF-S0?
It's not that I want to mix targets, I'm just collecting information because, well, there is no manual or standard procedures and you are the only person replying.

No one can help?

I am not much help as there are many unanswered questions for me too. I would think the best solution is to build the firmware yourself.

But then you need to find out how to make a sysupgrade image. But I don't know what making a sysupgrade image requires. Here are some questions I can't find answers to.

Questions for anyone and any device without sysupgrade images:

  • Is it impossible to create sysupgrade images for some devices?

  • Is it possible to create sysupgrade images for any device but some require much more work to do that?

  • If it's possible to create sysupgrade images for any device are there any guides to do that?

  • If it's not possible is it documented why it's not possible? If so, where?

  • If there's no documentation where to look in the build environment to understand how sysupgrade images are created?

There are probably other questions that need asking and answering but I don't know enough to know what else to ask.

I flashed cfe-bin image as a sysupgrade and everything went well.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.