[Solved]Slowness problem only on twitter website

Hi, firstly sorry for my english...
I have a TP-Link Archer C60 V2.0 Router with Openwrt 18.06.2 (installed 18.06.4, but caused memory issues, so i downgrade to the 18.06.2 and now the memory issue is gone). The problem is ONLY (i think, at least i didn't realize the issue on other websites) on the Twitter website, where most of the time it's terribly slow, it's loads the layout, text and sometimes pics, but videos are a pain to get playing, stay a really long time to load (like 2 minutes to play a 20 seconds video).
I have a 40 Mb Down / 20 UP FTTH link, wheres the Fiber comes to a Fiberhome AN5506-04, in Bridge to the TP-Link router, where i do the PPPoE auth. The problem is only on the OpenWRT router, because if i turn the Fiberhome to Router and use her to do the PPPoE, the Twitter works fine on all devices connected to the Fiberhome.

The OpenWRT install is fresh new, i just flash the 18.06.2, configure the PPPoE user and pass, and turn on wifi. I already try to disable firewall, and dont seem to do difference. below is my /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'                                                                                                                                                                                                              config globals 'globals'
        option ula_prefix 'fdf6:95d5:4deb::/48'                                                                                                                                                                                                 config interface 'lan'

config interface 'lan'
        option type 'bridge' 
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'                                                                                                                                                                                                                   config interface 'wan'

config interface 'wan'
        option ifname 'eth0'
        option proto 'pppoe'
        option username '*****'
        option password '*****'
        option ipv6 'auto'
        option peerdns '0'
        option dns ''                                                                                                                                                                                                            config interface 'wan6'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        option dns '2606:4700:4700::1111 2606:4700:4700::1001'                                                                                                                                                                                  config switch
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'                                                                                                                                                                                                                  config switch_vlan
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

if need any other info, i can provide of course. Anyone has any idea what's is going on? i search the forum and did not find nothing like this, Thanks

I see both of topics in a previous search, do all of the mentioned, but nothing changes, same issues.
I see DNSMASQ logs, and all querys are been replyed.
i notice that, sometimes, the twitter starts to work normally, but almost always have the issue. Nothing changes in the log when twitter is working...

It's entirely possible that the problem is actually just with Twitter's servers, particularly in your area maybe there are issues with geo-local servers that Twitter has deployed that aren't working well etc.


That's is whats my ISP says, before they do testing directly in their office. They can access normally from there. If i change the network to the Fiberhome it works normally too (so it's not server either ISP problem). Also, on mobile network (3G/4G on smartphone) it works normal too.
If i use a VPN on the OpenWRT router, the Twitter starts working normally too...

Different providers may use different policies for traffic shaping, different routes to the servers and even different servers due to load balancing.
Sometimes the only solution is to use VPN.

Those are good observations for debugging purposes... One question that occurs to me is whether ipv6 is involved. Perhaps your ISP's router doesn't use it but it's available and OpenWrt does. It would be useful to have a tcpdump of the traffic to see what's going on. The fact that it only happens to Twitter is hard to explain if it's a general purpose problem with OpenWrt.

Yes i know, but, the same provider, same PPPoE auth, and the same network, on the Fiberhome ONU works. On the OpenWRT Router doesn't. My ISP have DNS Hijack, but they deactivate because i ask. Changing DNS doesn't help either...

That's is true. My ISP Router doesn't support IPv6 and OpenWRT its using. But i try deactivating ipv6, and nothing changes...

I think a tcpdump would be in order, perhaps you'll find a lot of dropped or out of order packets or something. When you run the OpenWrt device is it behind the ISP device or is it in stead of the ISP device?

Fiber from outside>>Fiberhome in Bridge >> Archer C60 (OpenWRT)

Before that fiberhome, i used to have a Intelbras 110 ONU, but it stops working ipv6 even in bridge, the ISP than change to the fiberhome. With the intelbras, twitter was working ok.

I'm trying to get a tcpdump, but cant find the right syntax to capture twitter related packets. I tried specifying:
tcpdump -n host twitter.com
tcpdump -i eth0 host twitter.com
tcpdump -i eth0 net (the subnet that get on ping to twitter.com)
but dont get any packet...
if i do just "tcpdump", i can get all packets...

Have you considered the possibility to change your DNS servers? Have you tried the servers provided by your ISP?

Yes. I already change to because on the ISP DNS the problem was present. I tried Google 8.8.8 too...

Do you trust them?
Even if it's true, they can enable it again anytime.
I'd better use DNS encryption.

Yes. They tried with me to resolve this problem. And I run some DNS leak test, it's been desable. I try encrypted dns too, same problem.
I think the answer will be to use a VPN by now, until I can test with other router, if other router works, I think I will try to flash TP-Link stock firmware...

1 Like

Ok. Now it's working. I do many tests, because the cause of the problem is weird.
I go back to a previous config, everything was working before, and, the config that solves the problem was to separate the 2.4 and 5.0 WiFi SSID. This is really strange, but after I do that, its working. If I set the same SSID on both, to show as only one network to devices, the Twitter stop working properly, but if a do separate SSIDs (like Network_2.4 and network_5.0), than the Twitter stars to work normally. And after config separate SSID, the performance of websites in general seems faster, like the response time of the router decreases. This all sounds really weird I know, I will do more tests, on other routers, to see if it's just on this model...
Problem solved.

1 Like

5 GHz wifi is a little weird in OpenWrt system. I have a HomeHub 5A and if I use auto channel on 5G band I cant get IP address from router. But if I use a static channel then ecerything is fine.

Just like your case, it has been advised before to keep different SSIDs for both bands and it actually helps in most cases.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.