[Solved] Setting up VDSL in Germany with new LEDE box


#21

If you don't have any RJ11 plugs, you could shave off the sides of an RJ45 until it fits the DSL socket in the HH, which will mean removing plastic until it is almost down to the outside metal contacts. The height of the two plugs and the clip are the same. The only difference is in width.

Plugging an RJ11 into an RJ45 socket works, but it usually damages the two outside pins on the socket so they can't make contact with an RJ45 plug any more. This is no concern if the RJ45 is only wired for one DSL circuit on the innermost contacts.


#22

that's an extremely helpful hint, thanks ! I just removed a good portion of the RJ45 plug with just a regular kitchen knife (shouldn't recommend this though haha) until I could fit it in the gray modem socket of the HH5A. So far it doesn't connect but I am assuming I just did a lousy job (the plug looks horrible tbh!) but I have ordered a genuine TAE F to RJ11 cable that should arrive by the end of the week and then I'll report back. In the meantime I might try to use the Fritz!Box 7412 we got from the ISP as just a modem and link it up to the red WAN port of the HH5A. With recent firmwares it seems rather hard to get this working but someone recommended factory resetting the FB.
Anyways, thanks for all the help & recommendations so far ! Didn't expect that many responses, it's very encouraging :slight_smile:


#23

okay, got the right cable (TAE–RJ11) and the modem instantly connected to my ISP. Everything is going great ! Thanks for all the help, already in love with LEDE <3


#24

What speed you got ? Are you using VDSL with vectoring ?


#25

I just ran a quick fast.com check over WiFi last night to make sure it was working. It was about 42-47Mbps which seems alright considering we have a VDSL50 subscription. As far as I understand it everything >16Mbps would indicate it is using vectoring, is that correct? Where could I check within LEDE to confirm that? Also I read somewhere that the default WiFi configuration LEDE comes with leaves a lot of space for performance tuning & optimization. Is there a guide somewhere that I could follow to tweak the settings until I find the optimal setup?


#26

I dont know your device but you should look for something saying "G.Vector/Vectoring Full/ON".
You can post a screenshot of your DSL stats if you want, maybe I can tell you from there if vectoring is active...

You could also check if your driver version has vectoring support (look for incl. vectoring support): https://xdarklight.github.io/lantiq-xdsl-firmware-info/


#27

This is only true if your line card is already using vectoring! Only in that case will non-vectoring capable CPEs be provisioned with the fall-back profile that only uses frequencies <= 2.2 MHz (vectoring will as far as I know not be used on these frequencies anyway, since these are used by legacy ADSL links). But unless you installed your own firmware your device should not be vectoring capable, the default firmware as distributed by lede does not allow vectoring (I believe for licensing reasons.).
Maybe you could post the dsl information from your HH5A overview page, that should contain clues about what is used...

Best Regards


#28

ok according to the page my driver version 5.7.9.9.0.6 doesn't have vectoring support. now could I just update to something like 5.8.1.5.0.7-5.8.0.9.0.1 which includes vectoring and try again or does it mean that my ISP doesn't have vectoring enabled for our lane yet?
I was thinking about perhaps switching ISPs (to Deutsche Telekom directly) and upgrading to 100Mbps. For this to work it would be really important to have vectoring enabled, no?


#29

I am gonna make sure to post this information when I get home


#30

Exactly that, your MSAN/DSLAM/Linecard is not (yet) operating in vectoring mode, if if gets switched and your firmware really does not support vectoring (which it does not) you will most likely be relegated to a fall-back profile, which for DTAG means around 16 Mbps ingress.

As far as I know DTAG only offers VVDSL100, meaning vectoring is mandatory (and unless your MSAN/DSLAM is already operating in vectoring mode you also need to be switched from BRAS to BNG, a process that currently is estimated to take until at least 2019, but I digress).

Best Regards


#31

If your speed is up to 47mbit/s you shouldn't have vectoring active if your driver doesn't support it.
Otherwise your device wouldn't even sync and your fallback profile would be ADSL2+@Annex B with Deutsche Telekom. Your device does only support Annex A @ADSL mode...

Anyway i would recommend a Vectoring capable driver just in case...


#32

Except the fall back seems not to be ADSL(2+) but rather a restricted VDSL16 , so the HH5A should still work... personally I fully endorse VDSL16 in that case as I prefer PTM over ATM/AAL5 any old day, but I digress.

Best Regards


#33

If the VDSL100 works perfect the question are: Can the HH5a handle the speed. You should use the newest LEDE snapshoot with SMP support.
I have start a General discusion of the VDSL speed at Lantiq VR9 devices


#34

Alright I have stupid questions. I have the HH5A bought from eBay with the BT firmware I flashed with LEDE 17.04.1

I am trying to configure it for DTAG VDSL and I don't have any luck ever. I am using TAE->RJ11 cable which works fine with a TP-Link VR200v (TP-Link firmware).

Just to clarify, since it's not obvious to me. The HH5A has 4 conductors in the RJ-11 socket. The TAE cable is supposed to connect to the middle two contacts? The TP-Link VR200v only has 2 contacts in the RJ-11 socket, which meant I need to rewire the TAE cable since TAE pin 1 & 2 normally go to pins 4 and 1 on the RJ-11 side. I did this and the TP-Link works fine with 50MBit VDSL.

I tried both my modified TAE cable and a brand new TAE->RJ11 cable with the HH5A, and each one gives 0x200: silent

No matter what the settings are in /etc/config/network, I always have:

ATU-C Vendor ID:                          
ATU-C System Vendor ID:                   
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.7.9.9.0.6
API Version:                              4.17.18.6
XTSE Capabilities:                        , , , , , , , 
Annex:                                    
Line Mode:                                
Profile:                                  
Line State:                               DOWN [0x200: silent]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 0
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 16621 / Far: 16621
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L3 - No power
Latency / Interleave Delay:               Down: Fast (0.0 ms) / Up: Fast (0.0 ms)
Data Rate:                                Down: 0 b/s / Up: 0 b/s
Line Attenuation (LATN):                  Down: 0.0dB / Up: 0.0dB
Signal Attenuation (SATN):                Down: 0.0dB / Up: 0.0dB
Noise Margin (SNR):                       Down: 0.0dB / Up: 0.0dB
Aggregate Transmit Power (ACTATP):        Down: 0.0dB / Up: 0.0dB
Max. Attainable Data Rate (ATTNDR):       Down: 0 b/s / Up: 0 b/s
Line Uptime Seconds:                      0
Line Uptime:                              down

Here is my /etc/config/network:

config dsl 'dsl'
        option annex 'b'
        option tone 'b'
        option xfer_mode 'ptm'

config interface 'wan'
        option ifname 'ptm0.7'
        option proto 'pppoe'
        option username '<Anschlusskennung><T-Onlinenummer>#0001@t-online.de'
        option password '<Kennwort>'
        option ipv6 'auto'

There is no section for atm.

Is my hardware broken? Why won't this thing detect an xDSL signal?!


#35

A true RJ-11 (original standard) has the active line pair on the center 2 pins. I think the new BT stuff complies with that standard.

Remember, the HH5a does not do Annex B.


#36

The only difference (compared to a vgv7510kw22) I see, is the tone setting ('av' for me), but the status output just looks like a non-connected DSL cable (depending on your ISP, you might have to supply a vectoring enabled dsl firmware even for 50 MBit/s, but even without that, it should connect (with a 20 MBit/s fallback profile)).


#37

1.) no idea about RJ-11 but on TAE you need only a and b line see: https://de.wikipedia.org/wiki/Telekommunikations-Anschluss-Einheit

2.) use an DSL-firmware with vectoring support see: https://wiki.openwrt.org/toh/arcadyan/vgv7510kw22
(goto: VDSL Firmware)

3.) spezify the path of your new firmware "option firmware '...'" inside the config
(the "option annex 'b'" choice the path for the default firmware)
Add option line_mode 'vdsl'
here is my config:

...
config dsl 'dsl'
        option firmware '/lib/firmware/lantiq-vrx200-b.bin'
        option xfer_mode 'ptm'
        option annex 'b'
        option line_mode 'vdsl'
...

#38

Thanks to everyone for the replies!

I extracted the xDSL firmware from the FRITZ!Box 7490 linked on the lantiq xdsl firmware page. I copied vr9-B-dsl.bin from the FRITZ firmware to the router and used the configuration stanza from @Plonk34 in /etc/config/network

Maybe also important, I read that DTAG didn't reset the line state until 15 minutes after the DSL modem turns off. So I waited 15 minutes after unplugging the TP-Link VR200v and then plugged in the HH5A with the new xDSL firmware bin.

Now it's working!

ATU-C Vendor ID:                          
ATU-C System Vendor ID:                   
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.9.0.12.1.7
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.5 (VDSL2 with down- and upstream vectoring)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 0
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 120 / Far: 120
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Fast (0.15 ms) / Up: Interleave (2.0 ms)
Data Rate:                                Down: 51.392 Mb/s / Up: 10.047 Mb/s
Line Attenuation (LATN):                  Down: 13.2dB / Up: 11.3dB
Signal Attenuation (SATN):                Down: 13.2dB / Up: 11.3dB
Noise Margin (SNR):                       Down: 26.5dB / Up: 29.9dB
Aggregate Transmit Power (ACTATP):        Down: 0.6dB / Up: 13.6dB
Max. Attainable Data Rate (ATTNDR):       Down: 126.353 Mb/s / Up: 46.857 Mb/s
Line Uptime Seconds:                      5
Line Uptime:                              5s

#39

Hi @hmartin

Could you please post your complete network config? I'am using openWrt 18.6.1 and had no luck getting a Telekom connection to work :confused:


closed #40

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.