[Solved] Setting up VDSL in Germany with new LEDE box

Hi all,
I recently got interested in running LEDE as we were looking into getting a new router (with support for 5GHz ac WiFi) anyways. Someone suggested looking at the BT HomeHub 5A. I found one on eBay for around 30€ which was already flashed to LEDE Reboot 17.01.4 r3560-79f57e422d when it came.

Now the next step for us is to get the internet connection up and running. As this device has a built-in modem it should be perfect to replace our Fritz!Box 7340. Our current VDSL2 50MBit connection is provided by 1&1 as a reseller of Deutsche Telekom. I've already found out about the connection settings:
screen_20171213_190731
Connection: WAN interface using PPPoE

Through the help of countless threads I managed to put this into /etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda6:5a8a:a66c::/48'

config dsl 'dsl'
	option line_mode 'vdsl'
	option xfer_mode 'ptm'
	option annex 'b'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '00:__:__:__:__:__'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 'auto'
	option password '__________'
	option username 'H1und1/(__________)_____@online.de'
	option _orig_ifname 'ptm0'
	option _orig_bridge 'false'
	option ifname 'ptm0.7'

config device 'wan_dev'
	option name 'ptm0'
	option macaddr '00:__:__:__:__:__'

config atm-bridge 'atm'
	option vci '32'
	option vpi '1'
	option encaps 'llc'
	option payload 'bridged'

However I am not 100% sure if I should set Annex to 'B' or 'J' (FritzBox says B with tone B43)? One thread mentioned annex J for a similar setup with this ISP.

I have connected the cable to the WAN port and rebooted LEDE but it doesn't seem to connect. The line state remains "DOWN [0x200: silent]" and I can't figure out what I am doing wrong

root@LEDE:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:
ATU-C System Vendor ID:
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.7.9.9.0.6
API Version:                              4.17.18.6
XTSE Capabilities:                        , , , , , , ,
Annex:
Line Mode:
Profile:
Line State:                               DOWN [0x200: silent]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 0
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 75 / Far: 74
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L3 - No power
Latency / Interleave Delay:               Down: Fast (0.0 ms) / Up: Fast (0.0 ms)
Data Rate:                                Down: 0 b/s / Up: 0 b/s
Line Attenuation (LATN):                  Down: 0.0dB / Up: 0.0dB
Signal Attenuation (SATN):                Down: 0.0dB / Up: 0.0dB
Noise Margin (SNR):                       Down: 0.0dB / Up: 0.0dB
Aggregate Transmit Power (ACTATP):        Down: 0.0dB / Up: 0.0dB
Max. Attainable Data Rate (ATTNDR):       Down: 0 b/s / Up: 0 b/s
Line Uptime Seconds:                      0
Line Uptime:                              down

Am I missing something? Should I add a firmware config? I can see there are multiple files in the /lib/firmware folder:

root@LEDE:~# ls -la /lib/firmware/
drwxr-xr-x    1 root     root           320 Oct 17 21:44 .
drwxr-xr-x    1 root     root           232 Oct 17 17:46 ..
drwxr-xr-x    1 root     root           248 Oct 17 17:46 ath10k
-rw-r--r--    1 root     root          4096 Oct 17 17:46 ath9k-eeprom-pci-0000:00:0e.0.bin
lrwxrwxrwx    1 root     root            43 Oct 17 17:46 lantiq-vrx200-a-to-b.bspatch -> xcpe_581816_580B11_to_579906_574402.bspatch
lrwxrwxrwx    1 root     root            22 Oct 17 17:46 lantiq-vrx200-a.bin -> xcpe_581816_580B11.bin
-rw-r--r--    1 root     root          1920 Oct 17 17:46 xcpe_581816_580B11.LICENSE
-rw-r--r--    1 root     root        898952 Oct 17 17:46 xcpe_581816_580B11.bin
-rw-r--r--    1 root     root        253635 Oct 17 17:46 xcpe_581816_580B11_to_579906_574402.bspatch

Thanks for helping me get this router online :slight_smile:

Try to reboot the router, keeping the DSL cable in. The VDSL firmware can be only loaded during the boot cycle, so if it failed to load, nothing will help until the next reboot.

UPD: Sorry, I see you already did it. Can you confirm whether your are connected to the DSL socket via 4-pin telephone cable using the gray DSL port of HH5a or to the modem via the Ethernet cable using the red WAN port?

The annex setting doesn't really apply to VDSL connections, so its value doesn't matter here (just be aware that the hardware can't do annex B for ADSL links).

Just to be sure, you did connect the gray "Broadband/ DSL" connector directly to your first TAE (no splitter, no dedicated VDSL modem in front)? The red Broadband/ WAN port is just a simple GBit/s ethernet port and isn't connected to the internal modem (it allows the router to be used with non- ADSL/ VDSL internet connections).

Oh, thanks for saying that. Actually I connected to the red Broadband / WAN port. I tried the gray one but the DSL cable which is connected directly to the telephone socket in our apartment doesn't fit. it's one like this (10m TAE auf RJ45 Kabel für DSL ohne Splitter direkt aus der TAE Dose on eBay)

Do I just need to get a different cable now?

This looks like a Ethernet RJ45 cable, which has to go into the red WAN port. But this also means that the modem is somewhere else. OK, you do not need to look at DSL status and actually you'd better disable the dsl_control for good. The other thing you need to do is to enable the red WAN port (no, it is not enabled by default).

Pick up the wonderful Bill's manual here: https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266
Follow Section 9.2 to enable WAN port and configure PPPoE.
Follow Section 9.9 to disable dsl_control.

1 Like

You need a cable between TAE-6F and RJ11, which is "the other" common variant of xDSL cables, you might be able to nick one temporarily from a landline phone (dedicated xDSL cables are usually better shielded though).

1 Like

okay thanks for your quick replies ! gonna get one of these RJ11 cables and then report back.

thanks for the recommendation about this guide ! I was so lost before without something like this. However with the current issue I think @slh is right that I simply need to get the correct cable and then connect to the gray DSL BROADBAND port of the HomeHub 5A because I don't have a separate modem.

You may be right, but then how the Fritz box managed it without a modem? You can try to connect via WAN port using the cable you have already, and if it fails, you get a DSL cable and try through the DSL port. Good luck.

The Fritz!Box line from AVM is typically an all-in-one device, Modem, Router, Phone PBX/ DECT.

Yes, but if Fritz box was connected via Ethernet port, does not it mean that the modem was effectively unused? WAN port is connected directly to the switch, is it not?

The AVM Fritz!Box doesn't have a port labelled "WAN", you either use the gray "DSL" port (rj45), which obviously is the modem port - or configure the router to use "LAN1" as WAN port (plain ethernet).

http://www.wehavemorefun.de/fbwiki/images/6/65/FRITZ!Box_Fon_WLAN_7340-Bild4.jpg

We probably should ask @disrupted how the Fritz box was connected and it might be possible to connect HH5a in the same way. But getting a DSL cable can be perfectly fine, too.

Don't phone wires in the UK use a plug that is sort of like an RJ11, but isn't?

Yes, telephone sockets in the UK use BS 6305 but you would also need a microfilter which splits the DSL signal and has RJ11 output port for the modem.

For what it is worth, I connected a short RJ11-to-RJ11 cable to the home hun 5A's grey broadband socket, and then carefully inserted that into a RJ45-to-RJ45 passive coupler, to which I attached a grey telekom RJ45-to-TAE cable. While not being theoretically ideal it does work (but I note I live next door to the CO, so I have SNRM to waste...)

Well, talking specifically about the german market (and standards compliant wiring only), there are two options:

  • old style VDSL with a splitter (this is being phased out quite actively)
    here you usually have a rj45 socket on the splitter and need rj11 on the other side for the bt hh5a
  • new splitterless VDSL connections (All-IP, the modern installation type - within the next 2 years all existing setups will probably migrate to this)
    here splitter and NTBA are removed/ missing and you need to connect the VDSL modem (via rj11 in case of the bt hh5a) directly to the first TAE port.

Obviously you can reach your target using adaptors as well, but getting the correct cable is always cleaner and might be cheaper as well (such a cable should be significantly cheaper than 5 EUR).

Depending on the local infrastructure it might be necessary to use a vectoring capable xDSL firmware as well (VDSL with 50 MBit/s is possible with (new) or without (older setups) vectoring, but if your local ISP rolls out vectoring in your cable segment, all modems need to support it (or they use a 16 MBit/s fallback profile)).

[Disclaimer: I haven't used a bt hh5a so far]

1 Like

I can confirm this to work. In my case I connected TAE<->RJ45 to our office cabling bay (CAT-almost-5) and a bog-standard phone RJ11<->RJ11 to the outlet. Basically the cabling worked like @moeller0's passive coupler. HH5A worked like a charm on a German Télèfônicâ VDSL line.

(Now if there were any way to have the HH5A with Annex-B ADSL I'd be a happy Koala, but that's a different topic.)

HH5a is not capable of using Annex B with ADSL. It is a hardware limitation purely due to different resistors, not chips.

I'm aware of that, I'm also willing to mutilate my HH5a, and I know how to handle a soldering iron with only minor injuries. But I really don't want to hijack the thread.