[Solved] Samba4 and Time Machine, cannot select disk

Hi, I made a previous post about AFP Netatalk, but I have removed that package now and am trying Samba4. I cannot find out how to delete my post sorry. I have installed Samba4, enabled MacOS sharing, and added my drive at the bottom of the LuCI page, /mnt/sda1/backups. In my Time Machine pane on OSX I can see 'backups on OpenWRT.local' however I cannot select the disk. I get: 'There was a problem connecting to the server "OpenWrt". The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection and then try again.' Then a message saying: OSStatus Error 64.

What should be my next steps? I cannot reply at the moment as have been barred from replying to anyone, but I will be able to reply in 15 hours. Any help will be greatly appreciated.

The disk, on the mount points page, says UUID: 5f7f8b30-ac1b-409c-b6f5-65c611f10c98
(not present). I don't know if this is relevant.

1 Like

ps says:

4335 root 31964 S /usr/sbin/smbd -F
4336 root 19260 S /usr/sbin/nmbd -F

and OSX says there is a problem connecting to the server. Prior to installing Samba I installed AFP Netatalk, now uninstalled, should I also uninstall Avahi or AvahiUtils? Could avahi service file or daemon be causing a conflict with SMB? I am running Mac OSX 10.15.7 on my main machine, and the latest stable build of OpenWRT. My Mac can find a server called OpenWrt it thinks is a time capsule, but cannot connect to it, that's in Finder. It can also find backups in OpenWrt local in the Time Machine interface, but cannot connect OSStatus error 64 now. The drive is mounted in /mnt/sda1, but may be mounted improperly, how do I check and remount properly?

When I try Finder > Go > Connect to Server > smb:// I get the server unavailable message, check the ip address. It seems I cannot connect to my router as an SMB server. What would be causing this? Also, I cannot find a UUID for the drive in LuCI. Is it not mounted properly? Should I unmount, reformat, and try again?

Should I uninstall avahi and install umdns?

Please, read the quoted part carefully.

I've never used Avahi, but umdns works fine for me, at least for Linux clients.

@vgaetera It definitely has the permissions. I did chmod 777 -R /mnt/sda1 and also chowned it to nobody.

1 Like

@vgaetera Ok so I have uninstalled Avahi and installed umdns. Now the Mac cannot find the disk at all. Am I supposed to do something with umdns? The guide page is very sparse and I do not really understand it.

# OpenWrt
uci get system.@system[0].hostname
netstat -l -n -p | grep -e umdns

# PC
ping hostname.local

@vgaetera Output of netstat:

udp        0      0*                           3848/umdns
udp        0      0*                           3848/umdns
udp        0      0 ff02::fb:5353           :::*                                3848/umdns
udp        0      0 fe80::6038:e0ff:fece:51b0:5353 :::*                                3848/umdns

first command does not work, from my Mac if I ping the hostname I set (haydn_command) in /etc/config/system I get nothing, but if I ping openwrt.local there is success.

1 Like

Weird, post the output:

ubus call system board; uci show system

Output as requested:


"kernel": "4.14.195",

"hostname": "OpenWrt",

"system": "ARMv7 Processor rev 1 (v7l)",

"model": "Linksys WRT32X",

"board_name": "linksys,venom",

"release": {

"distribution": "OpenWrt",

"version": "19.07.4",

"revision": "r11208-ce6496d796",

"target": "mvebu/cortexa9",

"description": "OpenWrt 19.07.4 r11208-ce6496d796"












system.ntp.server='0.openwrt.pool.ntp.org' '1.openwrt.pool.ntp.org' '2.openwrt.pool.ntp.org' '3.openwrt.pool.ntp.org'





system.led_wan.mode='link tx rx'



system.led_usb1.name='USB 1'





system.led_usb2.name='USB 2'



system.led_usb2.port='usb2-port1' 'usb3-port1'


system.led_usb2_ss.name='USB 2 SS'






Underscore is not allowed to be used in the hostname.
And this is a wrong section.

Ok now something strange has happened, I rebooted the router and Samba is now totally uninstalled!

I now get:

Installing samba4-server (4.11.12-1) to root...
Collected errors:
 * check_conflicts_for: The following packages conflict with samba4-server:
 * check_conflicts_for: 	samba36-server * 
 * opkg_install_cmd: Cannot install package samba4-server.

So I cannot now install Samba4 even though I do not have samba36-server installed. There seems to be some serious problem. Should I reflash the device?

Ok well I think there's no resolution to this problem, all my messing about has broken something. I will do a fresh install of the firmware tomorrow.

opkg list-installed samba\*

@vgaetera No output.

1 Like

UPDATE: Fresh flash of firmware, and mounting drive, installing samba4-server from scratch, and I have an accessible drive and NAS storage! So I think it was a conflict with my earlier attempts to install AFP Netatalk and Avahi, which messed with Samba's Avahi settings. All solved now. Thanks for your help, @vgaetera!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.