[Solved] RO filesystem on snapshot builds?

I have an issue with my YouHua WR1200JS (RAMIPS based): uplink port flaps for 2-3 second, maybe I got https://bugs.openwrt.org/index.php?do=details&task_id=1449&string=mt76

I tried OpenWrt 20 snapshot and it seems it works fine and the issue has gone. I want to test more but it looks like the snapshot image has a RO filesystem: config changes and opkg installed packages do not survive a reboot. I tried to google and read the wiki but haven't found the solution.

Could you please help me?

Which file exactly have you flashed?
Anything usefull in the logs?

I flashed https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-youhua_wr1200js-initramfs-kernel.bin

Nothing special in logs. I installed luci and edited /etc/config/network but after a reboot these changes were gone.

You have flashed an initramfs image, therefore it is expected that no changes are saved over a reboot.

Usually you need to install another, permanent image after the initramfs image via sysupgrade.


My bad. I'm sorry for a stupid question. Thank you! I'll try

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.