[Solved] Request help getting ipv6 working again

Please advise me how to fix IPv6 from the wan, which stopped working a few weeks back.

I'm not sure if it is something I did or my ISP. I'm running 18.06.04 on TP-Link C2600, there's no change in behaviour from 18.06.02

From searching previous topics related, here's the starting relevant information. What further information is needed?

ifstatus wan6
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "eth0",
        "data": {

        }
}

Some relevant sections from the system log

daemon.notice netifd: Interface 'wan6' is enabled
daemon.notice netifd: Interface 'wan6' has link connectivity
daemon.notice netifd: Interface 'wan6' is setting up now
daemon.err odhcp6c[xxx]: Failed to send RS (Address not available)
daemon.err odhcp6c[xxx]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)

selected sections from /etc/config/network

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth0'
        option reqaddress 'try'
        option reqprefix 'auto'

config globals 'globals'
        option ula_prefix 'fdxx:xxxx:xxxx::/48'

another piece of information that I've seen requested

ip -6 addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::62e3:27ff:fec8:4a11/64 scope link
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fda6:xxxx:xxxx::1/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::62e3:27ff:fec8:4a10/64 scope link
       valid_lft forever preferred_lft forever

According to Google, this happens when the WAN6 interface doesn't have an IPv6 link-local address:

Some people say it is related to PPPoE misconfiguration, others say that the ISP doesn't support IPv6 properly.

Thank-you for this.

Can anyone suggest a way to work out the specific cause? Or suggest what I should do next?

As far as I can tell, my ISP delivers native Ethernet without PPPoE, via a fibre terminal box.

remove

        option reqaddress 'try'
        option reqprefix 'auto'

then

/etc/init.d/network restart

then wait 30 seconds and

logread | grep odhcp6c | tail -n 10

NOTE: You will want to obfuscate the middle of any valid ipv6 or and of any MACS

In config interface wan6
Try changing
option ifname 'eth0'
to
option ifname '@wan'
//edit
I have the message odhcp6c[4624]: Failed to send RS (Address not available) in my log too.
But ipv6 works fine.
However a few days ago prefix delegation stopped working.

I had this working config:

config interface 'modem'
	option ifname 'wan'
	option proto 'static'
	option ipaddr '192.168.0.2'
	option netmask '255.255.255.252'
	option metric '100'
	option mtu '1500'

config interface 'wan'
	option ifname 'wan'
	option proto 'dhcp'
	option peerdns '0'
	option broadcast '1'
	option sendopts 'lease:86400'

config interface 'wan6'
	option ifname 'wan'
	option proto 'dhcpv6'
	option peerdns '0'
	option iface_dslite '0'
	option noserverunicast '1'
	option reqaddress 'try'
	option reqprefix 'auto'

I changed my config to:

config interface 'modem'
	option ifname 'wan'
	option proto 'static'
	option ipaddr '192.168.0.2'
	option netmask '255.255.255.252'
	option force_link '0'
	option metric '100'
	option mtu '1500'

config interface 'wan'
	option ifname '@modem'
	option proto 'dhcp'
	option peerdns '0'
	option broadcast '1'
	option sendopts 'lease:86400'

config interface 'wan6'
	option ifname '@modem'
	option proto 'dhcpv6'
	option peerdns '0'
	option iface_dslite '0'
	option noserverunicast '1'
	option reqaddress 'try'
	option reqprefix 'auto'

And prefix delegation works again.
Maybe it has to do in which order the interfaces are brought up.
Or because the modem interface has static IP configuration and therefore defaults to force_link 1?
(and some things are not triggered because of that?)
The message: Failed to send RS (Address not available) maybe appears because odhcp6c is started too early.

I tried several variations on the advice from @shm0 and @anon50098793 with no change. I'm assuming that my ISP has a fault or stopped IPv6 service - will try to find some route to report this to them

now working, was an issue with the fibre terminal box supplied by my ISP. They reset it remotely and IPv6 started working. Thank you for the assistance

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.