[SOLVED] RB133 boot issue


I am new to LEDE/OpenWRT and me and my colegues found it interesting for use in our remote service routers. (Open source, custimizable, more-less HW/wendor independent...)

To start somehow, I took old Routerboard RB133, which is more less useless in todays standards (slow CPU, only 100MBit ports...) to use it as test device to look thru basic options. Nobody cares if it gets bricked, burned, tossed out of thew window in anger, etc in the proces. Later we will switch to something more powerfull.

I started going thru this manual:
and while it is missing some info i also looked thru here:
and build manual and serching some more in OpenWRT wiki...

And I got stuck.

As I understand I have RB with clean NAND (so RouterOS and Licences are no more) and bootloader works fine, takes DHCP, and boots images downloaded using TFTP. When I load any elf file for ADM5120 I can find in downloads of LEDE or OpenWRT, or even what I have built myself, I get into kernel panic with init missing or reboot loop with I guess similar issue showing for just split seccond before reboot.
Only difference is, if I try to load intramfs elf file from my built binaries. This ends with kernel too big even before trying to boot it.

Does anybody know, please, how to resolve this and advance to at least bit working system?


Vit Soucek

OK, so i searched even more, and i found this:


What means "subtarget marked as broken" ? And how can I use anything that is there on git?
Does it mean I'm just wasting my time, while OpenWRT will never work with RB133?


Vit Soucek

Well I found first mistake and directly get into next one.

First, switching on compression for ramfs helped quite a lot. So i can get into running openwrt from ramdisk.

But it is missing mtd2 and mtd3 blocks. So i am unable to mount and load firmware...

Any thoughts? Anybody?

I guess it is missing something in menuconfig


The ELF is read only. The BIN file is used to flash a permanent R/W copy of OpenWRT to the device.


Ah OK.
I get the point the RAM is quite the issue, while HW I'd like to play with is quite old, forgotten and obsolete...
So the way is to take older version, compile it, while pre-compiled elf image one can download does not come with init and then it might work... or I should stop playing with old junk...

you can compile by yourself removing as much as possible. I have nanostaion working with 16MB ram but only as AP - no iptables no LUCI but with collected for statistics - send to remote server (internal collected functionality from 5.7)

Well I'm not sure how much am I able to test on this basic system then. Iptables for example are for sure needed. But whatever If I make it just AP, would be OK for very beginning, just to get in touch with how to make OpenWRT alive.

Anyway, I still have problem making mountable mtd2 and mtd3 blocks in /dev. So I can't load firmware image in anyway...

So maybe first try older builds:

Hi :slight_smile:
A moment ago, I also tried run Openwrt on routerboard 133, with success. I followed instructions on https://blog.jfmcorp.org/tag/rb133/ with only one change - I cloned repository with Openwrt version 15.05 https://github.com/openwrt/chaos_calmer.git and builded image

You can build your own image, or download my image which I currently have builded

root@OpenWrt:/# uname -a
Linux OpenWrt 3.18.98 #1 Sun May 20 04:02:48 CEST 2018 mips GNU/Linux
root@OpenWrt:/# dmesg
[ 0.000000] Linux version 3.18.98 (taczanowski@taczanowski) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r49630) ) #1 Sun May 20 04:02:48 CEST 2018
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 0001800b (MIPS 4Kc)
[ 0.000000] SoC : ADM5120 rev 8, running at 175.000 MHz
[ 0.000000] Bootdev : NAND flash
[ 0.000000] Prom : RouterBOOT
[ 0.000000] Determined physical RAM map:

[ 0.084000] MIPS: machine is Mikrotik RouterBOARD 133


Now I tried to build Openwrt 17.01-SNAPSHOT in the same way as the previous image, and this is also working on my rb133 :smiley:

Bellow my image (included Luci, OpenVPN and Strongswan)

Wow! Thanks a lot! I will try your images, If we miss some functionalities or have too little space to work with, we will do some modifications.

I'm still wondering what mistakes did I do. I will compare blog you posted with OpenWRT wiki.

Vit Soucek

OK So i got a bit overexcited.

Can anyone please supply me working elf image with initramfs?

I'm having trouble building one which has all four mtd blocks in /dev after booting.
In older builds and bulds supplied by jtaczanowski, there is no init, while these are images to be used as final image and not ad bootable firmware to set everything up.


Vit Soucek

I booted my rb133 from network with old image http://wifi.ozo.com/airo/openwrt/firmware/kamikaze/2.6/adm5120/latest/openwrt-adm5120-2.6-vmlinux.elf
From this image I was able to mount /dev/mtdblock2 and /dev/mtdblock3.
On /dev/mtdblock2 I puted https://taczanowski.net/download/openwrt/rb133/lede-adm5120-rb1xx-vmlinux.elf as kernel and on /dev/mtdblock3 I extracted https://taczanowski.net/download/openwrt/rb133/lede-adm5120-rb1xx-routerboard-rootfs.tar.gz

mount /dev/mtdblock2 /mnt; cd /mnt

wget http://yourserver/kernel (https://taczanowski.net/download/openwrt/rb133/lede-adm5120-rb1xx-vmlinux.elf)

cd /; umount /mnt; mount /dev/mtdblock3 /mnt; cd /mnt

wget http://yourserver/lede-adm5120-rb1xx-routerboard-rootfs.tar.gz (https://taczanowski.net/download/openwrt/rb133/lede-adm5120-rb1xx-routerboard-rootfs.tar.gz)

gzip -d lede-adm5120-rb1xx-routerboard-rootfs.tar.gz; tar xvf lede-adm5120-rb1xx-routerboard-rootfs.tar; rm lede-adm5120-rb1xx-routerboard-rootfs.tar; cd /; umount /mnt; sync; reboot

After that I was able to boot openwrt 17.01 from nand :slight_smile:

Another good description of this proces is here https://www.noisebridge.net/wiki/RouterBOARD_133


Thanks everybody for support!

Hello Jan,
can You upload the last working .config?
My config does not work somehow...

Hi @x15

This is my config for lede-17.01 shapshot
(only with configured target for rb133 and luci)

I compiled image after switch to lede-17.01 branch:

git clone git://github.com/openwrt/openwrt.git
cd openwrt
git checkout origin/lede-17.01
./scripts/feeds update -a
./scripts/feeds install -a
wget https://taczanowski.net/download/openwrt/rb133/.config
make -j 2

Hello Jan,

Thank You! I'll test it at Monday.
I have a 3Com 10/100 LAN card and I'd compile a module for it.