[SOLVED] Problems with Adblock usage

Hi. I recently found out about custom firmwares for routers and I decided on using LEDE. So I flashed it without any problem, configured to my liking and then proceeded to use Adblock. I found this adblocker and decided to use it.

What I did to get it working:

  1. Install adblock and luci-app-adblock from software tab in router config
  2. Configured adblock in Services -> Adblock tab (checked adaway, adguard, disconned, reg_pl and yoyo)
  3. Saved, rebooted router and checked how it looked on my phone aaaand it's not working.

This is how my settings page looks like now, I want to get any help configuring it, I checked wiki on github and it looks like something is wrong on my end.

Oh, and initially I thought that it was because my sources didn't include some pages, but I have uBlock Origin on PC, Adaway on Android phone and I wanted to use router-based solution for iPhone, so I picked some site from adaway hosts list and checked if it works on every device of mine and:
uBlock blocked it, but if I disabled it I could load it
iPhone loaded it
Android blocked site
So I think it's problem with my router (or config as I'm a total noob in network configuration)

My router is TP-Link WR740N v4 and firmware is LEDE Reboot 17.01.2

Thanks for any help!

Yes ... :wink:
Two observations from your screenshot:

  • You have disabled all startup trigger, please add at least 'wan' as interface trigger.

  • You have no ssl library installed, therefore adblock can't download any lists from ssl sites. Install the package 'libustream-mbedtls' to fix this.

Hope this helps!

1 Like

Okay, so I proceeded to install it, but even after restoring defaults I only had ~50% (208KB) free space and after installation of this package it was like 11% so I couldn't install adblock.
So, do you have something more lightweight than this? I spend some time googling but couldn't really find anything. At the moment I have 172KB free space.

At the moment I changed interface trigger to wlan0 (my Wi-Fi), checked "blacklist" as source and pasted everything from adaway host list and it appears to be working, but I would prefer it to be automatic.

Oh, and adblock is not starting automatically after reboot, it appears like this
//Solved autostart with setting triggers to wlan0 and lan, I'm not sure how it works

If you can't install a ssl library you can only use the non-ssl sources (check the "SSL req." column). I doubt that 'wlan0' is a valid network interface (normally it's bound to hostapd). For a list of valid network interfaces type ...
ubus list | grep 'network.interface.'
... and take one of them ...

Okay, and one quick last question - is it possible for it to only work on certain device or only on wireless network? I would prefer it that way.

yes, you can define adblock exemptions see here

Everything works perfectly, thanks for help!

Hey I just installed lede but can not find the adblock menu anywhere. I have definitely installed it but can not find any settings for it. I'm on Linksys 3200

Thank you

Don't worry I worked it out

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.