[SOLVED] Problem cascading routers

Hi to all, it's a month now I have met with Lede/Openwrt and experimenting with various routers I find from friends or buying cheap. (rt-ac51u, wrt160nl,wrt1900acs)
A week ago I decided to get a nice 'n capable router to replace my rt-ac68(tomato). After a research I found the Linksys wrt1900acs would be ok and supported by Lede project and finally got one. But what a nightmare with Lede official builds....
Iam trying to set it up in front of 2 other routers but no way. Davidc502 build on this router(wrt1900acs), snapshot build for rt-ac51u and official build for wrt160nl, all are working fine under these settings but Lede official no way.
My home diagram must be looking like this and the Linksys wrt1900acs is the


For some reasong it doesn't get an ip from the router.
Luci settings are these, the same are working under all routers I mentioned before but not with wrt1900acs with official Lede. What is going on;


How would the device get a DHCP-issued WAN IP from, when you have it set for Static IP?

Do you have a good reason for utilizing a triple NAT setup like that? If not, you should:

  1. Only run a DHCP server on the lan bridge on the first router that is directly connected to the internet
  2. Connect router 2 & 3 to the previous router in line via the LAN ports, not the WAN ports (Or delete the wan interface, and bridge them together with the rest of the LAN).
  3. Make sure you change the static IP address protocol on router 2 & 3 to the DHCP client protocol (do that before hooking them up, or you might run into IP address conflicts)

This way, router 2 & 3 will function as a dump AP/switch and you will not utilize triple NAT.

Yes, as @Mushoz suggests, if you don't need those separate subnets, you might consider a "Dumb Access Point". There's a pretty good guide at https://openwrt.org/docs/guide-user/network/wifi/dumbap

I use this here. I use an Ethernet cable to connect the LAN port of my main router to the LAN port of the dumb AP, configured as described above. (In fact, I have two dumb AP's, connected LAN-to-LAN with the main router.)

Well I should have told I don't have access to router, iam renting a house and is landlords router who passed me a cable from his lan port to my apartment. How this new parameter changes things;
As for why I utilize this setup from lan to wan, I don't know...there is no reason.

If all your devices are connected by wire (and you landlord does not restrict the number of devices connected to his router), I would just bridge LAN and WAN ports or both routers, and have them all live in the same network. You could have separate networks on the middle router, if you want to isolate your network from the landlord's network; but the last router should not have separate networks.

Search for the "dumb AP" recipe, and apply it to the third router.

You do know...the poster could solve the problem in the OP...by changing the WAN back to DHCP???

This would fix the specific problem in the OP:

First of all thank you all for your time and efforts to help. Secondly, I will check and test each thing you propose me posting here my findings.

Hi! My findings to this are really strange.
Indeed setting the 3rd routers WAN to DHCP and LAN to is working, I can reach the router from a device set to ifconfig 192.168.3.* , and this router can reach the internet, I connect my mobile to it and I have internet on my mobile.....
but....when I take out and insert back the power cable of this 3rd router then it stops reaching the internet, I can access it from my local lan though.
This does not happen if I reboot or if I switch it off from the switch(but keeping the power cable in place).
In any case if I take out and reinsert the power cable then the internet is not reachable any more via this router, I tried both taking out the power cable before and after switching off the router from the power switch.

Some screenshots from LAN/WAN settings are following.

Iam really interested to find why is this happening (with the power cable I mean) and also I like the idea of the 3rd subnet. But as I told before Iam experimenting, learning.....

I will try to set it up in another way as people here say now but Iam really flexible to revert back if you or other have any suggestions about this lan->wan setup.


I notice you overrided the MAC on WAN (or obscured it)...does it match another device on router 1 or 2?

Nah, just painted on top of the fields example, there is a random mac addr.

I managed to set it up like a dumb AP ok, a question would be how is possible to make the lan ports usable;

Also tested with taking out and back the power cable, things are working again after booting(read more about this 2-3 posts before)

The LAN ports are probably acting like a normal Ethernet switch. If you plug in a device that supports DHCP, it should try to get an address and your landlord's DHCP server.

On "random mac addr", make sure its a valid unicast MAC address, not a multicast or reserved address.

Another clue about using this 3rd router Wan DHCP and Lan is that after taking out and back in the power cable, it doesn't keep the correct time. It keeps the correct time zone Europe/Oslo but the time is out Fri Jun 26 12:55:26 2037. I applied again timezone countery but time/date is not going to today

EDIT: this is wrong, it did apply the new time

On your dumb AP, go to the switch configuration and move the WAN port from VLAN 2 to VLAN 1. All of the Ethernet ports should be only in VLAN 1, and untagged. This makes all five ports work the same, use any one of them for the cable from the other router, and the other four can connect LAN devices.

You can delete VLAN 2 and the WAN network, or leave them in place but not use them.

I got it sorted out with this not working wan interface after hard restart. Workaround is to to unplug and replug back the data cable. Tomorrow will try to set it up as dumb ap again with usable ports. Thank you all, tomorrow again, Iam so tired.

Indeed. Ports are acting as eth switch. I should have complained to my laptop /etc/network/interfaces file.

Yes, it's like that all the switch conf page, thank you also for mentioning

Finally I have reached not one but 2 sollutions from your help.
One can setup Linksys WRT1900ACS being the double or triple NAT.
Problem is 1900ACS will not connect to the internet after removing and putting back the power cable.
Solution/workaround (for me at least) is to unplug and replug data cable when device is fully booted.

Also Dumb AP is ok depending on needs of course.

Thank you all :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.