[Solved] PPPoE Server (how to create?)

Hello.
I'm trying to create a PPPoE server and got tired of no sucess.
Using OpenWrt 19.07.3 r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-20.136.49537-fb2f363

I installed luci-app-rp-pppoe-server and configured using Luci.
Also tried with command

pppoe-server -C serverPPPoE -L 192.168.1.198 -R 191.168.1.199 -I eth0.1 -d -N 2 -k

Had popullated pap-secrets (also tried chap-secrets), edited pppoe-server-options. Still nothing.

I notice a recent change on PPPoE Server's Luci. But still no sucess. And i cannot find a "recipe" for doing this. Also do not get a "verbose" mode so see what is going on.

Any ideas?
Thank's a lot.

You just need to set the relevant parameters on the luci-app-rp-pppoe interface and set forwarding on the firewall.
RP PPPoE has a bug: network interface must be selected: lan, do not use the default br-lan interface.
Please modify in the following path or use the command mode to modify

pppoe server path /etc/config/pppoe

Command mode modification:

uci set pppoe.@pppoe_server[0].interface='lan'
uci commit pppoe
reboot

Thank you. Firt post. Welcome. What a privilege to me.

I didn't know about this bug. Is this about the "name" or the interface itself? I had tried eth0.1, not the br-lan but didn't work. I have no "LAN" interface:

    cat /etc/config/network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'

    config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'dhcp'
    option delegate '0'

    config device 'lan_eth0_1_dev'
    option name 'eth0.1'
    option macaddr 'xxxxxxxx'

    config interface 'wan'
    option ifname 'eth0.2'
    option proto 'pppoe'
    option password 'xxxxx'
    option ipv6 'auto'
    option username 'xxxxx'
    option auto '0'

    config device 'wan_eth0_2_dev'
    option name 'eth0.2'
    option macaddr 'xxxxxx'

    config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'
    option reqprefix 'auto'
    option reqaddress 'try'
    option auto '0'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 6t'

    config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0 6t'

No "LAN" is listed. Should i create one?

image

I found this at man:
-I interface
The -I option specifies the Ethernet interface to use. Under Linux, it is typically eth0 or eth1. The interface should be "up" before you start pppoe-server, but should not be configured to have an IP address. You can supply multiple -I options if you want the server to respond on more than one interface.

So, i believe i had to create a interface and leave "unmanaged", but it didn't work.

I'm sorry, the translation error! Now post my configuration.
pppoe server path /etc/config/pppoe

pppoe.@pppoe_server[0]=pppoe_server
pppoe.@pppoe_server[0].interface='lan'
pppoe.@pppoe_server[0].ac_name='access-concentrator-name'
pppoe.@pppoe_server[0].service_name='service-name'
pppoe.@pppoe_server[0].maxsessionsperpeer='1'
pppoe.@pppoe_server[0].localip='192.168.2.1'
pppoe.@pppoe_server[0].firstremoteip='192.168.2.2'
pppoe.@pppoe_server[0].maxsessions='254'
pppoe.@pppoe_server[0].optionsfile='/etc/ppp/pppoe-server-options'
pppoe.@pppoe_server[0].randomsessions='1'
pppoe.@pppoe_server[0].unit='0'
pppoe.@pppoe_server[0].offset='0'
pppoe.@pppoe_server[0].timeout='60'
pppoe.@pppoe_server[0].mss='1468'
pppoe.@pppoe_server[0].sync='0'

pppoe.@pppoe_server[0].interface='lan'
Notice and use this code,Save restart router

1 Like

Thank you. Solved. I could never imagine i should change the name to a diferent one listed on Luci. But that was the solution.

I also had to change from pap-secrets to chap-secrets.

#cat /etc/config/pppoe
config pppoe_server
        option maxsessions '64'
        option optionsfile '/etc/ppp/pppoe-server-options'
        option unit '0'
        option offset '0'
        option timeout '60'
        option mss '1468'
        option interface 'lan'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.