[SOLVED] Possibly bricked TP-LINK WDR4300 - Help!

Hi all,

Today I decided to try upgrading to LEDE from the latest OpenWrt build on my WDR4300. Flashed the sysupgrade.bin from OpenWrt, and it seemed to work okay, I was able to login to LuCI and it had a LEDE header. However, I tried restoring my backed up config from OpenWrt, and everything broke. Actually, it's really strange, because my network is still broadcasting, and I'm able to connect (no internet access thought), and the lights on the router are flashing normally. However I'm unable to pull up the web interface for the router and I can't ssh in.

I managed to boot the router into failsafe mode, but I still can't ssh in even though I set my computer's IP to (I get a 'no route to host' error). I also tried setting up a TFTP server and set my IP to, but it seems like when I boot with the reset button pressed, the router isn't even trying to access the TFTP server, because nothing happens.

Pretty stuck here, not sure what my next steps are. Can anyone here offer any help?

See the instructions here...


Followed those instructions in Windows, was unable to get any logs to show in the log viewer when I turn on the router with the reset button pressed (the circle arrows icon lights up when I do this).

I've also tried using tftpd on Linux and it just seems like my router isn't trying to request anything at all when I turn it on with the reset button pressed. Nothing happens, and I'm pretty sure I have all the network settings correct. Not sure why it isn't working :frowning:


While in failsafe mode, are you using an ethernet cable and not the WiFi to connect? With that cable, did you try all the ports, including the WAN port? If you ping you get also the "no route to host" error I presume?

Finally managed to fix it!

For some reason, flashing the LEDE firmware via TFTP wouldn't work. So instead, I flashed the stock TP-LINK firmware, and that worked. Then I installed the LEDE firmware from the TP-LINK web interface, and reconfigured everything manually. Good to go!

Thanks for the help @jwoods and @DjiPi !!

Glad that you got back on tracks! Whenever you want, feel free to mark your issue as solved.