[Solved] Port forward not working


I'm using OpenWRT 21.02 and using Transmission bittorent client. My downloads are stored on the hdd connected to the router. I tried to port forward on port 51413 but I could not manage to forward it. The port still appears to be closed.

Can you support me on this?
I think I got a Private IP, but I'm not sure. I'm not overly an expert in these matters. I am sharing the ss of the WAN interface.
Is there any other information you would like to see so you can comment?

Thanks a lot,

Your IP seems to be in a range from to - so yes, it appears your IP is not Public, see: https://en.m.wikipedia.org/wiki/Carrier-grade_NAT

You'll need a Public IPv4 to successfully Port Forward.

If you have IPv6, you should be able to make a Traffic Rule to allow that.


I didn't know that, thank you. I am using the modem provided by ISP in bridge mode. I don't understand why I can't get a public IP.
I'm sharing the WAN6 interface, I think you were talking about that right? but I don't know which traffic rule to create next.


Because it appears your ISP doesn't issue you a Public IPv4 address. This is out of your control, regardless of how the OpenWrt connects to an ISP's demarcation. That's described in the Wikipedia link.

Your wording wasn't clear, nonetheless it doesn't appear you're being issued IPv6 addresses, so my suggestion to allow the traffic on IPv6 is a no go.


Thank you very much. I will contact my ISP about this issue.

Have a nice day.

1 Like


I think now I got the public IP.

My firewall port forward rule is like this:

I want to port forward on port 51413.
In fact, when I look at the settings of the transmission package, it is written that port 51413 is already port forwarded. However when I check it, the port seems to be closed.
Can you help in this situation?

Is anything listening on 51413? If the port is forwarded, but there's nothing there to listen, it will still appear closed.

In addition, the "open/closed" tests usually apply to TCP, not UDP, so trying to determine the "open" state of a UDP port will prove challenging. Does Transmission use TCP or UDP?

You may be better off examining the host at to see if inbound connectivity is happening. Wireshark and/or tcpdump may be useful here.

1 Like

Then why do you have port 51413 forwarded to an internal host? Where is the Transmission client running? Is it running on the router, or is it running on

1 Like

Transmission client is running on the router. I had always port forwarded to the internal host before. Now, I realized it when you said it but I don't know which IP address to use for the transmission running on the router.

If it's running directly on the router - and it shouldn't, but that's a separate discussion entirely - then you don't need any port forwarding. Just create a traffic rule instead.


I had created this rule before I read what you wrote and the port seems to be open.
How can I create a traffic rule? Which method would be the best method?


please delete this forward rule, because Transmission is running (if i get it right) on router itself, so, there is no need for forward, you need: traffic rule for input

firewall -> traffic rules -> add


Thank you, I have configured it as you suggested.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.