[solved] Partly bricked D-Link DGS-1210-16 (serial access is broken, but OpenWrt can be accessed via LAN; reboot is broken too)

I had flashed the master snapshot build from 5th December a few days ago and there is only one LAN vlan now in the build and also the port1 issue seems to be resolved.
Unfortunately I wanted to factory reset it earlier.
Then it did not save any changes any more (maybe I did not wait long enough).
Then i tried umount /overlay && jffs2reset && reboot.
Then it did not reboot any more.
So I hard shut it off a few times and let it boot again and try to do a normal reboot from the serial console.
Eventually the serial stopped showing anything. So currently neither the u-boot nor the OpenWrt boot or OpenWrt access are possible via serial.
However I am able to access the switch via LAN at the moment. It also keeps changes I make to the settings.
I can't perform a reboot from there either. The power LED just starts blinking very fast and I have to restart with power off/on. I have a manual IP on my network adapter on the laptop and set it to auto connect, but it is not able to bring up the network interface in that state at all.
So a sysupgrade did not work that way either.
IO first thought u-boot would be broken (because of the serial access that is broken), but then it should not boot into anything at all. Right?

Does anyone have an idea, on how I could re flash the OpenWrt image? Or is the serial access part not even in OpenWrt and another partition is broken? Just let me know in case you want me to get some more info from the device.
Thanks in advance.

note: rebooting had worked a few days ago after I had flashed the snapshot

This sounds like the SoC hanging on reboot, because fast blinking is the standard setting for the system LED. With the latest snapshots, the watchdog driver is now used to reboot the system. Other DGS-1210 devices require gpio-restart using GPIO 34 on the RTL8231 to properly restart the system, so my first guess would be that this is also the case here.

Thanks svanheule. Do you have an idea, how can I adress these GPIO lanes? I can at leats not see any GPIO PINs here: https://openwrt.org/_detail/media/dlink/dgs-1210/dgs-1210-16_g1_pcb.jpg?id=toh%3Ad-link%3Adgs-1210-16_g1
Or is there a possibility to address these lanes from within OpenWrt?

I am really sorry and I should have read the Support for RTL838x based managed switches thread before flashing the newest snapshot. I just didn't think it could end that bad when flashing snapshot master. After a few month, where I did not really have the time to come back to the switch, I just wanted to see if there is progress with the port1 issue, I had in 21.02 and a master snapshot from mid May. May this be the lesson to learn.

Okay, I have good news.
I could flash 21.02.1 though it could not reboot, but after cutting power I had 21.02.1 on it, but for a strange reason I still had the old config from the snapshot (maybe because of the reboot not working).
I then did firstboot && reboot now, which successfully executed a factory reset and a reboot.

The serial problem seems to have been an independent issue. It started working again, but I had it again not working today. After rebooting the switch and cutting power to the serial adapter it worked again.
So I am wondering, if there is a general issue with the serial not always working reliably, or if it might my serial adapter causing these issues. I had the issue just some minutes ago, where it came back after cutting the serial adapters power, so it might be the latter.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.