[Solved] Openwrt WDS mode + DAWN Questions

I've got a build that is running Openwrt Snapshot + LuCI SSL + DAWN (and I believe I have included all the relevant packages). I've build the squashfs images for r7800 and tplink archer a7 v5. I can confirm that WDS mode is working and I have things working in general but not quite as I'd like.

Build diffconfig file (TP-Link Archer A7 v5):

> CONFIG_TARGET_ath79=y
> CONFIG_TARGET_ath79_generic=y
> CONFIG_TARGET_ath79_generic_DEVICE_tplink_archer-a7-v5=y
> CONFIG_BUSYBOX_CUSTOM=y
> CONFIG_BUSYBOX_CONFIG_DIFF=y
> CONFIG_BUSYBOX_CONFIG_ED=y
> CONFIG_BUSYBOX_CONFIG_FEATURE_DIFF_DIR=y
> CONFIG_BUSYBOX_CONFIG_FEATURE_DIFF_LONG_OPTIONS=y
> CONFIG_BUSYBOX_CONFIG_FEATURE_VI_UNDO=y
> CONFIG_BUSYBOX_CONFIG_FEATURE_VI_UNDO_QUEUE=y
> CONFIG_BUSYBOX_CONFIG_FEATURE_VI_UNDO_QUEUE_MAX=32
> CONFIG_BUSYBOX_CONFIG_PATCH=y
> CONFIG_BUSYBOX_CONFIG_PKILL=y
> CONFIG_BUSYBOX_CONFIG_WHOAMI=y
> CONFIG_PACKAGE_arp-scan=y
> CONFIG_PACKAGE_arp-scan-database=y
> # CONFIG_PACKAGE_ath10k-firmware-qca988x-ct is not set
> CONFIG_PACKAGE_ath10k-firmware-qca988x-ct-full-htt=y
> CONFIG_PACKAGE_block-mount=y
> CONFIG_PACKAGE_cgi-io=y
> CONFIG_PACKAGE_dawn=y
> CONFIG_PACKAGE_ddns-scripts=y
> CONFIG_PACKAGE_ddns-scripts-services=y
> # CONFIG_PACKAGE_iw is not set
> CONFIG_PACKAGE_iw-full=y
> CONFIG_PACKAGE_libcap-ng=y
> CONFIG_PACKAGE_libgcrypt=y
> CONFIG_PACKAGE_libgpg-error=y
> CONFIG_PACKAGE_libiwinfo-lua=y
> CONFIG_PACKAGE_liblua=y
> CONFIG_PACKAGE_liblucihttp=y
> CONFIG_PACKAGE_liblucihttp-lua=y
> CONFIG_PACKAGE_libpcap=y
> CONFIG_PACKAGE_librt=y
> CONFIG_PACKAGE_libubus-lua=y
> CONFIG_PACKAGE_libuuid=y
> CONFIG_PACKAGE_lua=y
> CONFIG_PACKAGE_luci=y
> CONFIG_PACKAGE_luci-app-dawn=y
> CONFIG_PACKAGE_luci-app-ddns=y
> CONFIG_PACKAGE_luci-app-diag-core=y
> CONFIG_PACKAGE_luci-app-firewall=y
> CONFIG_PACKAGE_luci-app-ntpc=y
> CONFIG_PACKAGE_luci-app-opkg=y
> CONFIG_PACKAGE_luci-app-upnp=y
> CONFIG_PACKAGE_luci-base=y
> CONFIG_PACKAGE_luci-compat=y
> CONFIG_PACKAGE_luci-lib-base=y
> CONFIG_PACKAGE_luci-lib-ip=y
> CONFIG_PACKAGE_luci-lib-ipkg=y
> CONFIG_PACKAGE_luci-lib-json=y
> CONFIG_PACKAGE_luci-lib-jsonc=y
> CONFIG_PACKAGE_luci-lib-nixio=y
> CONFIG_PACKAGE_luci-mod-admin-full=y
> CONFIG_PACKAGE_luci-mod-network=y
> CONFIG_PACKAGE_luci-mod-status=y
> CONFIG_PACKAGE_luci-mod-system=y
> CONFIG_PACKAGE_luci-proto-ipv6=y
> CONFIG_PACKAGE_luci-proto-ppp=y
> CONFIG_PACKAGE_luci-proto-relay=y
> CONFIG_PACKAGE_luci-ssl=y
> CONFIG_PACKAGE_luci-theme-bootstrap=y
> CONFIG_PACKAGE_luci-theme-material=y
> CONFIG_PACKAGE_luci-theme-openwrt=y
> CONFIG_PACKAGE_luci-theme-openwrt-2020=y
> CONFIG_PACKAGE_miniupnpd=y
> CONFIG_PACKAGE_ntpclient=y
> CONFIG_PACKAGE_px5g-wolfssl=y
> CONFIG_PACKAGE_relayd=y
> CONFIG_PACKAGE_rpcd=y
> CONFIG_PACKAGE_rpcd-mod-file=y
> CONFIG_PACKAGE_rpcd-mod-iwinfo=y
> CONFIG_PACKAGE_rpcd-mod-luci=y
> CONFIG_PACKAGE_rpcd-mod-rrdns=y
> CONFIG_PACKAGE_uhttpd=y
> CONFIG_PACKAGE_uhttpd-mod-ubus=y
> CONFIG_PACKAGE_umdns=y
> CONFIG_PACKAGE_wireless-tools=y
> # CONFIG_PACKAGE_wpad-basic-wolfssl is not set
> CONFIG_PACKAGE_wpad-wolfssl=y

I've got two Archer A7 devices. My Setup:
Fiber ONT <-CAT6-> TPLink A7 #1<< Wireless/WDS Setup >> TPLink A7 #2
TPLink A7 #1: Main Router + AP (2.4 GHz and 5GHz have different SSIDs with WDS AP enabled, along with 802.11k/v/r all enabled for DAWN), on 2nd floor (1st floor for those outside of USA)
TPLink A7 #2: Wireless Repeater (Static IP on LAN, firewall/dhcp/dnsmasq disabled, WDS Station on 5GHz channel, advertising same SSIDs as above), on 1st floor (Ground floor for those outside of USA)

My walls are sheetrock on wooden beams and floor separation is wood based so I'm not losing a lot of signal (as opposed to a house with concrete walls and floors)

The use case where a WiFi client is stationary is not of any concern. It receives IP and stays connected to the AP which it was originally connected.

Concern 1:
When a client connects to main AP while being on the 2nd floor, but then moves to the 1st floor while being on a VOIP call, I am not seeing the wifi client attach to the Wifi Network through the dumb WDS AP. Infact, if I am on a VOIP call through the iPhone SE, moving to the first floor will guarantee I will get kicked off WiFi as it loses connectivity to the AP upstairs. Some WiFi clients stay connected to the upstairs AP no matter how far they go (OnePlus6 stay connected much further than the iPhone SE).
In fact, in general, what I have observed is that if a client was initially connected to the main AP, attempting to connect to the dumb AP in quick succession fails and leaves the device without an IP address. This continues on for several minutes (about 4-8 minutes).
The only way I've had a previously attached WiFi client successfully join the network through the DumbAP is to turn of the client's WiFi radio for a few minutes and turn it back on. This completely defeats the purpose of having either WDS with or without DAWN. This behavior was apparent with and without DAWN, so in my opinion DAWN didn't help at all. I have a plethora of wifi devices for the same situation is occurring:

OnePlus6
OnePlus8T
Iphone11Promax
Iphone12
Galaxy Tab s7+
iPad
Galaxy Note8

Bottom line is that with or without DAWN, I am unable to freely move a wifi client between APs. What is the issue here in my setup ?

Concern2:
The DAWN module seems to be working but what I find to be odd is that I needed to reset the router even after flashing OpenWrt factory image in order for the Hearing Map to populate. It was showing no values until I reset the router and then performed the setup once again...
Furthermore, on the Main AP, Dawn module reports false for HT Sup and VHT for ALL devices. The DumbAP is showing True for many of the same values.

Here is the Hearing Map from the Router+AP:

Hearing Map from the Dumb AP in WDS mode:

Is there a problem here?

Concern3:
I am also seeing that while connected to either of the APs (main router or dumb ab), OnePlus devices are sending a lot of text or perhaps garbage data (see below) in BEACON-RESP-RX messages. Is this normal or a bug in DAWN or in the client device itself ?

Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-REQ-TX-STATUS 46:36:27:46:36:27 36 ack=1
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-REQ-TX-STATUS fa:74:b5:fa:74:b5 41 ack=1
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX 46:36:27:46:36:27 36 04
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-REQ-TX-STATUS 72:be:f7:72:be:f7 38 ack=1
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00010000000000000000000002e50050d4f7feac170012dbc90001b88041aa881400000064003114000346424901088c129824b048606c0301010504010200000706555320010b1e2a010030180100000fac040100000fac040200000fac02000fac040c000b0500005b0000460572000000003603d353013b0253002d1aee111bffffff00000000000000000001000000000000000000003d16010500000000000000000000000000000000000000007f080400080200000140dd180050f2020101810003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00010000000000000000000002c40050d4f7027fea0013dbc90001b83142f3611500000064003114000346424901088c129824b048606c0301010504010200000706555320010b1e2a010030180100000fac040100000fac040200000fac02000fac040c000b050400580000460572000000003603d353013b0253002d1aee111bffffff00000000000000000001000000000000000000003d16010516000000000000000000000000000000000000007f080400080200000140dd180050f2020101810003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00010000000000000000000002ae00f08175fd14060011dbc90001c18c5198c709000000640011140010537065637472756d53657475702d3030010882848b962430486c0301010504000100002a010032040c12186030140100000fac040100000fac040100000fac020c000b050000520000460502000000002d1a2d0017ffffff00000000000000000000000000000000000000003d16010800000000000000000000000000000000000000007f080400080000000040dd090010180200101c0000dd180050f2020101800003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00010000000000000000000002ad00b0bbe51f524e0019dbc90001c19a91a0e50a020000640011140010537065637472756d53657475702d3438010882848b962430486c0301010504000100002a010032040c12186030140100000fac040100000fac040100000fac020c000b0500004e0000460502000000002d1a2d0017ffffff00000000000000000000000000000000000000003d16010800000000000000000000000000000000000000007f080400080000000040dd090010180200101c0000dd180050f2020101800003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00010000000000000000000002ab00209a7ded27060013dbc90001c1984178170c010000640011140010537065637472756d53657475702d3030010882848b962430486c0301010504000100002a010432040c12186030140100000fac040100000fac040100000fac020c000b050100390000460502000000002d1a2d0017ffffff00000000000000000000000000000000000000003d16010815000000000000000000000000000000000000007f080400080000000040dd090010180201101c0000dd180050f2020101800003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00010000000000000000000002ab00ca4efc6c49f00019dbc90001d58361feaf05000000c80031140010537065637472756d53657475702d454601088c129824b048606c0301010504000100000706555320010b1e2a0100460573d000000c2d1aef1903ffffff00000000000000000001000000000000000000003d16010500000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f0805000f0200000040bf0cb2798a33eaff0000eaff0020c005000000fcffdd180050f2020101800003a4000027a4000042435e0062322f00dd0900037f01010000ff7fdd088cfdf00101020100
Wed Apr  7 20:57:37 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00010000000000000000000002aa00d0b2c43e97e8001adbc90001d68581c2bc41000000640011140009544338373137544532010882848b962430486c0301010504000100002a01042f010430140100000fac040100000fac040100000fac028c0032040c1218600b0502001c00002d1aad1917ffffff00000000000000000000000000000000000000003d16010815000000000000000000000000000000000000007f080400080000000040dd310050f204104a000110104400010210470010198ff8834e15d55c2423956984d2ac8f103c0001031049000600372a000120dd090010180202001c000046057208010000
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00060000000000000000000002be00e8ada65118e6007fdbc90001cde7a8cde40a0200006400110400134d79537065637472756d5769466965302d3247010882848b9624b0486c0301060504000100402a010632048c12986030140100000fac040100000fac040100000fac020c000b0507003c00002d1a2d0017ffffff00010000000000000000000000000000000000003d16060017000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f080500080000000040dd090010180207101c0000dd180050f2020101800003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00060000000000000000000002be00209a7de83d7e0075dbc90001c125748c14fc010000640011140010537065637472756d53657475702d3738010882848b962430486c0301060504000100002a010432040c12186030140100000fac040100000fac040100000fac020c000b0501001d0000460502000000002d1a2d0017ffffff00000000000000000000000000000000000000003d16060815000000000000000000000000000000000000007f080400080000000040dd090010180201101c0000dd180050f2020101800003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00060000000000000000000002b100ccd5397ca9a3007cdbc90001dcdc6678111d01000066002114000b7866696e6974797769666901088c1218243048606c0301060504000100000706555320010b1e0b050000a38d5b2001002a01002d1a2c181bffff0000000000000000000000000000000000000000003d1606000500000000000000000000000000000000000000460573c00000007f06001008040140851e03008f000f00ff0359003138383639335f434f4d4d554e4954000000003e9606004096001000dd180050f2020101800003a4000027a4000042435e0062322f00dd06004096010104dd050040960305dd050040960b89
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00060000000000000000000002b100487d2eb2583b007fdbc90001d9c643907afa01000064001104000c54502d4c494e4b5f35383342010882848b961224486c0301060504000100003308200102030405060733082105060708090a0b2a010632040c183060dd1a0050f20101000050f20202000050f2020050f20401000050f20230180100000fac020200000fac02000fac040100000fac0200000b05050000127a2d1aee1117ffffffff010000000000000000000000000000000000003d16060706000000000000000000000000000000000000004a0e14000a002c01c800140005001900bf0cb101c033aaff1806aaff1806
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00060000000000000000000002b000ccd5397ca9a40076dbc90001dc73c276111d01000066002114000b6f7074696d756d7769666901088c1218243048606c0301060504000100000706555320010b1e0b050000a38d5b2001002a01002d1a2c181bffff0000000000000000000000000000000000000000003d1606000500000000000000000000000000000000000000460573c00000007f06001008040140851e03008f000f00ff0359003138383639335f434f4d4d554e4954000000003e9606004096001000dd180050f2020101800003a4000027a4000042435e0062322f00dd06004096010104dd050040960305dd050040960b89
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00060000000000000000000002ad002401c78628400076dbc90001dd33b042ffa600000066002114000c537065637472756d5769466901088c1218243048606c0301060504000100000706555320010b1e0b050200af8d5b2001002a01002d1a2c181bffff0000000000000000000000000000000000000000003d1606000500000000000000000000000000000000000000460573c00000007f06001008040140851e03008f000f00ff0359003138383639345f434f4d4d554e4954000200003e9606004096001900dd180050f2020101800003a4000027a4000042435e0062322f00dd06004096010104dd050040960305dd050040960b89
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00060000000000000000000002ab0014918269e2150079dbc90001d7cb00f807ec00000064003104000c4c696e6b7379733134303136010882848b960c1218240301060504000100000706555320010b1e2a010232043048606c2d1a2d0803ffffff00000000000000000001000000000000000000003d16060001000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f0801000f0200000040bf0c32788233eaff0000eaff0000c005000000fcffdd1a00904c0408bf0c32788233eaff0000eaff0000c005000000fcffdd180050f2020101800003a5000027a500004254bc0062436600
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00080000000000000000000002b1000836c97b0bf9009ddbc90001dc304c04692e010000c800111400094e4554474541523734010882840b162430486c0301080504000200000706555320010b1e2a01042f010430140100000fac040100000fac040100000fac020c0032040c1218602d1aad1917ffffff00000000000000000000000000000000000000003d16080804000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f080500000000000040dd310050f204104a0001101044000102104700101b2845cd1a8207fe1636644c0b7dfd13103c0001031049000600372a00012046057208010000
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00090000000000000000000002a90054e43aeaa66c00aedbc90001cac611e8a2d2000000640031140003726564010882848b960c1218240301090504020300000706555320010b1e2a010032043048606c30140100000fac040100000fac040100000fac0200002d1aad511bffff00000000000000000000000000000000000000000033027fa13d160908040000000000000000000000000000000000000046050200010000dd180050f2020101010003a4000027a4000042435e0062322f00dd0700039301730b20dd0e0017f2070001010654e43aeaa66cdd0b0017f20100010100000007
Wed Apr  7 20:57:38 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00090000000000000000000002a800b06ebf9d3dd800afdbc90001ddab7151a1740000006400310c0008436973636f2d4534010882848b961224486c03010932040c1830600706555320010b143308200102030405060733082105060708090a0b0505000100000130140100000fac040100000fac040100000fac0200002a01022d1aec1117ffff0000010000000000000000000000000000000000003d16090006000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f080100000000000000dd180050f2020101800003a4000027a4000042435e0062322f000b0507000c127add07000c4303000000
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 000b0000000000000000000002c000485d36d2ed4600dbdbc90001dc9e9109e10a02000064003114000a46694f532d363841575a010882848b962430486c03010b0504000100000706555320010b1e2a010232040c12186030140100000fac040100000fac040100000fac020c000b050400130000460503000000002d1aad091bffffff00000000000000000000000000000000000000003d160b0007000000000000000000000000000000000000007f080400080000000040dd310050f204104a000110104400010210470010cbf0ec10d9c1825eff6cac2dc0f74a01103c0001031049000600372a000120dd090010180204001c0000
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 000b0000000000000000000002b00094917f11ee2800d4dbc90001d18311a5ae9b0000006400310400134d79537065637472756d5769466932412d324701080c1218243048606c03010b0504010300020706555320010b1e2a01022d1aef1903ffffffff000000000000000001000000000000000000003d160b0701000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f0805000f0200000040bf0cb2798b33aaff0000aaff0020c005000000fcffdd180050f2020101800003a4000027a4000042435e0062322f00dd0900037f01010000ff7fdd088cfdf00101020100
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 000b0000000000000000000002ae00eca94099b3ad00d3dbc90001cd836106fb020000006400310400134d79537065637472756d5769466941432d3247010882848b960c12182403010b0504000100000706555320010b1e2a010032043048606c2d1aad0903ffffff00000000000000000001000000000000000000003d160b0005000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f0801000f0200000040bf0cb2798a33eaff0000eaff0000c005000000fcffdd180050f2020101800003a4000027a4000042435e0062322f00dd0900037f01010000ff7f
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 000b0000000000000000000002ae0044adb13e15ee00d8dbc90001c1ef928edecf000000640011140010537065637472756d53657475702d4538010882848b962430486c03010b0504000100002a010032040c12186030140100000fac040100000fac040100000fac020c000b050000630000460502000000002d1a2d0017ffffff00000000000000000000000000000000000000003d160b0811000000000000000000000000000000000000007f080400080000000040dd090010180200101c0000dd180050f2020101800003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 000b0000000000000000000002ad00d8a7567d030600d8dbc90001cd8a31cfe40a0200006400110400134d79537065637472756d5769466930302d3247010882848b9624b0486c03010b0504000100002a010032048c12986030140100000fac040100000fac040100000fac020c000b0501003a00002d1a2d0017ffffff00010000000000000000000000000000000000003d160b0815000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f080500080000000040dd090010180201101c0000dd180050f2020101800003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 000b0000000000000000000002ab00c8b422e1314400d9dbc90001d18341139b890000006400310400134d79537065637472756d5769466934362d324701080c1218243048606c03010b0504020300000706555320010b1e2a01002d1aad0903ffffffff000000000000000001000000000000000000003d160b0001000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f0805000f0200000040bf0cb2798b33aaff0000aaff0020c005000000fcffdd180050f2020101800003a4000027a4000042435e0062322f00dd0900037f01010000ff7fdd088cfdf00101020100
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 000b0000000000000000000002ab004c1265589b8700d6dbc90001cd50722e792a0400006400310400134d79537065637472756d5769466938362d3247010882848b960c12182403010b0504000100000706555320010b1e2a010032043048606c2d1aad0903ffffff00000000000000000001000000000000000000003d160b0005000000000000000000000000000000000000004a0e14000a002c01c8001400050019007f0801000f0200000040bf0cb2798a33eaff0000eaff0000c005000000fcffdd180050f2020101800003a4000027a4000042435e0062322f00dd0900037f01010000ff7f
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 000b0000000000000000000002ab00209a7d1de0fe00dadbc90001ba90d155e60a0200006400111400095a656e656e7369746f010882848b962430486c03010b0504000100002a010232040c12186030140100000fac040100000fac040100000fac020c000b050100450000460502000000002d1a2d0017ffffff00000000000000000000000000000000000000003d160b0017000000000000000000000000000000000000007f080400080000000040dd090010180201101c0000dd180050f2020101800003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 000b0000000000000000000002aa00a41162639f4c00dadbc90001b780ad3f1d0c0100001f00310400134e5447525f564d425f38313032383230313334010882848b960c12182403010b05041b210000070a5553200b011e020a1e002a010032043048606c30140100000fac040100000fac040100000fac028c002d1aed111bffff0000000000000000000001000000000000000000003d160b0004000000000000000000000000000000000000007f080000000200000040dd180050f2020101800003a4000027a4000042435e0062322f00
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 00240000000000000000000000ad00e8ada65118e700ebdbc90001dfd89029e40a0200006400110000134d79537065637472756d5769466965302d354701088c129824b048606c05040001000030140100000fac040100000fac040100000fac020c000b0502001500004201002d1a6f0017ffffffff000000000000000000000000000000000000003d16240504000000000000000000000000000000000000007f080400088000000040bf0c32688b0faaff0000aaff0000c005012a000000c30402020202dd0500904c0417dd090010180202001c0000dd180050f2020101800003a4000027a4000042435e0062322f00dd07506f9a16010100
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 002c0000000000000000000000b000209a7de83d7f0004dcc90001dd6b20aa14fc010000640011110010537065637472756d53657475702d373801088c129824b048606c050400010000074e55532024011e28011e2c011e30011e3401183801183c01184001186401186801186c01187001187401187801187c01188001188401188801188c011890011895011e99011e9d011ea1011ea5011e2001002302160030140100000fac040100000fac040100000fac020c000b0501001e0000460502000000002d1aef0117ffffffff000000000000000000000000000000000000003d162c051600000000000000000000000000000000000000
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 002c0000000000000000000000a800f08175fd14070009dcc90001dd2d21415706000000640011110010537065637472756d53657475702d303001088c129824b048606c050400010000074e55532024011e28011e2c011e30011e3401183801183c01184001186401186801186c01187001187401187801187c01188001188401188801188c011890011895011e99011e9d011ea1011ea5011e2001002302160030140100000fac040100000fac040100000fac020c000b0505001b0000460502000000002d1aef0117ffffffff000000000000000000000000000000000000003d162c050400000000000000000000000000000000000000
Wed Apr  7 20:57:39 2021 daemon.notice hostapd: wlan0: BEACON-RESP-RX fa:74:b5:fa:74:b5 41 00 002c0000000000000000000000a80044adb13e15ef0005dcc90001dd5470bddecf000000640011110010537065637472756d53657475702d453801088c129824b048606c050400010000074e55532024011e28011e2c011e30011e3401183801183c01184001186401186801186c01187001187401187801187c01188001188401188801188c011890011895011e99011e9d011ea1011ea5011e2001002302160030140100000fac040100000fac040100000fac020c000b050600290000460502000000002d1aef0117ffffffff000000000000000000000000000000000000003d162c051600000000000000000000000000000000000000

Wifi Config from Main Router:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '149'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option country 'US'
        option noscan '1'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option wds '1'
        option ssid 'OpenWrt-5G'
        option encryption 'psk2'
        option key 'secret'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option ieee80211v '1'
        option ieee80211k '1'
        option bss_transition '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel 'auto'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT400'
        option country 'US'
        option noscan '1'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option wds '1'
        option ssid 'FBI'
        option encryption 'psk2'
        option key 'secret'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option ieee80211v '1'
        option ieee80211k '1'
        option bss_transition '1'

Wifi Config from WDS DumbAP:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '149'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option country 'US'
        option noscan '1'
        option cell_density '0'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option network 'lan'
        option mode 'sta'
        option wds '1'
        option ssid 'OpenWrt-5G'
        option encryption 'psk2'
        option key 'secret'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option wds '1'
        option ssid 'OpenWrt-5G'
        option encryption 'psk2'
        option key 'secret'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option ieee80211v '1'
        option ieee80211k '1'
        option bss_transition '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel 'auto'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT40'
        option country 'US'
        option noscan '1'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option wds '1'
        option ssid 'FBI'
        option encryption 'psk2'
        option key 'secret'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option ieee80211v '1'
        option ieee80211k '1'
        option bss_transition '1'

So I just ran iw list | grep "Supported interface modes" -A 9 command on my TPLink A7v5 and it does not show WDS. I'm confused, is WDS only an ath9k option ? How is the dumbAP/repeater even working then ? Is my setup failing the way it is simply because I'm using WDS mode which isn't supported ?
Should I switch to meshing (802.11s) because mesh point is a supported mode.

Help!

@jeff @eduperez @ACwifidude Any suggestions ?

The key here is that the client always determines when to roam. You have a wide range of clients so they will all roam differently. :grimacing: looks like your 2.4ghz has a typo of HT400 (40 what you were looking for, however very few devices connect at 40mhz - I’d set 2.4ghz to 20mhz.

To get “enterprise” level awesome roaming with optimal wifi signal and optimal wifi speed:

  1. if there is anyway to hardwire your second router - do it. Hire help if needed for fishing wire (I hired an electrician, easy job for them).
  2. I’d manually set your tx power to 20. Depending on your environment you’ll likely have to tweak the power setting.
  3. I’d get an app that reports RSSI in real time and walk around your house to quickly “map” your signal.
  4. Keep to 5ghz only for your smart devices. Pick different 80Mhz channels to prevent collisions.
  5. Apple devices roam at -70 so I’d try to tweak your power setting or adjust physical positioning of your routers- you’ll create “known” roaming locations where both routers lightly overlap at -65.

This is what I use to get 802.11v,k enabled on 5ghz radio (change to your timezone )


uci add_list umdns.@umdns[0].network='wan'; uci set wireless.default_radio0.ieee80211v=1; uci set wireless.default_radio0.ieee80211k=1; uci set wireless.default_radio0.bss_transition=1; uci set wireless.default_radio0.wnm_sleep_mode=1; uci set wireless.default_radio0.time_advertisement=2; uci set wireless.default_radio0.time_zone=CST6CDT,M3.2.0,M11.1.0; uci commit

What does your dawn config look like? I tried to make mine similar to the developer’s read me.

This will set it to enable VHT / HT and use all the evaluation features (nothing aggressive):


uci set dawn.@metric[0].ht_support='10'; uci set dawn.@metric[0].vht_support='100'; uci set dawn.@metric[0].min_probe_count='2'; uci set dawn.@metric[0].eval_probe_req='1'; uci set dawn.@metric[0].eval_auth_req='1'; uci set dawn.@metric[0].eval_assoc_req='1'; uci commit

The settings will look like this afterwards:


root@OpenWrt:~# cat /etc/config/dawn

config network
        option broadcast_ip '10.0.0.255'
        option broadcast_port '1025'
        option tcp_port '1026'
        option network_option '2'
        option shared_key 'Niiiiiiiiiiiiiik'
        option iv 'Niiiiiiiiiiiiiik'
        option use_symm_enc '1'
        option collision_domain '-1'
        option bandwidth '-1'

config ordering
        option sort_order 'cbfs'

config hostapd
        option hostapd_dir '/var/run/hostapd'

config times
        option update_client '10'
        option denied_req_threshold '30'
        option remove_client '15'
        option remove_probe '30'
        option remove_ap '460'
        option update_hostapd '10'
        option update_tcp_con '10'
        option update_chan_util '5'
        option update_beacon_reports '20'

config metric
        option ap_weight '0'
        option no_ht_support '0'
        option no_vht_support '0'
        option rssi '10'
        option low_rssi '-500'
        option freq '100'
        option chan_util '0'
        option max_chan_util '-500'
        option rssi_val '-60'
        option low_rssi_val '-80'
        option chan_util_val '140'
        option max_chan_util_val '170'
        option bandwidth_threshold '6'
        option use_station_count '1'
        option max_station_diff '1'
        option deny_auth_reason '1'
        option deny_assoc_reason '17'
        option use_driver_recog '1'
        option min_number_to_kick '3'
        option chan_util_avg_period '3'
        option set_hostapd_nr '1'
        option op_class '0'
        option duration '0'
        option mode '0'
        option scan_channel '0'
        option ht_support '10'
        option vht_support '100'
        option min_probe_count '2'
        option eval_probe_req '1'
        option eval_auth_req '1'
        option eval_assoc_req '1'


Thanks for taking a look. I am away for a couple of days, I'll take a look at the settings once I get home. and post back with findings. And yes that 'HT400' was a fat finger typo, not sure how that ended up as such.

1 Like

Back.
Fixed the HT400 typo as you pointed out and now my config for DAWN is exactly like yours.
I also added the additional options that you setup in on your wifi radios. I see DAWN working perfrectly. Both APs can see each other's associated STAs and the Network Overview is identical between the two.
MAIN AP:


DUMB AP (WDS)

The bad news: I think WDS is borked or there isn't an appropriate means to actually switch from MainAP to DumbAP relatively quickly (even with 802.11r,k,v all enabled + DAWN).

Behavior that I observed. If a device initially connects to the network via DumbAP, it doesn't have any issues roaming to MainAP. This is with or without DAWN (so 802.11r,k,v might be working in 1 direction, can't say for sure, will have to disable 802.11k,v,r and see if this is still the case). I observed this with the only device which actually has really weak 5Ghz reception (iPhone 5Ghz).
The other direction doesn't work: Can't roam on WDS DumbAP if the client device first connected to the MainAP. I attempted this with the iPhone, OnePlus6 and Galaxy Tab S7+.
The OnePlus6 can be forced to switch if its fully covered but as soon as it attempt to connect to the WDS DumbAP, it won't receive an IP address.
If there is a specific packet capture that I can perform to get more details to the right set of folks I'm willing and able to if someone can guide me with the right set commands.

Now I thought about going wired but I don't have any budget to run holes and have someone come in to run ethernet. I would do it myself but I simply don't have the time.

I'm probably not the first person who has attempted to do this.
I'm literally thinking of giving mesh mode a try (unless there are other bright ideas).

I’d save up for a wired install between your routers with some quality cat 6 or cat 6A cable. The wireless mesh / WDS options for router to router connections are plagued with poor performance. To get a good connection between the routers they have to be closer to each other which leads to compromises / degradation in roaming (see above setting up an “enterprise” like roaming setup).

Wired is always better.

Wireless is popular because they are “nodes” are easy to setup...that is the only advantage (and non-technical people don’t care / don’t measure their performance).

So I just tried mesh mode and my problems are solved.
Good riddance WDS!!!

EDIT:
I should also point out that after enabling mesh mode, I disabled DAWN. My Apple devices roam freely between APs now with just the WiFi config as below. My Samsung Galaxy Tab S7+ also roams freely without issues, as does my OnePlus 8T+. My OP6 does not, but I think the device simply doesn't support it based on my search over the internet.

Here is my config incase someone comes looking for the solution. Note that my 2nd AP is still configured as a DumbAP (static IP, with DHCP/dnsmasq/firewall/ etc disabled)

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '149'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option country 'US'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'redacted'
        option encryption 'psk2'
        option key 'redacted'
        option ieee80211r '1'
        option ft_psk_generate_local '1'
        option ieee80211v '1'
        option ieee80211k '1'
        option bss_transition '1'
        option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'EST5EDT,M3.2.0,M11.1.0'
        option ft_over_ds '1'

config wifi-iface 'wifinet2'
        option mesh_rssi_threshold '0'
        option network 'lan'
        option device 'radio0'
        option mode 'mesh'
        option mesh_fwding '1'
        option encryption 'sae'
        option key 'redacted'
        option mesh_id 'redacted'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel 'auto'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT40'
        option country 'US'
        option noscan '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'redacted'
        option encryption 'psk2'
        option key 'redacted'
        option ieee80211r '1'
        option ft_psk_generate_local '1'
        option ieee80211v '1'
        option ieee80211k '1'
        option bss_transition '1'
        option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'EST5EDT,M3.2.0,M11.1.0'
        option ft_over_ds '1'
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.