[Solved] OpenWrt Snapshot & Privoxy error

Within the SNAPSHOT version of openWrt, there is a fault with privoxy.
As i am not (yet) github member, please arrange the following change.

The 'list' items are not converted to the actual config-file (in /var/etc/privoxy.conf)

### SEE /etc/config/privoxy INSTEAD

logdir  /var/log
logfile privoxy.log
confdir /etc/privoxy
enable-remote-toggle    1
enable-edit-actions     1
forwarded-connect-retries       0
keep-alive-timeout      300
debug   4096
debug   8192
debug   1024
toggle  1
accept-intercepted-requests     1

Within the GUI & /etc/config/privoxy file is written:

config privoxy 'privoxy'
        option confdir '/etc/privoxy'
        option logdir '/var/log'
        option logfile 'privoxy.log'
        list filterfile 'default.filter'
        list actionsfile 'match-all.action'
        list actionsfile 'default.action'
        option enable_remote_toggle '1'
        option enable_edit_actions '1'
        option forwarded_connect_retries '0'
        option keep_alive_timeout '300'
        option debug_4096 '1'
        option debug_8192 '1'
        list forward_socks5t '/ 192.168.xx.1:9050 . '
        option debug_1024 '1'
        option toggle '1'
        list permit_access '192.168.xx.0/24'
        option accept_intercepted_requests '1'
        list listen_address '192.168.xx.1:8118'

config system 'system'
        option boot_delay '10'

Why does privoxy log shows '' ??
Where are all 'list' items from GUI & /etc/config/privoxy file?

2018-06-21 17:45:01.936 7f110e365b88 Info: Privoxy version 3.0.26
2018-06-21 17:45:01.936 7f110e365b88 Info: Program name: /usr/sbin/privoxy
2018-06-21 17:45:01.936 7f110e365b88 Info: Listening on port 8118 on IP address

I've also tried using 3.0.26-2 instead of 3.0.26-3 within a new build, both have same result.

Regards, DG.

I upgraded to the latest version LEDE that David offers on WRT3200ACM and
Privoxy stopped working. I also noticed the Listen address was in debug as well.
Side Question: Have you ever used Privoxy with Compression Enabled? I would love to, but I don't have the
compiling smarts (yet) to make a Privoxy package with compression libs needed. Cheers!

It doesn't look like there has been any changes in the privoxy package for two years.

Typically, the service start-up script transforms the UCI configuration into the format required by the executable into /tmp (same as /var on most OpenWRT installs). I'd look at that file to get some insight.

Since I don't recall any other discussion of the privoxy package here, it may not be a popularly used one, or nobody else is having problems. The maintainer is listed in the source, or through the package descriptions



To answer your question: no, i never tried 'Privoxy with Compression Enabled'.
It's also stated that when "Privoxy and the client are running on the same system, enabling compression is likely to slow things down. If you didn't measure otherwise, you should assume that it does and keep this option disabled." (https://www.privoxy.org/user-manual/config.html)
Also the client need to support this.

Btw, Privoxy won't stop working, it is running but won't proxy the right way, because of the wrong ip-address.
ie. it looks like it is stopped :slight_smile:



Privoxy runs perfect (even the newer version 3.0.26-3) on LEDE/openWrt 17.01.4.
I only tried building a VMware x86-64 version on which the mentioned error occures.

The new logfile is missing the following lines:

2018-06-24 00:22:03.056 7fba0ab81b48 Info: Loading filter file: /etc/privoxy/default.filter
2018-06-24 00:22:03.060 7fba0ab81b48 Info: Loading actions file: /etc/privoxy/match-all.action
2018-06-24 00:22:03.060 7fba0ab81b48 Info: Loading actions file: /etc/privoxy/default.action

And this line has the wrong ip-address (, instead of):

2018-06-24 00:22:03.066 7fba0ab81b48 Info: Listening on port 8118 on IP address 192.168.xx.1

I did a small check on both configuration files, they are identical.
But it looks like all 'list' options from config-files are not read/processed on the newer snap-version (18.01.x ?).


As the compression would be done on the LEDE Router / CPU / RAM / Volumes needed for file manipulation. ECT. The hardware of device(s) browsing via privoxy are doing the UNcompression.
The Privoxy user manual recommends not doing both when its installed locally on a Computer running the browser locally. (basically make-work with nothing to show for the effort).
Ideally the portion of content that is compressed is forwarded to SQUID (also running on LEDE) for catching on a locally mounted drive on the router itself. That is my goal eventually. Who knows, maybe I'll have my WRT1900AC running Privoxy which forwards to my WRT3200ACM running Squid?

Hi Jeff,

Could you gain any insights? I am having trouble with Privoxy with recent OpenWrt builds from David as well (still have to use a release from May, in all the newer ones including the one from yesterday I cannot get privoxy to work).

I'd work with the 18.06 builds as a forward-looking choice. Past that, it sounds like the problem is with privoxy itself. https://www.privoxy.org/user-manual/contact.html

same issue here even with 18.06 branch

issue was caused by https://github.com/openwrt/openwrt/commit/73d8a6ab7668173d70adbed45b61be5256c505e1 which also broke qos-scripts.

Has the code change implemented in the privoxy package? In the latest build from David the issue remains and looking at the change date of the privoxy files in github, the commit does not seem to be included (latest update of privoxy.init is 2 years ago).

Newer builds (ie. v17.01.x, v18.06,x and snapshot version) don't have this issue anymore!
Good work (or my builds were corrupted & cleared now)


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.