[Solved] OpenWRT on Raspberry Pi Model B - not assigning ip4 to wifi

My Hardware Configuration -

Raspberry Pi Model B
Wifi - Zydas zd1211rw based USB-Wifi adapter (Wifire - by hfield - Had one lying with me, it was supported so trying it out)
USB-Ethernet - ASIX AX88179 (TPLink Model UE306)

My problem - The wired connections are working fine. But the devices connected through wifi are not getting the ipv4 address .

Even Configuring static ip address etc on computer does not help. Cannot ping the OpenWrt (RPi) router

My configuration -

Network->

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd55:e1b6:bf5e::/48'

config interface 'lan'
	option proto 'static'
	option device 'eth1'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option proto 'dhcp'
	option device 'eth0'

Wireless ->

root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/20980000.usb/usb1/1-1/1-1.3/1-1.3:1.0'
	option channel '1'
	option band '2g'
	option cell_density '0'
	option country 'IN'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt'
	option key '##########'
	option encryption 'psk2'
	option network 'lan'

Firewall->

root@OpenWrt:~# cat  /etc/config/firewall 

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option masq '1'
	option input 'REJECT'
	option forward 'REJECT'
	option mtu_fix '1'
	list network 'wan'

config forwarding
	option src 'lan'
	option dest 'wan'

DHCP ->

root@OpenWrt:~# cat  /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'eth1'
	option interface 'eth1'
	option start '100'
	option limit '150'
	option leasetime '12h'

config dhcp 'eth0'
	option interface 'eth0'

config dhcp 'lan'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'lan'

config dhcp 'wan'
	option interface 'wan'

You need the lan using a bridge device:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'

config interface 'lan'
	option proto 'static'
	option device 'br-lan'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
1 Like

zd1211rw is a rather ancient wireless chipset, while not faultless in STA- (client-) mode it was working relatively well, but it's untested in AP mode, I would not expect anything in this regard.

1 Like

Thanks It worked.

Thanks.
I had this one lying unused for long in my store. Have another one based on rtl8812bu which is not supported. So trying the Zydas one and working fine so far

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.