[Solved] OpenWrt on MT7621/MT7615N devices with 5GHz problems

I made this small script to try to get the 5ghz wifi back into sense whenever it goes down
Save as /root/wlan_watchdog, chmod +x /root/wlan_watchdog and put "/root/wlan_watchdog &" into /etc/rc.local . Unfortunately the problem with this is that it takes out other wifi as well and in my testing it still typically takes 10-30 minutes of network restarts until things start working again. Single reboot of the router would probably work but is very risky to even try because if the script malfunctions it can lead to a reboot loop. I do not if this calls mt76x2_reset_wlan(and I doubt it will work) but I'll email Felix Fietkau and John Crispin perhaps they can propose stronger measures to reset the wifi without rebooting.


echo "wlan watchdog started " > $LOG
date >> $LOG

while true; do
	quality=`iwinfo $WIFI info | grep "Quality" | awk '{print $6}' | sed -e "s/\/.*//g"`
#	echo "$quality"
	if [ $quality == "unknown" ]; then
		fail_count=$(( fail_count + 1 ))
#	echo "fail count $fail_count" >> $LOG

	if [ $fail_count -ge 20 ]; then
		date >> $LOG
		echo "commencing network restart" >> $LOG
		/etc/init.d/network restart

	sleep 5s

Apologies if I oversimplified or misrepresented what your patch does. Linking to your comment where you discuss it more fully in case my comment misled anyone and they want more detail.

1 Like

Note: As of August 21, 2022, hauke has applied arinc9's patch into master = Snapshots as of that date should include the patch.
Reminder for those unfamiliar with OpenWrt: Snapshots do not include LuCI.
LuCI will need to be installed by the user.
LuCI should be installed almost immediately after snapshot installation, due to time limit.

With that said,
arinc9 deleted the mt7621-dts-work branch yesterday


This topic/thread is getting rather long so a quick summary for those who reported unresolved problems with MT7621/MT7615 routers.

Pico w/ DIR-1960
1 picky WPA2 2.4Ghz IoT device with really low data activity

Cheddoleum w/ EA7500 v2
directory listings from an NFS server made from a Macbook Air Finder window just give me a spinner that goes on for an indeterminate time

Mentioned fixes by some users,
NB: Fixes may/may not be necessary since OpenWrt snapshots may contain fixes already.

FWIW, I'm running a Netgear R6700 v2 and changing from WPA3 to WPA2 only fixed this for me

try temperately turning off "Enable SYN-flood protection"
under Firewall>General Settings

Note: My personal testing has arinc9 release (no longer available, since incorporated into snapshots) with an uptime of 25 days ... on a D-Link DIR-878 rev.A1

Will resume testing snapshots soon, unless a new 22.03.0 stable release comes out.

EDIT: Since not all the arinc9's patches were integrated into 22.03.0 stable release, sticking with snapshots.

1 Like

Just to add my experience also. I have a DIR-2640 that have been using for quite a while without any noticeable issues. I started seeing slow throughput (20 Mbps) in certain devices and could not figure out what was going on but others were just fine. Then more recently the disassociations started happening. In some of my debugging I “factory reset” openwrt but was getting the same issues. In setting things back up I did notice that messing with the 5Ghz radio settings were very quirky even causing things to freeze up and have to reboot router. I got things back limping along, but still have a number of devices that will just stop working all the time. Have to turn the client Wi-Fi off and the back on to get it to work again. I am patiently waiting for a new rc with these patches to test things. Meanwhile I got a new dedicated AP to add to my network to work around the WiFi problems.

just a note as well
connecting to a ssh console via a device over the MT7615's wifi
is sometimes impossible on it self or to another openwrt device
but on another access point it's fine to both devices
I have seen this a bit as well
note "using putty on windows 10"

It will work in the new rc. If you prefer, you can compile a snapshot for your device, which should fix this issue.

it's good it's fixed
I'll just wait for rc7 or .0 :slight_smile:

I suspect usb 3 connector was left out of newer Tp-Link Archer AX20 Wifi 6 with MT7621A because they knew it would interfere with the 5ghz wifi. Stuck the ssd with extroot on my newifi d1 to usb 2.0 port instead.

I'm not 100% but from what I have read around
it's the 2.4G that's Mainly upset by USB 3.0
eg https://www.pcmag.com/opinions/wireless-witch-the-truth-about-usb-30-and-wi-fi-interference

Okay, can anyone explain me with as much detail as possible what exactly is the issue here? I initially reported back in October 2021 that I never experienced the issue with my DIR-882 A1 and that's still the case even nowadays, almost an year later. In all this time I've been running the snapshot builds (updated monthly -- currently running the September 5th, 2022 one).

My Wi-Fi settings are still the same from my previous post, but the list of 5 GHz clients connected to the DIR-882 changed a bit: three smartphones (Xperia X, Galaxy A71 and Galaxy S10e), one laptop (Intel Wi-Fi 6 AX201) and a Blu-ray player (Sony BDP-S6700 with 802.11abgn support -- no ac, aka Wi-Fi 5).

Although both 2.4 GHz and 5 GHz SSIDs are the same, the laptop is specifically configured to always prefer the 5 GHz band and even then I've never experienced the "Connected, no internet" many described here. The smartphones also keep connected to the 5 GHz 90% of the time since I live in a small apartment (enough to get full bars on the 5 GHz band in all rooms), they only switch to 2.4 GHz when I'm already out and relatively far from the router.

This time I'm including also the command line I use with the image builder and the extra packages I add to the snapshots, maybe something here helps identifying why I don't experience the issue:

make image PROFILE="dlink_dir-882-a1" PACKAGES="block-mount e2fsprogs ipset kmod-fs-ext4 kmod-usb-storage-uas libustream-openssl -libustream-wolfssl luci luci-app-samba4 luci-app-upnp wpad-basic-openssl -wpad-basic-wolfssl"

(I use libustream-openssl and wpad-basic-openssl instead of their default WolfSSL versions as a space saving measure, otherwise the resulting image is too big to fit on my DIR-882 -- Samba4 is the biggest package and requires OpenSSL anyway, can't switch to ksmbd because it doesn't work with Windows' File History, something I use extensively)

As already mentioned, USB 3.0 is known to cause interferences only on 2.4 GHz networks, 5 GHz networks are immune. Also, several routers have mitigated this problem either by shielding the USB 3.0 connector, by moving it away from the antennas, or by doing both (the case of DIR-882 and all other routers based on that same AP-MTKH7-002 board from SGE that includes USB 3.0 ports)...

Stable release 22.03.0 for MT7621 available for download.
Waiting on arinc9 to confirm patches are included or not.

Either way,
Keeping copies of arinc9 releases just in case!

Pretty sure the answer is 'no'. I reviewed the commit history for the 21.03.0 tag and those commits do not appear.


I saw that too. I found some clues that the ssd might be an issue(more stable without extroot). Upgraded to 22.03.0 and put extroot on tf card this time instead of ssd leaving both usb unused. Even though the ssd is rated 5V 1.7A it only draws less than 200ma measured. Interesting to see what happens.

Getting an excellent deal on Netgear r6800 router (MT7621AT and MT7615E). Will you guys suggest to go for it, since I see most of the things are now getting sorted out or should I pass. @Warlock / other's pls guide.



Personal experiences:
Netgear routers use nmrpflash for recovery.

When I had a Netgear router in the past for testing, I ended up bricking it several times during OpenWrt installation.
The first two/three? times I managed to recover it
The final time, the nmrpflash did not work.

I could not bother trying to use solder/serial recovery method mentioned and never really liked the nmrpflash to being with, so I threw it out.

EDIT: For MT7621AT/MT7615N routers, I use/test with D-Link DIR-878 rev.A, DIR-882 rev.A and DIR-2640. Several years of testing, recovery method has never failed.


Others may want to know, which firmware were you using? How long before slow throughputs were noticed? How long before dis associations started?
arinc9 release or snapshot?


OpenWrt 21.02.3 r16554-1d4dea6d4f

I haven’t had a chance to upgrade yet.

I really don’t know how long everything was. It developed over a long period of time. I first noticed a few months ago on a laptop that I do not use regularly that updates were being incredibly slow. I messed with things then trying to narrow down the problem and I decided it must have been something about WiFi on that particular machine because I was not really having issues with anything else. But it started getting worse and worse and effecting more clients. All these things worked fine wired. My primary phone started getting disconnects eventually and I really dug into people having issues like mine and I was not finding much until I found this thread. After a week or so dealing with the disconnects on my everyday devices I finally broke down and bought a separate AP to tie into the network. Everything works great now on that AP and still having the same symptoms on the DIR-2640.