[Solved] OpenWrt on MT7621/MT7615N devices with 5GHz problems

Thanks for the reply.
That release was reported with issues last April.
It goes without saying, not recommended to use that release.

Maybe this is worth a look, caught red-handed on OpenWrt 22.03.0

WiFi: mt76: mt7615: add mt7615_mutex_acquire/release in mt7615_sta_set_decap_offload

Noticed another commit authored by arinc9
Dated September 18, 2022

Two dumb routers fighting for one channel. The way I see it, there is very little point in manually selecting channel when anyone at any time can come over and start sending DFS radars refusing to leave the channel yielding a nice race condition. One way around it would be to replace the channel selector with a text entry e.g.: "36, 40, auto" would try 36 and 40 failing back to automatic and "36, 40" would only try 36 and 40 before giving up.

@ cyberdork33
I think you are being hit by DFA-radar as these debug messages were not in none of the RC releases.

1 Like

Not sure what debug messages you are referring to. I don't think I posted any. Maybe you meant someone else?

I was referring to the logs I posted which now have been expired and therefore gone.

Wed Sep 14 09:03:16 2022 daemon.notice hostapd: wlan1: DFS-RADAR-DETECTED freq=5500 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5530 cf2=0
Wed Sep 14 09:03:17 2022 daemon.notice hostapd: dfs_downgrade_bandwidth: no DFS channels left, waiting for NOP to finish
Wed Sep 14 09:03:17 2022 daemon.notice hostapd: wlan1: AP-DISABLED
Wed Sep 14 09:03:18 2022 daemon.err hostapd: could not get valid channel

22.03.0 added some good new debug stuff that was not in RC releases. This behavior needs to be changed, it is causing ppl loose their hair over it.

an observation at this point
I use some of these devices as access points & switches
in this example I have a Ethernet point near my lounge TV
I have for many years now had a device attached to this point
it give me good wifi while watching TV.

This also doubles as to branch out to other devices
so I make use of the switch to the TV,media PC
and raspberry pi playing a security camera feed.

In this case using a switch & having the device plugged in only via it's wan
seems to work fine "all ports setup as one interface LAN with DHCP"
as soon as I remove the switch & try to use the ports on the device
"EA8100" then my wifi experience suffers with lots of drop outs
I also have a EA7500 setup exactly the same without these problems
tho this presence like a wifi problem
I'm starting to believe it's a switch or DSA problem
I ether have to disable "SYN-flood protection" or the firewall service itself
and then this problem goes away
I will note the ea7500 is not DSA at lest still has the switch
I will note the CPU in the ea7500 is much faster as well " IPQ8064"
both using V22.03.0

Ah OK. Thanks for the suggestion. I did update to 22.03.0 awhile back, but I am not seeing any messages about DFS in the logs.

for other owners of a Mi r3p: which channels work for 5GHz WiFi? For me it only reliably works when I use channel 36, sometimes channels >149 but they don't show up as valid choices in the channel dropdown menu in the current snapshot or any of the "stable" builds. Hasn't worked for at least 18 months if not longer. Any time I select a channel other than 36, it says wireless not associated / device is not active.

Hey there, I have the same router as the one you've got with the latest stable release. I don't know if you play online fps games or similar, but I noticed during my gameplay that I get consistent lags at more or less the same intervals, after around 5 minutes I have several interruptions after which the game resumes normally again. The router is practically an extender, I have a wwan interface connected to my main router in 2.4 and my pc in 5ghz. After seeing this thread, I'm wondering if is an issue with this new release and what should I try to do about it.


I currently stick with the snapshot releases.

I forgot the reason why, but that last current stable release was not stable for me.


OpenWrt SNAPSHOT r20985 dated October 19.
After several hours, just encountered the aggravating 5 GHz WiFi displaying the error:
Connected, no internet.

I should have kept running the earlier snapshots, just after security updates. :frowning:

EDIT: Trying out the latest r21015 snapshot, dated Thu Oct 20. Hoping the previous r20985 was just a glitch. Did not encounter error message during 24hrs of testing but subjectively? the 5 GHz WiFi felt sluggish. Frequently loaded 80% of a webpage then appeared to hang.

Trying out r21023 dated Fri Oct 21 now. Same error.
r21087: 22 hours into testing. Same error.


After I updated to 22.03.0 my Intel Wireless-AC 9560 m2 wifi adapter started giving firmware errors(https://bugzilla.kernel.org/show_bug.cgi?id=215635) almost crashing the entire system. As you can see this bug is still in open state meaning it is either resolved by newer kernels(I have not tested) or below the threshold to catch attention.

Anyway, I kind of realized what I am really after is server room reliability and way to do it is known as RJ-45. So like F35 fighter jet which almost shot itself in the foot, I think 5GHz Linux(maybe Windows as well) wifi will eventually fly but in the meantime perhaps bullet train is actually better. Perhaps I extent my network to a privately run and managed VPN to my house so I get the pihole and other goodies by cellular network instead of wifi.

Friday Nov.11,
Noticed several commits posted for MT7615: Details

Time permitting, will try a snapshot during weekend.

EDIT: The internet LED on router lit up solid immediately after firmware update reboot.
The internet LED did not blink once network cable to modem was connected.
Router did not provide IP for connected pc system. Required a hard reboot, then functioned normally.

Stopped testing after 22 hours. New snapshot dealing with WiFi released.


Saturday Nov.12,
Another commit dealing with MediaTek WiFi: Details

WARNING: Disregard. May want to avoid this snapshot. Soft-brick?

After firmware update, router reboots but then fails to provide IP to connected device(s)?
Waited for a minute or two.
The internet connection LED lit up solid, immediately after reboot, even when network cable to modem was not connected.
The internet connection LED also remains solid, no blinking (activity indication) when network cable to modem was connected.
Tried powering on/off the router using the power button but no change.

Snapshot download was SHA256 checked for corruption immediately after download.

Confirmed router hardware is not the issue.
Installed and tested with old arinc9 release, based off snapshot 20025? for above listed problems. No issues.

Test router: D-Link DIR-882 rev.A1


it really is disappointing that many years later the mt7615 support is not much better.

some people here are so happy about having a stable connection, which is just sad.

i wanted to again try the mt76 driver because the RALINK driver is missing station mode support, but looking at the above i just see some convenient FUD and others raving about uptime.

as it is, in AP mode i consistently get 500up/down and that's on a Broadcom BCM43xx 1.0 ( AirPortDriverBrcmNIC-1305.12)

is openwrt this better than stock firmware? yes. is it better than other offerings? only if you need station mode. it makes things difficult for people like myself who have the best build for this family of devices.

station mode is only for a small group of people but it still does matter.

the choice is disappointing: use mt76 and have the connectivity/throughput issues, OR use the mt_wifi driver and have great performance but no station mode.

i feel bad for the people here who are happy using OPENWRT in AP mode. really bad, but that's their choice. they don't know a better life and i'll let them continue their lives in this pitiful way.

You don’t have to be here, you know. You don’t have to spend your effort expressing pity for OpenWrt users. Or, you can even be part of the solution - this is an open source project. Get in there and work on the code rather than writing a diatribe about your displeasure.

i already did get in there.

i have the best 867/882/878/2640/2660/3040/3060 firmware in the game. i spent the time and indeed 'worked on the code'.

it just doesn't have station mode which sucks, but oh well.

i know for a fact if i had a 4x4 client device i'd get way more than 500/500. but my desktops are 14 and 10 years old. one uses a wusb600n and the other is a 2012 mac pro with a 3x3 bcm card.

500/500 up down in such circumstances is more than good.

I have three of these units, CAT6 hardwired, as dumbap's throughout my home:
YouHua WR1200JS

Hardwired, I get between 650-670Mbps. 5Ghz WiFi from these units, I'm seeing maybe 200Mbps from my cellphones, and even worse from my HP Laptops (RAlink intergrated WiFi hardware I think). If anyone has good suggestions getting better WiFi download speeds, I'm all ears.

Here is my WiFi config:

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option channel '44'
	option wmm '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'sr_guy-5Ghz-Den'
	option key 'password'
	option encryption 'psk2+ccmp'

not sure about that, are you saying that mtk drivers do not work as station?