[SOLVED] No wireless signal, but enabled wifi

Hi!

Today I updated the firmware on my ASUS RT N56U using Lede 17.01.4. I want to use this system for adblock. After installing the firmware and made all configurations the system worked fine. I had an internet connection on all my devices and the checked blocklists of adblock were updated. But after two hours I didn't had an internet connection on the mobile devices (connected to the wifi). I restartet the router and after that the wifi get a 0% signal and no bitrate. Also adblock has no entries in the logfile. I checked the configurations and restared the router serveral times. The router is behind a cable modem.

root@LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8e:5302:6d5f::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option _orig_ifname 'eth0.1 wlan0 radio1.network1'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'da:50:e6:d8:9c:6d'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'd8:50:e6:d8:9c:6c'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 8t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 8t'

root@LEDE:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'HT20'
        option distance '12'
        option country 'DE'
        option channel '6'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'ssid'
        option encryption 'psk2'
        option key 'key'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option country '00'
        option distance '10'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'ssid'
        option encryption 'psk2'
        option key 'key'
        option network 'lan'
        option disabled '1'

This is the first time I flashed my router, so I'm not an expert :neutral_face:
One solution on my research says to reflash the with OpenWrt firmware, but I think its my fault. Maybe you can help me?

Regards,

Isabell

I made a screenshot, so you know what I mean.

Wfi

Are you certain that you meant to set these parameters that low?

Counting noise, you'd have to be in the same room, with little to no interference. Try changing these settings to 100 meters to see if you can associate clients.

This seems odd...are you sure you don't mean:

option encryption 'psk2+ccmp'

Shouldn't this be 0?

Why is there a country mismatch?

Unless you have a very specific need to do so, these micro-optimizations (e.g. distance) are a very bad idea to begin with - keep it simple.

1 Like

option encryption psk2 is a legitimate setting. I realize you have redacted your real key and posted 'key', but remember a usable PSK key must be at least 8 characters long.

Your 5 GHz AP is definitely not going to come up, since you have explicitly disabled it.

Set the country code to be your country on both radios.

And certainly get rid of those distance lines. Setting the distance should only be necessary on multi-kilometer outdoor links. It relaxes some time parameters to allow more time for the radio waves to travel, which is not necessary for indoor usage. The default distance is usually 2 km.

This is completely normal as long as nothing is associated. There is no signal to measure if no client is connected.

1 Like

Hi!
Thank you for you replies!

I changed the distance to 100, enabled the 5 Ghz AP and set the country code to DE. This is the configuration now:

root@LEDE:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'HT20'
        option country 'DE'
        option channel '6'
        option distance '100'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'ssid'
        option encryption 'psk2'
        option key 'key'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option country 'DE'
        option distance '100'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'ssid'
        option encryption 'psk2'
        option key 'key'
        option network 'lan'

Of course I choose a key with 8 characters :wink:
I restartet the router and this is the new screenshot :sweat_smile:

Wfi2

Now I get a wifi signal on my mobile phone and it works fine!
Hope it will still work in two hours, but now I'm very thankful for your help!!

2 Likes