[SOLVED] No ipv6 on clients after router reboot

Hi all,

It's probably just a configuration issue. When I restart my router it needs some time to get wan connectivity and afterwards still a bit more to get IPv6-PD address (::/56). I would expect the router interfaces and clients to get ipv6 GUA addresses from this point on but it is not happening. At some point it was working before but I am not sure why or why not. Link local and ULA addresses are working fine. Actually my clients are getting two ULAs per interface... someone now why?

my config:
/etc/config/network

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask 'x.x.x.x'
        option ip6assign '64'
        option ip6class 'local wan6'
        option ipaddr 'x.x.x.x'
        option ifname 'eth0.1'
        
config interface 'wan6'                                           
        option ifname '@wan'                                      
        option proto 'dhcpv6'                                     
        option reqaddress 'try'                                   
        option reqprefix 'auto'

/etc/config/dhcp

config dhcp 'lan'
        option interface 'lan'
        option limit '150'
        option start '10'
        option leasetime '30d'
        option ra 'server'
        option dhcpv6 'server'

Just for testing, please add wan_6 to your ip6class definition.

1 Like

Well.. seams to just work :thinking:

I went to the documentation to figure out what I was missing and a general ctrl+F -> wan_6 sure gave me exactly one match.
https://openwrt.org/docs/guide-user/network/ipv6/start

auto : (default) enable IPv6 on the interface. Spawn a virtual interface wan_6 (note the underscore) and start DHCPv6 client odhcp6c to manage prefix assignment. Ensure the lan interface has option ip6assign 64 (or a larger prefix size) set to redistribute the received prefix downstream.

okay... it states for the wan_6 the "_" is important. But what is the reasoning here? From placement in the the docs I would have assumed it only refers to dhcp6 client configuration and not static configuration. Furthermore the WAN_6 interface is shown in Luci but not by ip link show.

I do feel responsible for doing it wrong but I don't really understand it...
Can I delete the wan6 from my ip6class?

And most importantly: Why did it work sometimes before???

Issue probably solved but I would like to have it running a few days to make sure.

You can change the option ipv6 from auto to manual or 1 and the wan_6 will not appear anymore. You can continue with just wan6, which you can customize it to your needs.

It is not a physical interface.

Normally you don't need the ip6class at all. Only if you want to control which IPv6 addresses will be assigned to each downstream interface.

Most likely sometimes the wan6 interface got dhcpv6 faster than wan_6. But it is not correct to run them both.

1 Like

Removing the ip6class solved my client getting 2 ULA addresses which I find a bit strange because the both where same ULA prefix but one ::/64 and one ::128 but works for me :slight_smile:. The whole point of that option was me tinkering with ULAs but since it now seams to work I leave it out.

Is there any benefit I am not aware of yet? In my mind it should be best to have my ISP choose the prefix and OpenWrt handle the rest.

I will test a bit and report back.
Thanks a lot for advice and explanation.

SLAAC

DHCPv6

You can leave it to auto and let all negotiations configure the interface. This usually works fine for most cases. It is not only the size of the delegated prefix you can alter there.

I have tried a bit and all seams good. So issue Solved. I have marked the post of @slh since it was a bit more on point but thanks a lot to @trendy as well for the additional info.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.