[Solved] No Internet on LEDE Router

Hi Guys,
First time here and I seriously need help with this one...
I've purchased BT Hub 5a flashed with "LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)"

For the love of my live I cannot get this thing to connect to internet...
Few details: TalkTalk FTTC.
Existing router works fine no issues when connecting.

When I connect line to hub I can get DSL readings, but no internet. I've spent last 3 days trying to configure it over and over ans still nothing.

Based on this page (https : / / openwrt . org/docs/guide-quick-start/ts-internetconnectivity), I changed my setup to following:
VDDSL --> existing TT router
existing TT router LAN 1 port --> BT Hub (LEDE) WAN port

TT router is

When I login to Luci I can see that Wan6 interface received IP from TT router and it's receiving and transmitting data (mainy receiving). But when i go to diagnostics page and try to pign lede-project.org I get response: ping: bad address 'lede-project.org'
When I try to ping I get100% loss:
PING ( 56 data bytes

--- ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

Any help will be appreciated.
I'm familiar with networking, but this just escapes me... and I'm not sure what I'm missing?

I'm OK with configuring my LAN and Wi-Fi interfaces, just struggle to make those talk to WAN or WAN6 interface.
Currently both WAN's are set to be DHCP clients (I know that DSL side requires different config, but for now I just want to make this talk to internet and confirm that it works).

Thanks in advance...

The BT Home Hub 5 type A defaults to using the VDSL modem as WAN interface (which I'd also suggest to use, instead of another router in front), but https://openwrt.org/toh/bt/homehub_v5a#example_boardjson_tweak should help you, with https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=138 providing some further device and LEDE specific information.

Thank you slh, much appreciated. I'll start reading this now.
Yes, I'm planning on ditching existing TT router altogether, I'm simply trying to work this one out and such setup was suggested on one of random pages I've found about troubleshooting this.

I'll get back to this thread if I'll have any questions.

Thanks for the links slh, it pointed me in right direction and I worked out how to set it up using built in VDSL modem.
I've found solution on Bills manual: https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=175#p1400

Those settings worked perfectly for my ISP: TalkTalk FTTC VDSL connection