[Solved] Netgear xr500: flash openwrt back to stock or dd-wrt?


I am new to OpenWRT and have multiple Netgear XR500 to setup. I am playing with openwrt, stock and dd-wrt firmwares.

One device is running openwrt now, however there seem to be no way back to stock or dd-wrt. Is that true?

Here is what I've tried so far:

  • I've added luci, uploaded dd-wrt firmware but received a warning afterwards as this seems not compatible. So I hesitate to continue via force mode. Shall I continue?

  • I tried to send the stock firmware via tftp as detailed by netgear's docs, but the openwrt router never accepts uploading anything (tried many times from different PCs and OSes).

  • I've finally scp'ed dd-wrt firmware (factory-to-dd-wrt) to /tmp and then did "mtd -r write /tmp/fiemware...bin kernel" but this fails with "Writing from /tmp/XR500-V2.3.2.134.img to kernel ... [e]Failed to get erase block status"

  • I've read that some devices need stripped firmwares but there seem to be none yet for the XR500 ones...

Is there no way to move from openwrt to stock or dd-wrt?

Thanks for any pointers...

Most Netgear supports nmrp recovery, this is a simple way to return to stock. TFTP recovery is very similar in that it works from the bootloader of the router, before the OS even boots, so it will not matter what OS is installed or if that OS is able to boot. TFTP recovery should be activated by holding down the reset button while turning the power on and keep holding the button until the power LED flashes orange. NMRP if supported will load when the router is turned on without pressing any buttons, when the PC is running an NMRP server.

Don't try to install dd-wrt from OpenWRT or vise versa, always return to stock then flash the third party OS.

Using mtd directly is not recommended, it is likely to brick.

No, the TFTP recovery flash should work, writing either an OEM image, a OpenWrt factory image or similar dd-wrt initial install image.

That TFTP is in the u-boot bootloader, so OpenWrt or dd-wrt have no role in enabling/disabling it.

The device-specific advice is well documented since year 2016 for R7800, which is the almost identical older sister of XR500. (The LED colors may vary etc., but that is non-essential for the process itself.)

Not really necessary with R7800/XR500 when using the TFTP recovery, as the current router OS is completely bypassed and replaced with the new OS.

1 Like

Thanks for the super fast responses.

That background info helps understanding what way should work: So, indeed, with the above mentioned details, tftp did finally work with the stock firmware. Well, at least partly, I had to do another 30/30/30 reset afterwards.

So, good to know that trying openwrt is not one-way.

1 Like

First guess:
because OpenWrt does not touch the areas where OEM stores its settings, you probably had the old/original OEM settings still on flash, and the new OEM firmware then found those previous settings (that were incompatible with the version that you flashed).

Ps. There isn't any real 30/30/30 any more. The settings are stored in normal files on flash.