Solved: Netgear WNDR4500v3 - brick / Bootloop after first reboot

Hi there, I'm creating this topic for fellow WNDR4500v3 users. I had this problem and solved it. The problem is similar to Netgear WNDR4500v3 - Bootloop after first reboot which cannot be posted anymore.

After installation and some reboot or short power breaks the device gets into a bootloop. So now an tutorial for solving and installing correctly:

  1. Get "nmrpflash" via github. This is THE tool for repairing corrupted netgear routers (worked better than netcups original support advices).

  2. You need to install npcap-1.31 with winpcp legacy for the program to get the need libaries.

  3. Download the original firmware which is e.g. "WNDR4500v3-V1.0.0.58.img".

  4. Rightclick with pressed shift in your folder in which you have all the tools stored and click on powershell.

  5. do .\nmrpflash.exe -L

  6. poweroff your router with powerclickbutton (you should be connected with lancable)

  7. do .\nmrpflash.exe -i net12 -f .\WNDR4500v3-V1.0.0.58.img BUT changed net12 accordingly to what you saw in the last command with -L. After that turn on power on router again and let it work. When command prompt says it power of and power on the router again.

  8. Now you can get to your normal router software.

  9. Download e.g. netgear_wndr4500-v3-squashfs-factory.img from https://downloads.openwrt.org/releases/21.02.1/targets/ath79/nand/ (see if there is newer realse than 21.02.1). And use that file when doing the firmware update with the original netgear router software.

  10. After installing openwrt this way go and set a password and ssh and connect via ssh (using e.g. putty) to e.g. 192.168.1.1 (or what s your adress) and the set login (root and your password).

  11. do via ssh cd /tmpand wget https://downloads.openwrt.org/releases/21.02.1/targets/ath79/nand/openwrt-21.02.1-ath79-nand-netgear_wndr4500-v3-squashfs-sysupgrade.bin (again maybe set other newer version). you may check hashes like described in https://openwrt.org/de/docs/guide-user/installation/generic.sysupgrade .

  12. then do via ssh sysupgrade -v /tmp/openwrt-21.02.1-ath79-nand-netgear_wndr4500-v3-squashfs-sysupgrade.bin

  13. you will disconnect and wait some minutes. After that power of and power on.

  14. you should be able to use your router fine now.

  15. disable ssh access via browser with lucy (disallow root and generll passwort logins)

explanation/rationale: the installation via firmware upgrade via original router software probably does the installation not completeley correctly. By doing a sysupgrade we do it correctly.

For completion: I also did editing /etc/config/network and on lan interface changed ipaddr to '192.168.2.1' and service network reload, see https://openwrt.org/docs/guide-user/base-system/basic-networking. It was before or after sysupgrade thing, don't know anymore, but i don't think that was the thing fixing it (but if the above didn't you can try with that).

Maybe for the future: If you have e.g. trouble with reset button or something, you can edit or remove by editing script file /etc/rc.button/reset .

Hope this is a shortcut for all other 4500v3 users (and maybe other people ).

Cheers.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.