[Solved] Netgear R7800 DDNS Script terminates with error

Hi folks,
I am new to openwrt/lede so my apologies if this is a stupid question/problem.
I am using the latest image for Netgear R7800: lede-17.01.4-ipq806x-R7800-squashfs

After configuring the DDNS script, luci won't start the service. It terminates with an error looking for "option update-url" that is already part of the script. Please see below. Any suggestions on what I am doing wrong? Thank you!

210952       : ************ ************** ************** **************
 210952  note : PID '15163' started at 2018-04-07 21:09
 210952       : ddns version  : 2.7.6-13
 210952       : uci configuration:
 210952       : verbose mode  : 0 - run normal, NO console output
 210952  WARN : No update_url found/defined or no update_script found/defined! - TERMINATE
 210952  WARN : PID '15163' exit WITH ERROR '1' at 2018-04-07 21:09

Huh...did you also install the template scripts, or just the DDNS service???

I only installed luci-app-ddns and I think it installed a bunch of packages include ddns-script.
Is template scripts a separate installation? If so, I did not install it.
Do I need it? How do I get it and install it?

Thanks for looking at this!

Use either "option service_name" or "option update_url".

currently there are 4 "service_name" predefined inside /etc/ddns/services and ./services_ipv6 for afraid.org

"afraid.org-basicauth"	using url "http://[USERNAME]:[PASSWORD]@freedns.afraid.org/nic/update?hostname=[DOMAIN]&myip=[IP]"
"afraid.org-keyauth"	using url "http://freedns.afraid.org/dynamic/update.php?[PASSWORD]&address=[IP]"
"afraid.org-v2-basic"	using url "http://[USERNAME]:[PASSWORD]@sync.afraid.org/u/?h=[DOMAIN]&ip=[IP]"
"afraid.org-v2-token"	using url "http://sync.afraid.org/u/[PASSWORD]/?address=[IP]"

Inside LuCI you can select one of them and fill in the Username/Password as required.

1 Like

You are awesome, Chris5560!

Using "afraid.org-keyauth" as the service_name worked wonderfully.

Thank you very much!!
Problem Solved!!

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.