[SOLVED]Netgear R6220 bricked

while installing openwrt to netgear R6220, it got bricked.
not its not booting or when i try to recover using tftp method, its not responding.
i followed flashing instructions as in https://openwrt.org/toh/netgear/netgear_r6220

Installation through telnet:

  • Copy …-kernel.bin and …-rootfs.bin (see table above) to a USB flash disk, plug to USB port on the router

  • Call the link: http://[IP-address]/setup.cgi?todo=debug (login if required, default: admin - password)

  • You will see “Debug Enabled!”

  • telnet IP-address and login with “root” (default: admin - password)

  • ls /mnt/shares/ to find out path of your USB disk - myUdisk for example

  • cd /mnt/shares/myUdisk

  • mtd_write write rootfs.bin Rootfs

  • mtd_write write kernel.bin Kernel

  • reboot

Hmm , that device page is pretty patchy..

in any case , the window on most devices where the tftp connection can be made is very small - few seconds a most. On this point have you confirmed the tftp IP address is correct (its usually different to when the router normally boots) and your client machine has an ip in same subnet to match? Similarly, have you hard-set the mac address arp entry of the tftp (also usually different) on your client so it transmit the firmware image straight away when the router boots?

Theres a chance you have hit this issue too:

Update 2018-11-08: There has been a bug filed with regards to this behavior stating that in case of bad erase blocks prior to the factory partition OpenWrt uses incorrect/shifted offset addresses to access the factory partition. If this bug is confirmed this may the reason for the behavior reported by several users. Please follow the bug status over here: https://bugs.openwrt.org/index.php?do=details&task_id=1926

If so , youre likely gonna need serial to recover it

1 Like

thanks Sparks. the issue got resolved. i contacted the support team of netgear and it seems there are some steps to follow to reset the router. i followed steps and i could see ping happening for few times after bootup. in that window, i started tftp with few retries set in tftp2.exe
and it started flashing.

  1. To reset your router to factory defaults, press and hold the reset hole using a paperclip while the device is plugged in for 30 seconds.
  2. Release the button and wait for the router to reboot.
  3. Unplug the router for 20 seconds and after 20 seconds, plug in the router. Wait for the power icon to stabilize its connection.

Nice one :+1:

If youre happy with the result, can you mark this thread resolved / edit the thread title with “(solved)”. It helps others in future that are searching for solutions to find them easier

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.