[Solved] Need help connecting openwrt router to ISP modem

I need help to connect openwrt router to ethernet
i have connect ethernet cable from ISP Modem to openwrt router (port 1)
and connect ethernet cable from openwrt router to my pc (port 2)

I have set the modem according to this guide

and i can enter the modem login page

the problem is, i have no internet connection.
I have no idea how to enable ethernet connection in openwrt

here is my openwrt settings


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fdbc:6072:332d::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option ifname 'lan1 lan2 lan3'
	option ipaddr '192.168.2.1'

config interface 'modem'
	option proto 'static'
	option ifname 'wan'
	option ipaddr '192.168.100.2'
	option netmask '255.255.255.0'

is there something i need to configure in order to access the internet?

You have no gateway set.

2 Likes

Your config is missing a working 'wan' interface. Did you delete it?

The wiki instructions are for adding a 'modem' interface to work alongside a functioning 'wan' interface.

LAN devices connect to internet via 'wan' interface.

The 'modem' interface is only used for managing the ISP modem (eg. cable modem) operating in 'bridge' mode. It is not required if ISP modem is operating in 'router' mode.

Please provide more information about the ISP modem.
Specifically, is it operating in 'router' mode, or in 'bridge' mode?

If you connect a PC directly to the ISP modem, what is the IP address assigned to the PC and does it connect to the internet?

2 Likes

i'm sorry but how can i do that?
how to fill gateway to the router menu?

yes, i delete it yesterday....
i ended up flashing new firmware just now to get those interface back, but still no internet connection available

i'm sorry but how do i know if the ISP modem operating in router mode or bridge mode?
those ISP modem is in original firmware (no openwrt)

the ISP Modem ip address is 192.168.100.1

What do you normally use with the ISP modem for successful internet access?

Can you connect a computer to the ISP modem ethernet port?
Does PC connect to internet?
If yes, what is the IP address assigned to the PC ?
(For Windows PC, use 'ipconfig /all' command to reveal IP address, gateway, DNS etc)

This PC test may reveal if ISP modem is in 'router' mode or 'bridge' mode.

Alternatively, log into the ISP modem (192.168.100.1) and provide some screenshots of the main menu options?

Does your ISP have a modem information web page?

What is the make and model number of the ISP modem?

1 Like

i had another router (tp link with dd-wrt) and it works... but this router is too old (have used it for about 5 years) and have connectivity problems, so i change to a new one... i flash it with openwrt and have no clue how to setup the connection

if i connect my computer to ISP Modem ethernet port, it has no connection (but if i connect it to my tplink router the internet connection works)

here is my /ipconfig all result

Windows IP Configuration

   Host Name . . . . . . . . . . . . : WIN-U10PLKKRHEA
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Unknown adapter VPN - VPN Client:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VPN Client Adapter - VPN
   Physical Address. . . . . . . . . : 5E-C9-BA-89-3A-1D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Ethernet 4:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) 82583V Gigabit Network Connection
   Physical Address. . . . . . . . . : AC-22-0B-4F-87-86
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::c917:7a8d:7e2e:dbb3%18(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.100.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 296493579
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-2A-09-E2-1B-74-27-EA-47-34-60
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

this is my isp web page (192.168.100.1)

You appear to have disabled DHCP for IPv4 on your Windows computer?
What happens when you turn on DHCP on PC?

What are the WAN settings on old working TPlink router?
Is it just set up for DHCP client or something else?
What IP address is reported on WAN interface of old TPlink router?

What is make and model number of ISP modem?

1 Like

Is WAN settings the same with ipconfig all command?
if yes, this is the result

Windows IP Configuration

   Host Name . . . . . . . . . . . . : WIN-U10PLKKRHEA
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Unknown adapter VPN - VPN Client:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VPN Client Adapter - VPN
   Physical Address. . . . . . . . . : 5E-C9-BA-89-3A-1D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Ethernet 4:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) 82583V Gigabit Network Connection
   Physical Address. . . . . . . . . : AC-22-0B-4F-87-86
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::c917:7a8d:7e2e:dbb3%18(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.145(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, June 23, 2023 7:16:06 PM
   Lease Expires . . . . . . . . . . : Saturday, June 24, 2023 7:16:06 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 296493579
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-2A-09-E2-1B-74-27-EA-47-34-60
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

My ISP Modem is CM5100.d1

If the ipconfig/all output showing 192.168.1.1 is from your PC connected to tplink router, then answer is NO.

You have to log into the tplink router (192.168.1.1 and find the WAN interface settings and current WAN IP address. I have not used ddwrt in many years but if tplink has ddwrt, try:

Setup > Basic Setup > WAN setup

Look in 'Status' tab for current IP address

After turning on DHCP, does PC now have internet when connected to the ISP modem?
Update: @mk24 is correct to point out with cable modems, you may have to power cycle them when changing to a different router (or computer)

1 Like

This looks like cable Internet. The ISP has probably locked to the MAC address of the old router. In most cases if you unplug the modem from the power supply and wait 30 minutes, the cable system will forget the MAC address and let you use a new router when you start it back up. Sometimes you may need to call the cable company or log in to your account from another Internet connection.

With a cable modem you do not need to create a "modem" interface. Since the modem is IP based (not pppoe) and the default route you can simply go to 192.168.100.1 from the LAN and it will route to wan and reach the modem without additional setup. (This does require the wan to have completed dhcp at least once. If the cable system is completely down it will not do that.)

3 Likes

here is the info from dd-wrt page
is wan ip the number from top right page?

is there anything i need to do with the wan ip to the openwrt router?

let me try it, thanks for the suggestion :grinning:
i will update the result later

ddwrt is using factory default DHCP client connection protocol.

Your ddwrt screenshots show WAN IPv4 address is 10.187.192.224. (CGNAT network?)

For your openwrt router (or PC), it should work with default DHCP client settings.

Try rebooting the cable modem as suggested by @mk24 in first instance.

ps. your cable modem is operating in 'bridge' mode.

2 Likes

it works, resetting the modem solves the problem
thank you all

1 Like

Please mark as Solved.

btw, you could try cloning the WAN MAC address from old TPlink router

WAN MAC     64:66:B3:66:0F:1C

to your new OpenWrt router.

1 Like

how can i do that?
which menu do i have to enter to clone the wan mac address?

I don't know what router you have and I don't have an OpenWrt 22 router in front of me at the moment., but try this method

Make a backup of the openwrt settings before you change anything.

Look in the LuCI -> Network -> Interfaces. Note down the current MAC address for the WAN interface.

From an earlier post for 'wan' interface, It may be
28:D1:27:87:5A:64 ??

LuCI -> Network -> Interfaces -> Devices tab

Identify the 'device' with matching MAC address (ie. 'wan')

Click 'Configure'

Enter the new WAN MAC address (from old ddwrt router)
64:66:B3:66:0F:1C

Save & Apply.
Reboot router for changes to take effect.
Reboot ISP modem too.

Another possible method is to use an editor to open /etc/config/network file. Find and replace the MAC address, then reboot the router and ISP modem I use WinSCP windows utility.

ps. I have seen posts where MAC cloning/changing may not work with some ISPs. I think it is due to how openwrt on the device behaves during boot up. Someone will correct me if I'm wrong.

Good luck.

1 Like

thanks a lot for the guide mr bill888

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.