[SOLVED] MX60W - Commands don't work

Finally was able to get my USB to UART cable to work and followed these settings here: https://github.com/riptidewave93/LEDE-MX60-MX60W/blob/master/README.md#flashing

I get to step 3 where it should be booting from TFTP but I'm not sure it actually does.

Here is my output after the flash commands and booting the device:

U-Boot 2009.08-00049-g0ee25dd Meraki MX60 (Jul 27 2012 - 14:59:20)

CPU:   AMCC PowerPC  UNKNOWN (PVR=12c41c83) at 800 MHz (PLB=200, OPB=100, EBC=10             0 MHz)
       Bootstrap Option D - Boot ROM Location NAND wo/ECC 2k page (8 bits), boot             ing from NAND
       32 kB I-Cache 32 kB D-Cache
Board: Buckminster Wireless - Meraki Buckminster Wireless Cloud Managed Router
BoardID: 0 0
Reset Button Status: 1
I2C:   ready
DRAM:  512 MB
NAND:  1024 MiB
I2c read: failed 4
I2c read: failed 4
I2c read: failed 4
Net:   ppc_4xx_eth0
Initializing Bluestone Ethernet Port ...
Disabling port 0
Disabling port 1
Disabling port 2
Disabling port 3
ENET Speed is 1000 Mbps - FULL duplex connection (EMAC0)
*** ERROR: ping address not given
RESET is un-pushed

Set serverpath and run meraki_netboot to netboot

Hit any key to stop autoboot:  0
Creating 1 MTD partitions on "nand0":
0x000000240000-0x000040000000 : "mtd=2"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size:   131072 bytes (128 KiB)
UBI: logical eraseblock size:    129024 bytes
UBI: smallest flash I/O unit:    2048
UBI: sub-page size:              512
UBI: VID header offset:          512 (aligned 512)
UBI: data offset:                2048
UBI: attached mtd1 to ubi0
UBI: MTD device name:            "mtd=2"
UBI: MTD device size:            1021 MiB
UBI: number of good PEBs:        8168
UBI: number of bad PEBs:         6
UBI: max. allowed volumes:       128
UBI: wear-leveling threshold:    4096
UBI: number of internal volumes: 1
UBI: number of user volumes:     4
UBI: available PEBs:             3398
UBI: total number of reserved PEBs: 4770
UBI: number of PEBs reserved for bad PEB handling: 81
UBI: max/mean erase counter: 268/264
kernel volume not found
recovery volume not found

Any thoughts as to what I'm doing wrong?
I have a Cat5e cable plugged into WAN1 and the IP address set to on my laptop as well as running tftp32 but the document also refers to a "buck.bin" which I'm not sure where that file is.

Thanks for any help!


You need to setup a TFTP server, you need to make the LEDE BIN file buck.bin.

After you boot, you need need to get network access to install recovery, see here about that:

Afterward, you will flash the sysupgrade to work as normal.

OK, if you get:

This means you already wiped the partitions. You need to boot the TFTP image to:

  • access the UBI software
  • ensure you deleted the other partitions
  • rearrange the board-config to ubi0_0
  • to create the recovery partition and flash the BIN file to it
  • to access LuCI and flash the sysupgrade TAR file (please note that I was only able to flash the MX60 sysupgrade - see thread linked in my post above).

That's the OpenWRT BIN file you download from downloads.openwrt.org. You must rename it to buck.bin so that it will TFTP and boot the router.

You also need that BIN file to save as the recovery image (please note there's a LAN issue with the BIN files, my thread above links to workarounds in order to proceed (A. - editing the network config; or B. - using a second device and editing the firewall to access LuCI via the WAN). Also, if you accidentally erased board-config already, the threads above has access to a copy for you.


I've tried this 3 times already with the same result.

How do I get the system to boot buck.bin and continue?

I've tried tftpboot buck.bin which loads the file but does nothing else.

I type version and get the following:

U-Boot 2009.08-00049-g0ee25dd Meraki MX60 (Jul 27 2012 - 14:59:20)

I follow the commands and do savenv but I still get the same results. I'm scratching my head here and appreciate any insight.

You were supposed to boot and get LuCI first. Did you?

Otherwise, you proceeded further.

I did the following:

  • I took a machine whit a NIC card
  • I assigned the IP and configured my TFTP software. I used the 17.01.4 BIN file, and renamed it buck.bin
  • I attached the serial cable and opened my terminal software
  • The countdown stops in 2 seconds, I hit a key before it proceeded
  • I enter:

setenv serverpath; setenv netloadmethod tftpboot; setenv bootargs console=ttyS0,${baudrate} rootfstype=squashfs mtdoops.mtddev=oops; run meraki_load_net meraki_checkpart meraki_bootlinux

  • It booted

From there, you perform the steps in my other post. If you read the threads I linked, you will see there's 2 options to get the network operational in order to flash recovery and 17.01.4 MX60 (in my case) to the router.

Also understand:

Ok, found my breakthrough. I was missing the "Booting" commands.

I'm stuck at step #6 now. Getting the file over to the device. Going to try to disable my internet connection and try again.

So I can't ping the firewall while it is booted using buck.bin.

Trying to figure out an easy way to get the lede-17.01.4-apm821xx-nand-mx60w-initramfs-kernel.bin over to the device so I can finish step 6.

Are you sure you read my thread about the issues with the images???

You seem stuck exactly where I was...before I solved it.

I've mentioned a few times the network issue and the workarounds.

Do you have a MAC address, does it match the label? (Checking if board-config is present)

I'm looking at your post but don't see any of the steps listed that solved this issue for you.

You talk about having LuCI and flashing mx60 but you don't have the steps listed that got you to that place.

My /etc/config/network matches yours as well.

I'm sorry that I'm asking so many questions. I'm new to linux and have been trying to learn the command line after years of DOS and Windows commands.

I do appreciate your help.

In post 1 of the "Issues with Meraki MX60 and MX60W Images" thread:

There are 2 links.

  • The first is from someone else who used the serial to edit eth0.2 to LAN, then applied the changes after confirming they were accurate. They seem to have then accessed LuCI and flashed the router (I have not confirmed this procedure).
  • In the other, I independently came to the same issue (but noticed that WAN was making DHCP requests) and used a second device to make a tagged LAN port that used VLAN ID 2. I then made an iptables rule to allow port 80 on WAN. I then accessed LuCI and flashed the MX60 image.

This is not necessarily a N00b issue, the Merakis are newer device being supported (likely because most are still under support by their OEM)...the images for version 17 have a slight config issue.

Hope this helps.

Ok. Got the network file edited as I didn't see you posted two links. duh.

Got the initram file over to tmp but the command makes a 5mb partition and the initram.bin is over 6.

Now I need to figure out how to delete that first recovery partition.

If you have already successfully moved board-config to 0_0, then you should be able to wipe all other UBI using similar commands on the github site.

ubinfo -a

Will list all the partitions.

From there you can delete them using the remove command with -N (do not delete board-config at 0_0!!!) and then re-create the recovery, get the image, flash it to 0_1, etc.

From there, you sysupgrade. Please recall if you ever have to hold the reset button to boot recovery will have to access LuCI again the same way...until v18 is released - and you flash that BIN to recovery.

(I'm not sure the instruction make the U-Boot environment edit the reset button to boot recovery, I think it only boots if the main image is missing.)

This is the fun I get now:

root@LEDE:/etc/config# ubiupdatevol /dev/ubi0_1 /tmp/lede-17.01.4-apm821xx-nand-
ubiupdatevol: error!: "/tmp/lede-17.01.4-apm821xx-nand-mx60w-initramfs-kernel.bin" (size 6386688) will not fit volume "/dev/ubi0_1" (size 129024)

root@LEDE:/etc/config# ubinfo -a
UBI version:                    1
Count of UBI devices:           1
UBI control device major/minor: 10:59
Present UBI devices:            ubi0

Volumes count:                           3
Logical eraseblock size:                 129024 bytes, 126.0 KiB
Total amount of logical eraseblocks:     8168 (1053868032 bytes, 1005.0 MiB)
Amount of available logical eraseblocks: 7951 (1025869824 bytes, 978.3 MiB)
Maximum count of volumes                 128
Count of bad physical eraseblocks:       6
Count of reserved physical eraseblocks:  154
Current maximum erase counter value:     268
Minimum input/output unit size:          2048 bytes
Character device major/minor:            252:0
Present volumes:                         0, 1, 2

Volume ID:   0 (on ubi0)
Type:        dynamic
Alignment:   1
Size:        1 LEBs (129024 bytes, 126.0 KiB)
State:       OK
Name:        bg
Character device major/minor: 252:1
Volume ID:   1 (on ubi0)
Type:        dynamic
Alignment:   1
Size:        1 LEBs (129024 bytes, 126.0 KiB)
State:       OK
Name:        board-config
Character device major/minor: 252:2
Volume ID:   2 (on ubi0)
Type:        dynamic
Alignment:   1
Size:        57 LEBs (7354368 bytes, 7.0 MiB)
State:       OK
Name:        recovery
Character device major/minor: 252:3



YOUR 0_0 is bg!?!?

Something's wrong...

UPDATE: I think you should get a copy of your 0_1 (board-config.img) move it to /etc/config so you can use LuCI to get a backup config of it....and use a HEX Editor to verify it is in fact the board config.

Hmm. Hopefully I didn't screw this up.

I flashed the recover to 0_2 and ran reboot.

The device rebooted and LuCi is accessible after I edited the /etc/config/network to remove the vlan tagging.

Should I start from scratch again to make sure board_config is 0_0? When I ran the initial commands

ubinfo /dev/ubi0 -N board-config

The volume id was 2 for board_config.


To be honest, it's your choice...I usually flow the adage "if it ain't broke, don't fix it..." but I'm not sure how the images will expect the UBI layout to be in futures versions...

You should be able to proceed to flash sysupgrade from here...since you should be able to boot by TFTP and the recovery from this point.

I surmise this means, you successfully booted into OpenWRT from the recovery you were able to flash after editing /etc/config/network...

The choice to rearrange the partitions is yours. DO SO AT YOUR OWN RISK.

No, can't flash as I get an error.

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Are you using the MX60 TAR image???

What version of OpenWRT are you using for the BIN???

If you prefer to force the upgrade of the 'bad' TAR, you have to use another workaround...

This exact problem is noted in my Solved thread and is explained in the MX60/W image issues thread.

So it will flash the MX60 image, not the MX60W.

Not that I was planning on using the wireless function on this.