[solved] multi-SSID hardware

Hello friends,

Is it possible to build a multi-SSID device with any WLan hardware?

If not:

  • which Wlan hardware do I need?
  • How to find out if a hardware is multi-SSID capable?

currently I have the following devices to choose from:

  • ID 0bda: 8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter to a raspberry1
  • GL.iNet GL-AR750
  • GL.iNet GL-MT300A

Does MIMO have anything to do with Multi-SSID?

Best regards

A PCI or internal (built into the CPU system on chip) Atheros or MediaTek will fully support multi-SSID. Hardware connected by USB may not, especially if it is Realtek.

If you have the hardware in place and running under OpenWrt (or other Linux) use the iw list command to show the capabilities of the hardware and driver. The "interface combinations" section shows how many APs can be run simultaneously.

MIMO is a different concept. Think of it as a form of modulation. When a radio is MIMO capable, it will try to use it on all links to any device on any SSID.

Thank you, great answer!

My GL.iNet GL-AR750 says
@ 2.4GHz
valid interface combinations:
* # {managed} <= 2048, # {AP, mesh point} <= 8, # {P2P-client, P2P-GO} <= 1, # {IBSS} <= 1,
total <= 2048, #channels <= 1, STA / AP BI must match, radar detect widths: {20 MHz (no HT), 20 MHz, 40 MHz}

@ 5.8GHz
valid interface combinations:
* # {AP, mesh point} <= 8, # {managed} <= 1,
total <= 8, #channels <= 1, STA / AP BI must match, radar detect widths: {20MHz (no HT), 20MHz, 40MHz, 80MHz}

What does that mean? On 2.4GHz 2048 SSIDs and on 5.8GHz only 1 SSID possible?

On either radio, the number of APs and / or mesh points may be up to 8.

Managed is also known as a STA or a client. The 5 GHz can only run one such interface. It is very unusual to have a use case that needs to run more than one STA interface on a radio.

Since the internal radio on my router is acting up; I am trying to use a USB stick.
First I tried a TPlink with car9170 module: two SSIDs worked but the hw was flaky (and I knew that already, so I discarded it).

Now I am trying this one:
050d:705a Belkin Components F5D7050 Wireless G Adapter v3000 [Ralink RT2571W]

When I configure it for 2 SSIDs on 2 VLANs, the wifi interfaces will show only outgoing packets and nothing received. Is this what happens when the hw does not support multiple SSIDs?

valid interface combinations:
	 * #{ managed, AP, mesh point } <= 4,
	   total <= 4, #channels <= 1

The driver reports that you can have up to 4 SSIDs, at least as I read that.

Since the interfaces are appearing, from the sound of it, the problem is elsewhere.

I've never had much luck with Ralink chipsets and AP mode.

What do the messages in dmesg and logread show?

1 Like

I saw nothing out of the ordinary:

[   36.176684] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt73.bin'
[   36.331162] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 1.7
[   36.464341] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   36.498715] br-lan: port 2(wlan0) entered blocking state
[   36.504154] br-lan: port 2(wlan0) entered disabled state
[   36.510037] device wlan0 entered promiscuous mode
[   38.872422] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   38.879223] br-lan: port 2(wlan0) entered blocking state
[   38.884660] br-lan: port 2(wlan0) entered listening state
[   38.899308] br-guest: port 2(wlan0-1) entered blocking state
[   38.905381] br-guest: port 2(wlan0-1) entered disabled state
[   38.911508] device wlan0-1 entered promiscuous mode
[   38.999973] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
[   39.006488] br-guest: port 2(wlan0-1) entered blocking state
[   39.012270] br-guest: port 2(wlan0-1) entered listening state
[   39.906330] br-guest: port 2(wlan0-1) entered disabled state
[   40.484659] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
[   40.491633] br-guest: port 2(wlan0-1) entered blocking state
[   40.497452] br-guest: port 2(wlan0-1) entered listening state
[   40.945161] br-lan: port 2(wlan0) entered learning state
[   42.545134] br-guest: port 2(wlan0-1) entered learning state
[   43.025083] br-lan: port 2(wlan0) entered forwarding state
[   43.030697] br-lan: topology change detected, propagating
[   44.625144] br-guest: port 2(wlan0-1) entered forwarding state
[   44.631112] br-guest: topology change detected, propagating

Same in logread, it looks like with the tplink I tried earlier. Only clue something isn't right, beside not having working wifi, is that the two interfaces never receive anything.

Thanks for the feedback. Unless you have a burning desire to get to the bottom of this issue, I'm ok with disabling the guest ssid and leaving it like that, since I just ordered a Fritzbox 4040 to replace it.

rt2571 is an ancient 802.11g USB card, which never really got 100% reliable - in STA mode, not even talking about AP mode…

(rt2571 != rt73, while rt73 is has better support than rt2571, it's not all glory either, still 802.11g, still USB with serious firmware limitations basically making AP mode impossible in the first place (no support for powersaving clients)). These devices were never made or tested for AP mode support, and that shows - primarily in the given firmware support (bugs, missing features, etc.), but also the driver side - that's before even looking at thermal issues arising from 24/7 continuous operations and the antenna designs.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.