[Solved] Multi-point Communication

Greetings! This is my first time in this forum. I don't really know how to look for the answers I need so I'm just gonna ask myself.

I have a little router that's intended to be used over LTE, but I'm not using it for that purpose.

I've taken this router and set it up in my own home and connected the WAN port to an Ethernet cable that goes upstream to my actual house router. I need it set up this way because I play a lot of fairly active games and having a poor wireless connection through cinder blocks is not effective. It's also connecting my computer and Octoprint instance to the internet.

I can easily get access to WAN with the current set up, but people upstream on the base router cannot see any devices on this sub-net.

In short, Devices on "ARRIS-500A", my Internet provider's router, cannot see devices connected to "OpenWRT", the network connecting to Octoprint, servers, consoles etc. However, devices on "OpenWRT" can access devices on "ARRIS-500A".

What configuration changes do I need to make for this to work? I need access to my printer and servers when I'm upstairs.

What is the device?

ubus call system board

What you probably want is to set this up as a basic bridged AP.

https://openwrt.org/docs/guide-user/network/wifi/bridgedap

1 Like

I am in the GUI of the router, as im tethered through ethernet, the device name is "Zbtlink ZBT-WE826 (16M)"

What is the output of the above command when you connect via ssh?

oh you wanted that through SSH okay gimme a sec

root@OpenWrt:~# ubus call system board { "kernel": "5.15.150", "hostname": "OpenWrt", "system": "MediaTek MT7620A ver:2 eco:6", "model": "Zbtlink ZBT-WE826 (16M)", "board_name": "zbtlink,zbt-we826-16m", "rootfs_type": "squashfs", "release": { "distribution": "OpenWrt", "version": "23.05.3", "revision": "r23809-234f1a2efa", "target": "ramips/mt7620", "description": "OpenWrt 23.05.3 r23809-234f1a2efa" } }

Ok... that looks good.

Just follow the link I provided above to create a basic bridged AP.

Alright, i'll let you know if something explodes lol

The first step says to change my /etc/config/network file, im assuming, this is what i want? or should i change it up
image

yes and no.

For the IP address, that is correct. The rest of the syntax of that looks very wrong.

Please post the current configuration:

cat /etc/config/network

so i created a new problem, i pushed this update without thinking about it and it, got me on my main network, however now i cant access the router by wire or wireless, it just kind of ceased to exist in my upstream routers device list

Reset it to defaults using failsafe mode:
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

Okay, I'm back online. Here's my current config:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd35:d1dc:d345::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr 'f8:5e:3c:06:ba:61'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'```

Great....

The only changes that should be made are:

  • to the above stanza to change the IP address (192.168.0.2 per your earlier post)
    • you may optionally add the gateway and dns lines as you have in that screenshot
  • Disable the lan DHCP server on this device
  • Enable wireless (set the country code, set the SSID, encyption type, and pass phrase, and then enable the radio).

Then connect a cable to one of the lan ports of this device and you should be good.

Good news and Bad news, Good news is i'm connected to the internet with a WAN cable plugged into a LAN port rather then wan as per the configuration, However, the router's configuration page is no longer accessible no matter what i try.

Can you provide a diagram of the devices and connections, please? That would make it more clear.

To be clear...

In other words, it should be a lan-lan connection, unless I'm misunderstanding your desired configuration or your topology.

This is the best i can produce to explain it.
I have however figured out how to access the OpenWRT router config, just requires force changing my default gateway from 0.1 to 0.2


In short, Devices upstairs are connected to the ISP's router
They requested stuff from Octopi.lan which is on the openWRT router, connected by ethernet,
Octopi never hears the request

There should be a cable between the lan of the ISP router and the lan of your OpenWrt router (not the wan port)

You should not require any changes in the default gateway.

Let's see your complete configuration of the OpenWrt router:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@FloofBox:~# ubus call system board
{
        "kernel": "5.15.150",
        "hostname": "FloofBox",
        "system": "MediaTek MT7620A ver:2 eco:6",
        "model": "Zbtlink ZBT-WE826 (16M)",
        "board_name": "zbtlink,zbt-we826-16m",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ramips/mt7620",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}
root@FloofBox:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd35:d1dc:d345::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.0.2'
        option gateway '192.168.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr '----'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

root@FloofBox:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10180000.wmac'
        option channel '10'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'FloofBox'
        option encryption 'psk2'
        option key '-----------' (I've blanked this for my own safety)

root@FloofBox:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option dynamicdhcp '0'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@FloofBox:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

For reference, i disabled and stopped odhcpd and odns by service commands

You did not disable the DHCP server on the lan.... it should look like this:

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

Reboot the AP and then try again (with a lan-lan connection)