[SOLVED] MR 18 build 22-142110 using Method B then A can't use WGET


I'm trying to install OpenWRT on Meraki MR18 (build 22-142110), I follow the Method B (modify serial number) then successfully access to the root shell (after pressing 's') at the startup.

Unfortunatelly I can't use the wget command as it seems to not be install on the BusyBox version installed on the meraki (BusyBox v1.01)

My dhcp server is ready and UP
My website with openwrt sources is UP

I'm stuck at the point 4, 5 and 6 method A (https://oldwiki.archive.openwrt.org/toh/meraki/mr18)

I also tried the Method C with the odm firmware part2 but it told me the url is not http or ftp.

Did anyone already see this issue? or maybe have something for me to continue investigation?

PS : I don't know if it happens but to access to the root shell, it's very difficult, I need to press the reset button to reboot the AP then have the "s" choice which failed everytime so i've to restart again before pressing correctly the "s" button and arrive to the shell (not but "/#"

Many thanks for your help.


New URL: https://openwrt.org/toh/meraki/mr18

The old page is for archival purposes only and does not receive updates any more.

1 Like


Sorry mistake from my side. I use the new one.
In fact, I use all process i saw without any result.

Even if I went to the point 6, the wget command is missing.
Is there another way to download the image without wget?

Thank you in advance.


Just to update for futur people who get this issue.
It works for me, in fact, I had to

  • remove the RX pin (on the MR18)
  • press s + plug the power.
    -replug the RX and work on the shell

Once the wget done,

  • remove the power,
  • unplug the RX,
  • press 2 +plug the power
    -plug the RX pin and check the screen then the webpage

Hope this help

thanks for the info. glad to see that method B worked.
what you say means that to successfully use the "S" or "2" key at boot time, you were required to disconnect the Rx line of the serial adaptor. on a bare full duplex serial connection with no flow control the Rx line connection should not matter. In particular, the MR18 is sending out data on this line, and cannot "know" if it is connected or not. So there must have been something going on in your terminal software, or your serial USB adapter.

In fact i found tips on another forum but to remove the TX pin before power on. On my side it didn't work , i was able to sexe the screen but cannot write anythings. So I tried to remove RX pin and it works.
What i didn't Say is i was not able to power up the mr18 with the UART USB plugged, on Putty it was unreadable (like crypted or chinese). I don't why but for me it was the only solution. That's why i want to share after working on it during 3 days.

do you still remember your serial port terminal settings? was xon/xoff flow control enabled?
you may also want to flag the thread as "solved".


Sorry for the delay.
Default settings so by memory it's set as enabled.


so this might be the culprit. When the MR18 boots, it sends text to the terminal. Maybe the terminal does some XOFF/XON flow control, and the character to change boot behavior (the "s" or the "2" in our case) arrives in 2nd position, and is ignored. Anyway, just in case, I put a note about switching off flow control on the device page.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.