[Solved]Missing libiwinfo-lua

I installed the snapshot image on my AC51U and installed all the ipks for minimal LUCI offline install.

When I tried to access the wireless config via LUCI, it shows "Package libiwinfo required!
The libiwinfo-lua package is not installed. You must install this component for working wireless configuration!"

libiwinfo is installed, i searched for the libiwinfo-lua package but cant find it anywhere. Am i checking this right?

I am looking here for the ipk file.

The libiwinfo-lua package is target specific, therfore it is located in another directory. You'll find it at https://downloads.lede-project.org/releases/17.01.4/targets/ramips/mt7620/packages/libiwinfo-lua_2016-09-21-fd9e17be-1_mipsel_24kc.ipk

excellent, thank you. that worked great.

Now I need to find instructions on how to use this as a Brigde client. I have a portable wifi that has limits on number of clients.
So, i need my lede router to connect to portable wifi and share its internet to all clients that is connected to my lede router. not familiar with the LEDE interface, so not sure where to look/how to proceed.

Any pointers would be appreciated.