[solved] Mariadb/mysql update

I would like to update the 5.1 version of mysql with a more recent one but I'm seeing the following error, despite managing to pass most of them I can't bypass this

staging_dir/target-x86_64_musl/usr/include/uClibc++/limits:24:2: warning: #warning limits header is nowhere complete or accurate [-Wcpp]
 #warning limits header is nowhere complete or accurate
In file included from staging_dir/target-x86_64_musl/usr/include/uClibc++/map:24:0,
                 from build_dir/target-x86_64_musl/mariadb-10.2.4/storage/innobase/include/ut0new.h:125,
                 from build_dir/target-x86_64_musl/mariadb-10.2.4/storage/innobase/include/sync0types.h:33,
                 from build_dir/target-x86_64_musl/mariadb-10.2.4/storage/innobase/include/univ.i:657,
                 from build_dir/target-x86_64_musl/mariadb-10.2.4/storage/innobase/include/ha_prototypes.h:32,
                 from build_dir/target-x86_64_musl/mariadb-10.2.4/storage/innobase/dict/dict0dict.cc:31:
staging_dir/target-x86_64_musl/usr/include/uClibc++/associative_base: In function 'dberr_t dict_table_rename_in_cache(dict_table_t*, const char*, ulint)':
staging_dir/target-x86_64_musl/usr/include/uClibc++/associative_base:444:8: error: 'void std::__base_associative<Key, ValueType, Compare, Allocator>::swap(std::__base_associative<Key, ValueType, Compare, Allocator>&) [with Key = dict_foreign_t*; ValueType = dict_foreign_t*; Compare = dict_foreign_compare; Allocator = ut_allocator<dict_foreign_t*>]' is protected
   void __base_associative<Key, ValueType, Compare, Allocator>::swap(__base_associative<Key, ValueType, Compare, Allocator>& m)
build_dir/target-x86_64_musl/mariadb-10.2.4/storage/innobase/dict/dict0dict.cc:1996:32: error: within this context
storage/innobase/CMakeFiles/innobase.dir/build.make:542: recipe for target 'storage/innobase/CMakeFiles/innobase.dir/dict/dict0dict.cc.o' failed

@jow I see you as the maintainer of mysql, can you give me a hint ?

thanks !

Tried and failed many times and finally gave up. I sent email to package maintainer. He suggested to try the makefile as below. End up with failure too.

If you only want to deploy WordPress, mysql-server 5.1.73 works. If you want to deploy owncloud which needs at least mysql-server 5.5, try postgresql in official repo. It works too.

For me, I just bought Raspberry Pi 3 with Raspbian installed. I'm running mysql-server 5.7.17 and php7 on it. All works fine. No more frustrating.

on 10+ I get the same errors but I managed to build 5.5.54, I'll cleanup the patches and makefile and make a mariadb pull request
maybe on 10+ I'll try with the TokuDB engine as it is failing on InnoDb engine


how are you?
is there any info on this?
I would like to make a small package from GitHub so I can build you code.

warning limits header is nowhere complete or accurate

#warning redirecting incorrect #include <sys/poll.h> to <poll.h>

/build/source/staging_dir/toolchain-arm_cortex-a9+vfpv3_gcc-5.4.0_musl-1.1.16_eabi/lib/gcc/arm-openwrt-linux-muslgnueabi/5.4.0/../../../../arm-openwrt-linux-muslgnueabi/bin/ld: copy reloc against protected `__stack_chk_guard' is dangerous
../../mysys/libmysys.a(my_context.c.o): In function `my_context_spawn_internal':
my_context.c:(.text+0x24): undefined reference to `setcontext'
../../mysys/libmysys.a(my_context.c.o): In function `my_context_continue':
my_context.c:(.text+0x8c): undefined reference to `swapcontext'
../../mysys/libmysys.a(my_context.c.o): In function `my_context_spawn':
my_context.c:(.text+0xfc): undefined reference to `getcontext'
my_context.c:(.text+0x164): undefined reference to `makecontext'
../../mysys/libmysys.a(my_context.c.o): In function `my_context_yield':
my_context.c:(.text+0x194): undefined reference to `swapcontext'
collect2: error: ld returned 1 exit status

as I remember I tested it on arm too, I'll see about changing build to libstdc ASAP

RAMIPS: https://cdn.corifeus.com/lede/17.01.3/packages/mipsel_24kc/mariadb/
LINKSYS WRT ARM: https://cdn.corifeus.com/lede/17.01.3/packages/arm_cortex-a9_vfpv3/mariadb/

Right now it will be singed as well, but building the whole repo which is 6 hours....

Soon because of @lucize, there will be MariaDB 10 :slight_smile:

Right now it is here:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.