I have a Linksys WRT1900ACS which has been running OpenWRT 19.07 just fine for a long time; today I replaced it with a second WRT1900ACS running 23.05.4, and my network is happy.
I now want to upgrade the first WRT from 19.07 to 23.05, so I powered it up, plugged in my laptop and got no GUI. So I powered off, held down the reset button, powered it on, continued holding down reset for 20 seconds, then let it boot. My laptop got a 192.168.1.x IP address, and 'Router' and 'DNS Server' were both 192.168.1.1. I attempted to connect to 192.168.1.1 with Firefox, and got 'Unable to connect', so I tried resetting the router again, with the same result. I can ping 192.168.1.1 and get a response, but attempting to ping the upstream device (plugged into the WAN port) gives:
92 bytes from openwrt.lan (192.168.1.1): Destination Net Unreachable
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 5400 eda5 0 0000 40 01 0827 192.168.1.139 192.168.2.1
At this point I tried switching to the other firmware partition using the instructions here: https://openwrt.org/docs/guide-user/troubleshooting/vendor_specific_rescue#dual_firmware_partition, and got the exact same failure - it acted like it hadn't switched partitions.
After repeating all of the above several times I did some reading here in the forum, SSH'd into the router, and ran a few tests:
OpenWrt 19.07.8, r11364-ef56c85848
-----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# netstat -antp
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 1789/uhttpd
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 2460/dnsmasq
tcp 0 0 192.168.1.1:53 0.0.0.0:* LISTEN 2460/dnsmasq
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1638/dropbear
tcp 0 208 192.168.1.1:22 192.168.1.139:51376 ESTABLISHED 2478/dropbear
tcp 0 0 :::80 :::* LISTEN 1789/uhttpd
tcp 0 0 ::1:53 :::* LISTEN 2460/dnsmasq
tcp 0 0 fe80::6238:e0ff:fe04:61a3:53 :::* LISTEN 2460/dnsmasq
tcp 0 0 fe80::6038:e0ff:fe04:61a3:53 :::* LISTEN 2460/dnsmasq
tcp 0 0 fd98:dbef:f47e::1:53 :::* LISTEN 2460/dnsmasq
tcp 0 0 fe80::6038:e0ff:fe04:61a3:53 :::* LISTEN 2460/dnsmasq
tcp 0 0 fe80::6238:e0ff:fe04:61a3:53 :::* LISTEN 2460/dnsmasq
tcp 0 0 :::22 :::* LISTEN 1638/dropbear
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd98:dbef:f47e::/48'
config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option ifname 'eth1.2'
option proto 'dhcp'
config interface 'wan6'
option ifname 'eth1.2'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'
I can see that uhttpd is running and listening on port 80, but LuCI is still missing. The network configuration looks OK for a pre-DSA firmware, although I am puzzled by VLAN 2.
Does anyone see anything obviously wrong? What should my next troubleshooting steps be?
Thank you in advance for your help!