[SOLVED] Luci not saving changes

Hey all
Im using the latest snapshot for bthh5a i have installed the uhttd and luci however when i click on anything it asks for logon credentials. Then lico goes to the page i clicked on however when i enter any details and press save or save and apply the changes are not saved.

Have i missed a module or something when installing lucI ?


I've seen this with multiple windows open on the same LuCI instance. It seems as though the user-session management "isn't happy" with that.

You shouldn't have to install anything other than luci. Let it pull in uhttpd automatically as a dependency. Not sure whether your manual installation might have messed things up. You can reset the router to defaults to remove all installed packages, and start over again. And this time, try installing only Luci.

But @jeff's advice is probably better and easier to try out first :slight_smile:

I need luci to setup the dsl i had to manually scp the ipks to the bthh5a. Otherwise the bthh5a has no internet.
I tried the single window vut even then it just goes back to logon and then does not save. I have installed the mod-admin but still never helped... maybe i can bodge it on my network somehow

Luci has many many different dependencies, so if you only installed 2 or 3 ipks you're probably missing quite a few, and hence stuff is broken. There's multiple options that you can do:

  1. Compile in Luci yourself. You can follow this quick guide for compiling yourself. Make sure you include Luci in make menuconfig. It will pull in all the dependencies automatically: https://openwrt.org/docs/guide-developer/quickstart-build-images
  2. Run a release image that already has Luci included and configure your connection here. Optionally, you can then upgrade to a snapshot while preserving settings. This will make sure you connection remains functional and hence you can then use opkg to install Luci on the snapshot build.
  3. Configure your connections via UCI or manually editing the configuration files. Then use opkg to pull in Luci.

Omg deleteing the luci and uhttpd i deleted /etc/config....
Now tring to get into failsafe lol

Will automatically be generated upon running the firstboot command via an ssh shell.

Thanks just ran it and it whinged about ubio 2 not being mounted :blush: had to mount_root first

1 Like

Fixed.... thanks all


This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.