[Solved] Luci delete interface bug on x86

Using https://downloads.lede-project.org/releases/17.01.1/targets/x86/64/lede-17.01.1-x86-64-combined-squashfs.img I did the following:

  1. On (In luci) add a new interface. Name it something strange like "bug", and then fill in static information.
  2. On Delete interface, and the interface does not disappear.
  3. Interface appears to stop receiving packets but the interface is still there, and it's still in /etc/config/network.

I apologize if this is already known. I didn't find it.

Edit: By the way, https://downloads.openwrt.org/snapshots/trunk/x86/64/openwrt-x86-64-combined-squashfs.img behaves as expected.

When I do the same steps in firefox it works. I was using chrome to duplicate the bug.

I had time to create a VM, and I cannot reproduce the problem using 17.01.2. Since you did not specify, I tested both case: before committing changes and after committing changes. Interface is gone also from /etc/network file. I've tested with Chrome and Firefox and both yield the same results.

Can you test again with 17.01.2 ?

I tried and yes chrome works as expected with luci. I can add and delete an interface.

I was using 17.01.1 before.