[solved...kinda] Not seeing DHCP clients in client list

My PC has an ipv4 and ipv6 address assigned from OpenWRT router via DHCP. Like this:

I expected to see my IPv4 address and mac in the DHCP client list. But it does not show up there. Only the IPv6 address is shown. Why is that? It's the case in both the status page as well as the DHCP page.

I'm using v21.02.1 OpenWRT.

A lot of people have asked about the ability to disable IPv6, but the answer seems to be you can't. Is that still the case? I have no utility for ipv6.

Since the router LAN IP is .240, the gateway is .3, and the client get .1.x IPs, the dhcp wouldn't appear to be used.

You're LAN is still off, in some way.

There must be another server in the .1.0 network which actually served your PC. That is not good. It gets really complicated having more than one DHCP server in a network, so the typical home network should have only one, hosted in the main router. Often the problem is failing to turn off the DHCP server in a dumb AP or other LAN device.

The IPv6 features of the DHCP server can be turned off separately by clicking the IPv6 tab and setting the options to disabled.

The LAN IP at <> is the "IPv4 Upstream". That is the WAN IP address of the OpenWRT router, since it's being assigned a private IP from the main home router. So it's "the internet" side for this OpenWRT router. The LAN side of the OpenWRT router is 192.168.1.x, so it's on a different subnet. The interface screen shot makes this more clear:

Just now, I tried isolating the OpenWRT from the upstream network by removing the WAN cable, and that's when my PC showed up in the IPV4 client list.

I have no idea what's going on. :face_with_raised_eyebrow:
It shouldn't matter that I have another router upstream of this OpenWRT. Why does unplugging the cable on the WAN make the IPv4 address show up?

It's a Linksys WRT1200AC, v3.

And yes, my previous reply clarify that the 192.168.2.x subnet is on the WAN side of this OpenWRT router that I'm playing with. I included a screen shot of the LAN side of my OpenWRT router, to show it's on a separate subnet.

I don't believe I have another DHCP server on the network. As I'm playing around with OpenWRT and getting familiar with it, I have just my PC plugged into it, and another cable on the WAN side of the OpenWRT router going to my main house router, which is on a separate subnet.

Can you clarify where to find the IPv6 disable option? Is it this, under Network>Interfaces>LAN, edit>Advanced Settings>Delegate IPv6 prefixes? The option doesn't really make it obvious that it means to disable IPv6 for DHCP.

Edit: oh, I think it's this option under Network>Interfaces>LAN,edit>DHCP Server > IPv6 Settings >
Set DHCPv6Service to disable.

Edit: With IPv6 off, my IPv4 address shows up in the DHCP lease list, even with WAN port plugged in. I don't understand why, if this is a weird bug, or if it's something I'm doing. I'm not comfortable with the odd behavior.

I'd say it's an user error, we've been given far from enough details to be able to say it's openwrt related.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.