[Solved] Issue with build on latest Ubuntu 18.04 LTS

I'm getting this error on make menuconfig with latest LTS Ubuntu, wondering if anyone else is seeing same; dirclean was done.

Is that the just-/about-to-be-released "Bionic Beaver" or

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.4 LTS
Release:	16.04
Codename:	xenial

Yes, it's BB 18.04, released on the 26th. I copied a configdiff over from a 16.04 machine last week and have done a number of builds(_make defconfig only, which are running), just did not get around to doing a make menuconfig until today.

I have moved my build environment into Ubuntu 18.04 last week and have seen no problems.

Menuconfig gets compiled ok and works as expected, both with the master and the 17.01 branch.

Did you ensure you installed all required build packages that would have likely needed different version numbers for Ubuntu 18? Specifically:

  • libboost1.xx-dev, libgtk-x-dev, openjdk-x-jdk, perl-modules-5.xx, & python3.x-dev

Would a make clean fix something like that, or could one simply clone the repo into a new folder, issue make menuconfig in the new folder, exit, then copy the new repo contents to the existing repo, overwriting whatever file is the cause of the issue?

Well, at least for me the same prereqs as with Ubuntu 17.04 and 17.10 worked ok. Python2 needs to be installed since 17.10 (as there is just python3 by default), but otherwise the list has not changed for a while.

sudo apt-get install build-essential subversion libncurses5-dev zlib1g-dev
sudo apt-get install gawk gcc-multilib flex git-core gettext libssl-dev
sudo apt-get install python

And I am not sure if the config options have any relevance there. menuconfig is just compiled inside scripts/config with the native host gcc, I think.

Thanks, it was my environs. This was an existing buildroot on a small x86 box, updated from Ubuntu LTS 16.04 to 18.04. It required a distclean to clear out existing modules built by 16.04 under the ./scripts directory.

Yeah, those compiled objects in scripts/config are a bit hidden.

Ps. there is a specific make command to clean them:
make config-clean

1 Like

Reviving this for another weird error on Ubuntu 18.04: https://pastebin.com/N8GcAFSR (I think it's better to collect all errors in the same thread, right?).

Freshly downloaded and untarred mvebu SDK, after make menuconfig I ran update script and while it did check out files from git successfully, I keep getting the errors.

I didn't change the default locale (it's a server after all), so I have no idea what might have prompted that. Any help?

So if I do make distclean the feeds script errors seem to go away, but as soon as I recompile binaries make package/linux/compile, it comes back.

On Ubuntu 18.04.1 x86 box.
Just grabbed the recently generated 18.06.1 SDK, extracted, make menuconfig with save, and get the same on doing a feed update, with the addition of interspersed core dumps. On some cursory googling this appears to be a locale issue, but I think everything is correct on this box for LANGUAGE=en_CA:en.

Edit: have you tried the image builder for same behaviour? I have never used either of these tools before.

1 Like

Image Builders work fine (I have different ones for different targets).

Did you solve the problem by just export LANGUAGE=en_CA:en? Because I've done that and it didn't help.

Try export LC_ALL=C to prevent loading any locales.

1 Like

Thank you, dunno if it was the export or the 18.06.1 update, but combination of those helped.