Hmm...
I would try the following.
Search for your wan interface in /etc/config/network
(i guess ops device supports swconfig)
config switch_vlan
option device 'switch0' // may differ
option vlan '3' // may differ
option vid '6' // may differ (should be vlan 6?)
option ports '4t 6t' // may differ
Create the the following new vlan
config switch_vlan
option device 'switch0' // may differ
option vlan '4' // may differ
option vid '4' // Vlan id 4
option ports '4t 6t' // may differ.
caution: only alter the switch config if you know how to recover you device in the case you lose access.
Create the vlan 4 interface:
(Copy and pasted from OP x) )
config interface 'iptv'
option proto 'dhcp'
option ifname 'eth0.4'
option classlessroute '1'
option vendorid 'IPTV_RG'
option defaultroute '0'
option peerdns '0'
option gateway '0'
config interface 'lan'
......
option igmp_snooping '1'
......
config route
option interface 'iptv'
option target 'x.x.x.x/x'
option gateway 'x.x.x.x'
Is this even needed? Why doesn't the isp dhcp server push the routes?
If someone could explain this to me please?
Actually i would try to remove option classlessroute, defaultroute, peerdns and gateway and then check what the the isp dhcp hands out?
firewall
config zone
option name 'iptv'
option output 'ACCEPT'
option masq '1'
option network 'wan'
option family 'ipv4'
option forward 'DROP'
option input 'DROP'
option mtu_fix '1'
config forwarding
option dest 'iptv'
option src 'lan'
igmpproxy
config igmpproxy
option quickleave 1
config phyint
option network iptv
option direction upstream
list altnet 0.0.0.0/0
config phyint
option network lan
option direction downstream
And let the igmp proxy init script create the firewall rules.
or if not wanted
config rule
option src iptv
option proto igmp
option target ACCEPT
config rule
option src iptv
option dest lan
option proto udp
option dest_ip 224.0.0.0/4
option target ACCEPT
option family ipv4
Maybe increase the ttl by 1
/etc/firewall.user
/usr/sbin/iptables -t mangle -A PREROUTING -p udp -d 224.0.0.0/4 -i iptv -j TTL --ttl-inc 1
Also try to force igmp version 2
/etc/sysctl.conf
net.ipv4.conf.all.force_igmp_version=2