Difference between igmp_snooping on switch and interface section

Okay, thanks for mention that. At the moment there is only one development device (Rpi4) temporaly connected to the C2600. I just want to know all limitations.
I have to setup two different networks for my family and their don't have such a core router and have to connect some devices to the OpenWRT router itself. That's the use case.

Just for information. I found an old entry about the same question: https://openwrt-devel.openwrt.narkive.com/BXnHsjX0/about-igmp-snooping-support

Hi,

My router hardware has a AR8327 switch which is supposed to support hardware
IGMP snooping, but it seems it doesn't work on my OpenWrt of trunk.
I noted that in target/linux/generic/files/drivers/net/phy/ar8216.h there is
a AR8327_FWD_CTRL1_IGMP defined but not used anywhere.
And there is a config option CONFIG_BRIDGE_IGMP_SNOOPING in kernel config.
Does these two affect this feature? How can I enable IGMP snooping in
OpenWrt on my router

IGMP snooping for switches has a slightly different meaning than IGMP
snooing support in linux.
For switches (also for AR8xxx) IGMP snooping means that any
JOINS/LEAVES are redirected to the CPU port, so the CPU can
setup/update the appropriate forwarding entries in the switch.
So for this feature to work it requires a daemon capable of that,
which currently doesn't exist.

The IGMP snooping from linux does something like that already, but
only for bridge interface members. That means that is able to prevent
multicast traffic from leaking to wlan, but it does not have any
influence to the individual switch ports.

Jonas

So I guess there is no daemon available after 8 years.

I just read nearly every thread here in the forum about IGMP snooping. This is the most interesting one: Multicast/switch/snooping/vlan problem. Bug?

There is suggested to invert the CPU ports to the switch. I will try that and test IGMP snooping again. But first I will update today to the latest stable release.

Okay, I updated to the latest stable release (19.07.4) and tested following cases:

  1. Enable igmp snooping and igmpv3 in the switch config and leave everything like in the config posted earlier: the multicast stream on the iptv box stops after some seconds and stands still for about 4 seconds. After that time the streams works again for about 10 seconds. The network doesn't get flooded.
  2. I tested only igmp snooping without igmpv3 enabled: same results as in 1.
  3. Only igmpv3 without igmp snooping doesn't seem to have an effect: the stream works fine and my network gets flooded.
  4. I inverted the CPU ports in the network config. All eth0 interfaces changed to eth1 interfaces and vice versa. In the vlan section I inverted the CPU ports of the vlan 1 and vlan 7. After it I enabled igmp snooping and igmpv3. The stream on the iptv box stops after some seconds, then the sound disappears and the stream gets really stuttering and laggy without sound. This was the same result before I sysupgraded the router without changing the CPU ports. So the update in 1. is an improvment but still not usable. :frowning:
root@OpenWrt:~# tcpdump -n -i eth1.1 'igmp'
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1.1, link-type EN10MB (Ethernet), capture size 262144 bytes
11:41:08.525609 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:41:15.944149 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:41:18.948919 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:41:18.976102 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:41:26.892805 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:41:34.252050 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:41:42.433037 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:41:49.573587 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:41:50.329828 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:41:53.334158 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:41:54.615809 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:42:03.930604 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:42:13.927021 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:42:22.977089 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:42:27.554219 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:42:27.896466 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:42:31.356943 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:42:37.353177 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:42:43.360470 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:42:52.774095 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:43:01.929970 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:43:08.577036 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:43:14.586791 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:43:16.777194 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:43:23.065380 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:43:26.069681 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:43:39.130970 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:43:50.426970 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:43:57.850931 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:43:57.850931 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:44:04.064552 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:44:07.069125 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:44:07.116864 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:44:16.048199 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:44:19.052332 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:44:25.930322 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:44:37.375559 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:44:45.292651 IP 192.168.1.1 > 224.0.0.1: igmp query v2
11:44:51.119662 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
11:44:51.119662 IP 192.168.1.195 > 232.0.20.85: igmp v2 report 232.0.20.85
^C
38 packets captured
41 packets received by filter
0 packets dropped by kernel
root@OpenWrt:~#

With igmp snooping on the latest version of OpenWRT I can see igmp traffic on the interface, but the iptv box stops the stream periodically after some seconds and starts it again.

@lleachii
I read this topic today:

You wrote disabling IGMP snooping makes igmpproxy unnecessary. Now I'm thinking my igmpproxy config isn't correct.

Now I changed my igmpproxy config like in the wiki:

config igmpproxy
        option quickleave 1
#       option verbose [0-3](none, minimal[default], more, maximum)

config phyint
        option network wan
        option zone wan
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan
        option zone lan
        option direction downstream

My network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbc:33fb:8f21::/48'

config interface 'lan'
        option type 'bridge'
        option igmp_snooping '1'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.7'
        option proto 'pppoe'
        option password 'xxx'
        option username 'xxx@t-online.de'
        option ipv6 'auto'

config interface 'wan6'
        option ifname 'eth0.7'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option igmp_snooping '1'
        option igmp_v3 '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '1 2 3 4 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option vid '7'
        option ports '0t 5t'

And in the firewall config I added the input rules:

config rule
        option target 'ACCEPT'
        option family 'ipv4'
        option proto 'udp'
        option dest_ip '224.0.0.0/4'
        option name 'iptv'
        option src 'wan'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option name 'Allow-UPD-IPTV'
        option family 'ipv4'
        option proto 'udp'

With these settings I can see via tcpdump only the routers IP-address in the packets (192.168.1.1). Of course IPTV isn't working. When I disable IGMP snooping network is flooded but IPTV works and I see all IPs via tcpdump.

That makes me think my igmpproxy isn't working properly?

Turn off all streams on the TV. Then, on your router, tcpdump on the LAN interface for igmp. Then have the TV start up a stream... You should see on the router an IGMP subscribe event. If you don't it's because IGMP snooping is failing to realize your router wants to hear subscribes... if it doesn't hear subscribes, then it doesn't know to proxy them onto the WAN. I think this is the problem.

Sorry for the late answer, had to wait till my family doesn't need the TV anymore. :wink:

Here's what the tcpdump looks like when igmp_snooping on the switch is enabled. I turned the iptv box on around 17:48:10. It has to boot for about 60 seconds.

root@OpenWrt:~# tcpdump -n -i eth1.1 'igmp'
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1.1, link-type EN10MB (Ethernet), capture size 262144 bytes
17:42:19.516313 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:42:28.670539 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:42:36.990386 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:42:48.034285 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:42:55.710534 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:43:03.525388 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:43:12.192962 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:43:22.431655 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:43:32.030370 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:43:39.632603 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:43:49.951099 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:43:59.462023 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:44:05.474616 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:44:15.858389 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:44:21.866168 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:44:30.797285 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:44:36.806542 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:44:43.711080 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:44:51.550174 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:45:01.633101 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:45:09.471865 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:45:18.364312 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:45:24.715756 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:45:34.912600 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:45:48.054434 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:45:56.673076 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:46:07.765275 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:46:15.366658 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:46:21.383870 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:46:29.994263 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:46:36.954577 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:46:43.375424 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:46:53.631864 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:47:01.231108 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:47:11.552687 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:47:22.155976 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:47:29.194940 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:47:35.994022 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:47:44.832720 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:47:51.050255 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:48:00.796544 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:48:08.751797 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:48:18.111048 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:48:27.072410 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:48:37.835815 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:48:48.063961 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:48:56.511301 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:49:08.016763 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:49:18.270617 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:49:27.232501 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:49:34.794855 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:49:40.803447 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:49:48.060541 IP 192.168.1.1 > 224.0.0.1: igmp query v2
17:49:57.756308 IP 192.168.1.1 > 224.0.0.1: igmp query v2
^C
54 packets captured
54 packets received by filter
0 packets dropped by kernel
root@OpenWrt:~#

I can't see the iptv box on the dump. It has the ip address of 192.168.1.195. After it I turned the iptv box off and did another dump and then started the box again:

root@OpenWrt:~# tcpdump -i eth1.1 dst net 224.0.0.0/4
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1.1, link-type EN10MB (Ethernet), capture size 262144 bytes
17:54:23.471858 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:54:30.893206 IP nas540.lan.49001 > 224.0.0.251.5353: 0 [3q] PTR (QU)? _raop._tcp.local. PTR (QU)? _airplay._tcp.local. PTR (QU)? _googlecast._tcp.local. (77)
17:54:33.196258 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:54:40.191110 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:54:49.791585 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:54:55.801112 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:55:00.894290 IP nas540.lan.49001 > 224.0.0.251.5353: 0 [3q] PTR (QU)? _raop._tcp.local. PTR (QU)? _airplay._tcp.local. PTR (QU)? _googlecast._tcp.local. (77)
17:55:03.597129 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:55:10.440249 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:55:19.871843 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:55:26.681179 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:55:30.895516 IP nas540.lan.49001 > 224.0.0.251.5353: 0 [3q] PTR (QU)? _raop._tcp.local. PTR (QU)? _airplay._tcp.local. PTR (QU)? _googlecast._tcp.local. (77)
17:55:35.756273 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:55:42.671555 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:55:51.048284 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:55:58.476024 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:56:00.896496 IP nas540.lan.49001 > 224.0.0.251.5353: 0 [3q] PTR (QU)? _raop._tcp.local. PTR (QU)? _airplay._tcp.local. PTR (QU)? _googlecast._tcp.local. (77)
17:56:07.434328 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:56:13.876104 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:56:21.035006 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:56:30.271410 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
17:56:30.897615 IP nas540.lan.49001 > 224.0.0.251.5353: 0 [3q] PTR (QU)? _raop._tcp.local. PTR (QU)? _airplay._tcp.local. PTR (QU)? _googlecast._tcp.local. (77)
17:56:38.395542 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
^C
23 packets captured
23 packets received by filter
0 packets dropped by kernel
root@OpenWrt:~#

The iptv box was booted around 17:55:48. I can't see a stream. Now I turned off the box again and did a third tcpdump and turned the box back on:

root@OpenWrt:~# tcpdump -i eth1.1 'udp' | grep 192.168.1.195
[...]
18:03:48.071734 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.074731 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.079754 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.083749 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.086997 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.091499 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.096245 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.100726 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.103725 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.109474 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.112963 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.117224 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.121728 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.126475 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.129589 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.134226 IP 87.141.218.47.32188 > 192.168.1.195.34483: UDP, length 1328
18:03:48.399034 IP 192.168.1.195.34484 > 87.141.218.47.43962: UDP, length 180
18:03:50.260220 IP 192.168.1.195.34905 > OpenWrt.lan.53: 36223+ A? api-global.netflix.com. (40)
18:03:50.260239 IP 192.168.1.195.45087 > dns.google.53: 27810+ A? api-global.netflix.com. (40)
18:03:50.268799 IP OpenWrt.lan.53 > 192.168.1.195.34905: 36223 10/0/0 CNAME api-global.dradis.netflix.com., CNAME api-global.eu-west-1.origin.prodaa.netflix.com., A 52.208.47.23, A 54.154.201.229, A 34.242.190.16, A 52.211.32.129, A 54.77.50.87, A 52.214.229.94, A 34.241.87.114, A 34.240.25.4 (249)
18:03:50.277029 IP dns.google.53 > 192.168.1.195.45087: 27810 10/0/0 CNAME api-global.dradis.netflix.com., CNAME api-global.eu-west-1.origin.prodaa.netflix.com., A 52.213.76.13, A 52.208.94.135, A 52.214.146.245, A 52.48.157.65, A 34.249.164.177, A 52.213.219.23, A 52.51.246.237, A 54.171.95.57 (249)
^C16275 packets captured
16282 packets received by filter
0 packets dropped by kernel

root@OpenWrt:~#

I can see packets of UDP (first 5 seconds after the box is on) and then only some packets. This would match to the stuttering. My understanding is, that the box uses UDP for the first seconds after switching the stream and then uses multicast. The problem is with snooping the multicast part doesn't work.

Now I turned of igmp snooping in the config switch part and iptv box finished booting at 20:11:25:

root@OpenWrt:~# tcpdump -n -i eth1.1 'igmp'
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1.1, link-type EN10MB (Ethernet), capture size 262144 bytes
18:09:59.915303 IP 169.254.165.153 > 224.0.0.251: igmp v2 report 224.0.0.251
18:10:02.288563 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:10:03.323857 IP 192.168.1.101 > 224.0.0.2: igmp leave 224.0.0.251
18:10:03.324832 IP 192.168.1.1 > 224.0.0.251: igmp query v2 [gaddr 224.0.0.251]
18:10:03.345412 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:10:07.213134 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:10:07.494220 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:10:10.498943 IP 192.168.1.1 > 224.0.0.251: igmp query v2 [gaddr 224.0.0.251]
18:10:13.503317 IP 192.168.1.1 > 224.0.0.251: igmp query v2 [gaddr 224.0.0.251]
18:10:16.507112 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:10:17.603539 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:10:19.494764 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:10:19.595733 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:10:22.315894 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:10:29.577143 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:10:30.025904 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:10:32.903130 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:10:34.345306 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:10:37.350969 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:10:38.284163 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:10:42.076126 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:10:44.954192 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:10:46.303389 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:10:46.605889 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:10:48.291201 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:10:53.686600 IP 192.168.1.195 > 224.0.0.22: igmp v3 report, 1 group record(s)
18:10:53.758773 IP 192.168.1.195 > 224.0.0.22: igmp v3 report, 1 group record(s)
18:10:54.076360 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:10:56.763159 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:10:57.207106 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:10:57.786992 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:01.756429 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:11:02.963288 IP 192.168.1.195 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:04.297220 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:09.409674 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:11:09.826677 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:11.504139 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:11:16.515961 IP 192.168.1.195 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:16.783568 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:17.116701 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:11:19.658469 IP 192.168.1.200 > 224.0.0.2: igmp leave 224.0.0.251
18:11:19.756234 IP 192.168.1.200 > 224.0.0.2: igmp leave 224.0.0.251
18:11:21.298108 IP 192.168.1.195 > 232.0.20.2: igmp v2 report 232.0.20.2
18:11:24.310966 IP 192.168.1.195 > 232.0.20.2: igmp v2 report 232.0.20.2
18:11:28.867845 IP 192.168.1.195 > 232.0.20.2: igmp v2 report 232.0.20.2
18:11:33.260632 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:11:34.996347 IP 192.168.1.195 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:38.728651 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:40.812421 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:42.004366 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:11:42.244214 IP 192.168.1.195 > 232.0.20.2: igmp v2 report 232.0.20.2
18:11:43.357056 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:11:46.014811 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:11:46.527119 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:46.796491 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:46.804491 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:11:48.164145 IP 192.168.1.195 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:49.083918 IP 192.168.1.195 > 232.0.20.2: igmp v2 report 232.0.20.2
18:11:49.437134 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:11:59.231960 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:11:59.320137 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:11:59.799695 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:12:01.505696 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:12:08.003941 IP 192.168.1.195 > 239.255.255.250: igmp v2 report 239.255.255.250
18:12:08.739791 IP 192.168.1.195 > 232.0.20.2: igmp v2 report 232.0.20.2
18:12:08.957356 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:12:12.411252 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:12:12.787392 IP 192.168.1.149 > 239.255.255.250: igmp v2 report 239.255.255.250
18:12:14.305020 IP 192.168.1.107 > 224.0.23.12: igmp v2 report 224.0.23.12
18:12:14.979869 IP 192.168.1.195 > 239.255.255.250: igmp v2 report 239.255.255.250
18:12:15.460480 IP 192.168.1.20 > 239.255.255.250: igmp v2 report 239.255.255.250
18:12:15.807583 IP 192.168.1.195 > 232.0.20.2: igmp v2 report 232.0.20.2
18:12:21.117548 IP 192.168.1.101 > 224.0.0.251: igmp v2 report 224.0.0.251
18:12:22.540302 IP 192.168.1.1 > 224.0.0.1: igmp query v2
18:12:23.192018 IP 192.168.1.195 > 239.255.255.250: igmp v2 report 239.255.255.250
^C
75 packets captured
79 packets received by filter
0 packets dropped by kernel
root@OpenWrt:~#
root@OpenWrt:~# tcpdump -i eth1.1 dst net 224.0.0.0/4
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1.1, link-type EN10MB (Ethernet), capture size 262144 bytes
18:13:37.450602 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.451601 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.453115 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.454120 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.455627 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.456882 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.458614 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.460112 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.461620 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.462564 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.463554 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.465056 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.466298 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.467798 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.468801 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.470386 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.471798 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.472803 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.473804 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.475547 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.476557 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.478051 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.478552 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.480052 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.481566 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.482547 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.483602 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.484843 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.486342 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.487353 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.488834 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.490520 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.491845 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.492844 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.494590 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.496091 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.497597 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.498597 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.500087 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.501609 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.502629 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.503846 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.505364 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.506466 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.507354 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.508342 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.509844 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.510853 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.512096 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.513097 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.514101 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.515598 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.516595 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.518108 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.519347 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.521114 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.522094 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.523102 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.524607 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.525749 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.527104 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.528594 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.529608 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.530927 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.532852 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.533852 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.535354 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.536344 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.537851 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.539094 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.540590 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.541096 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.542106 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.543605 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.545096 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.546091 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.547603 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.548348 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.550473 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.551350 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.552853 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.553848 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.555454 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.556874 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.558099 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.559599 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.560603 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.562102 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.563106 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.564597 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.566090 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.567347 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.568349 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.569847 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.570851 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.571848 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.573350 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.574347 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.575597 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.576598 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.577599 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.579106 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.580616 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.581602 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.583105 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.584093 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.585113 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.587105 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.588112 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.589602 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.591095 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.592100 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.593585 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.594841 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.596346 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.597848 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.599354 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.600408 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.601356 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.602791 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.603548 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.605041 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.606039 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.607554 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.608538 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.609545 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.611041 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.612038 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.613294 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.614794 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.616300 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.617800 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.619377 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.620791 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.622039 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.622548 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.624039 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.625544 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.626550 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.628040 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.629534 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.631385 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.631903 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.632877 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.634365 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.635378 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.636864 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.637864 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.638877 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.640124 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.641634 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.642633 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.644123 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.645116 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.646622 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.647628 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.649125 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.650700 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.652109 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.653102 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.655095 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.656220 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.657861 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.658861 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.660437 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.661843 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.662847 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.663856 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.665350 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.666345 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.667101 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.668604 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.669607 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.671106 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.672109 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.673592 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.674606 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.675857 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.677353 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.678854 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.680470 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.681358 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.682356 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.683850 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.685599 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.687103 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.688101 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.689597 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.690608 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.692101 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.693102 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.694849 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.695356 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.696859 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.697860 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.699351 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.700452 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.701360 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.702868 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.704104 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.705100 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.706097 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.707602 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.708603 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.709623 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.711124 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.713107 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.714111 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.715606 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.717097 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.718594 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.719607 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.721095 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.722373 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.723357 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.724846 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.726363 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.727592 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.728375 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.729863 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.730555 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.732053 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.733055 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.734540 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.736042 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.736546 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.738544 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.739798 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.740797 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.742303 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.743302 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.744792 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.745799 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.747299 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.748545 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.750046 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.751054 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.752612 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.754101 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.755600 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.757097 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.758352 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.759850 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.761371 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.762365 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.762867 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.764364 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.765363 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.766611 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.768101 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.769105 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.770105 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.771618 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.772612 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.774111 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.775122 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.776850 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.778136 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.779607 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.781114 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.782600 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.783601 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.784601 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.785857 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.787349 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.788355 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.790022 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.791362 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.792850 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.793853 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.795092 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.796111 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.797101 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.798600 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.799597 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.800615 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.802105 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.803099 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.804851 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.805858 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
18:13:37.806852 IP 87.141.215.251.4000 > 232.0.20.2.10000: UDP, length 1328
^C
281 packets captured
284 packets received by filter
0 packets dropped by kernel
root@OpenWrt:~#

Now the stream works and floods my network.

Glad you got it working.

(Can you explain what network flooded means?)

Every client connected to the switchport of the OpenWRT router gets the multicast stream. I want igmp snooping on the switch so only the ports that requested the multicast will get it. I wonder why this works without problems on the router of the ISP. There not all wired client gets the multicast when the iptv box is active.

My suspicion seems to be correct... only with snooping disabled on the C2600 do the IGMP reports show up.

I just don't think this is likely to ever work. I don't know if it's a hardware issue, or a lack of documentation, or a software issue in the kernel not enabling the hardware snooping properly, or what, but in these consumer switches it seems rare for the hardware snooping to work correctly.

From a practical perspective, the solution is to stop using the C2600 switch, and move to using a tp-link or zyxel consumer managed switch ~ $25-30

Zyxel GS1200-5 or TP-link sg108e (and update the firmware to the latest as soon as you get it).

That's unsatisfying. :frowning: So it has to be something with the software, configuration or documentation. Because with stock firmware many routers can handle IGMP snooping without issues. I'll test some other devices soon.

I would be interested to see tests on that.

1 Like

I could flash the stock firmware or use a Linksys EA8300 or a Linksys EA6350 behind the C2600 and sniff the traffic on different ports while the iptv box is running. Or how would a good test be? Because I can't do a tcpdump on a stock firmware.

Maybe I will create a separate VLAN only for the iptv box and have a unique broadcast domain.

That seems like a reasonable test. My general take on this kind of stuff is to avoid the hassle and just spend the $30 for a supported piece of hardware (a smart managed switch). Debugging this can't be less than 2 hours of fiddling around, and probably less than 50% chance it'll work right by the end of it... so expected benefit far less than minimum wage where I live. Of course if you actually figure it out, you might help hundreds of people on the internet. so there's that.

I did just one more test: I let my iptv box running and made a tcpdump on the entire eth1 interface. I see there IGMP packets. I did the same for the entire eth0 interface and couldn't get a single packet within 5 minutes while the iptv box was running.
Then I enabled in the switch config igmp_snooping for eth1. The subscribed iptv stream began to stutter and hanging for several seconds, I could still see some IGMP packets on eth1 interface. I think this happens because I didn't reboot the iptv box. But then I made a tcpdump on eth0 and now with igmp_snooping enabled on eth1 I also see packets on eth0? This is the same behaviour like described here:

Now the obvious question: I thought this bug is already fixed in the latest build? How would my network config look like if I want to invert the CPU ports for eth0 and eth1?

My current network config (igmp_snooping on switch disabled) looks like this:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbc:33fb:8f21::/48'

config interface 'lan'
        option type 'bridge'
        option igmp_snooping '1'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.7'
        option proto 'pppoe'
        option password '[...]'
        option username '[...]'
        option ipv6 'auto'

config interface 'wan6'
        option ifname 'eth0.7'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option igmp_snooping '0'
        option igmp_v3 '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '1 2 3 4 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option vid '7'
        option ports '0t 5t'

config interface 'wg0'
        option proto 'wireguard'
        option private_key '[...]'
        option listen_port '[...]'
        list addresses '10.14.0.1/24'

config wireguard_wg0
        option public_key '[...]'
        option persistent_keepalive '25'
        option description '[...]'
        list allowed_ips '10.14.0.3/32'

config wireguard_wg0
        option public_key '[...]'
        option persistent_keepalive '25'
        option description '[...]'
        list allowed_ips '10.14.0.4/32'

config route
        option interface 'wg0'
        option target '10.14.0.0'
        option netmask '255.255.0.0'

root@OpenWrt:~#

Would the config with the inverted CPU ports for eth0 and eth1 (and enabled igmp_snooping) looks like this?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbc:33fb:8f21::/48'

config interface 'lan'
        option type 'bridge'
        option igmp_snooping '1'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.7'
        option proto 'pppoe'
        option password '[...]'
        option username '[...]'
        option ipv6 'auto'

config interface 'wan6'
        option ifname 'eth1.7'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option igmp_snooping '1'
        option igmp_v3 '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option vid '7'
        option ports '5t 6t'

config interface 'wg0'
        option proto 'wireguard'
        option private_key '[...]'
        option listen_port '[...]'
        list addresses '10.14.0.1/24'

config wireguard_wg0
        option public_key '[...]'
        option persistent_keepalive '25'
        option description '[...]'
        list allowed_ips '10.14.0.3/32'

config wireguard_wg0
        option public_key '[...]'
        option persistent_keepalive '25'
        option description '[...]'
        list allowed_ips '10.14.0.4/32'

config route
        option interface 'wg0'
        option target '10.14.0.0'
        option netmask '255.255.0.0'

Thanks in advance!

Just want to update the thread: I got a TP-Link SG108E (v5) for my parents. No firmware update for this hardware version is available.

Last weekend I rebuilt the network at my parents home and I was unable to get IGMP to work with the SG108E switch. I also have a special use case:

In the basement is the fibre modem and the TP-Link SG108E switch. Both connected together. In the first floor is an OpenWRT router connected to the SG108E in the basement. It is the same cabling like in the picture from my previous post. Modem, Router and Switch is separeted in VLAN7 (tagged) on the connected ports and Router, Switch and the rest of the equipment is all in VLAN1 (untagged). In this scenario it's not possible to enable IGMP Snooping in the switch. It will block the unicast regardless the VLAN IDs. Only if I disable IGMP Snooping it's possbile to watch IPTV.

Maybe the switch is just looking globally for multicast traffic in hardware and ignoring the VLANs. So I can't get IPTV working. I have to use this topology because there is only one CAT6 cable going from the basement to the office in the first floor. I have to use VLAN tagging if I want to setup the access point in the first floor.

TL;DR
A TP-Link SG108E is not always a solution.

hmm, sorry to hear it didn't work. I have a spare one of these in the v3 variant. I'm pretty sure mine works appropriately. for example it allows for minecraft LAN games discovery for my kids and such.

I recommend you put the router entirely tagged. so tagged vlan7 and tagged vlan1. it's possible mixed packets are getting goofed up somewhere.

What is the benefit to have VLAN 1 also tagged? I need an untagged VLAN for all normal network devices which can't handle VLAN tagging.

I'm not sure how your solution would look like config wise. I need additional network ports on the OpenWRT router and all network ports on the switch in the basement. Would you do an additional subnet for the ports and force routing through the OpenWRT router? I thought I could just "add" more ports to the OpenWRT router via the switch in the basement.