[Solved] Internet Connection in Router Mode - Archer C7


#1

So I have Archer C7 V2. I have recently bricked it then just managed to fix it again today and re-flash it with OpenWrt 18.06.1 (same version I had before I bricked it with a different firmware).

Earlier I had WAN not working (probably incorrectly set-up). Now it's working, and I can in fact ping form the router, but not form the PC. I am confident that the modem is properly set-up, as it's working with a different router running a different firmware (and again I can ping form openwrt).

The modem is actually modem-router set in bridge mode, and connected via Ethernet cable to the WAN port of Archer C7. I tried setting the LAN address of the modem is on 192.168.0.1 (not that I expected it will fix the problem), but still, computers connected to the router have no internet. It doesn't seem to be DNS issue either, as I tried pinging 8.8.8.8 from the computer but no good.

Attached screenshots. Is there anything wrong there? I noticed that the WAN port got no MAC address, but I don't know what that means.

Screens

Many thanks
Mo


#2

Screenshots are too small to read.

The WAN IP address has to be in a different range from the LAN (they can't both be 192.168.1.X for example).


#3

Thanks for your reply. Yes, they are on different subnets (192.168.0.1 on the modem and 192.168.1.1 for the router). But then again, I have the WAN port as PPPoE, so I don't expect IP of the modem to matter anyway).

Status Interfaces WAN LAN


#4

The router is properly connected to the Internet. Next step would be to check on the PC that it received the proper IP, gateway and DNS configuration.


#5

Thanks. Yes, I figured out the router is accessing internet. But even when I manually set the PC IP, gateway and DNS, still not working.

Is there anything I need to do to have the router routing internet form WAN to LAN?


#6

If your PC cannot get dhcp settings or cannot ping the router when you assign static IP/mask there is something wrong with the configuration. Out of the box the LAN has full access to the router and DHCP server serves the LAN.
Have you changed anything in LAN-DHCP or in Firewall?


#7

I didn't. After flashing I just set WAN to PPPoE, put in ISP settings (e.g. credentials) and set WiFi password. I tried now connecting PC via cable but still not working.


#8

To recap, you have access to the router (hence the screenshots), but no internet. How did you connect to the router and got the screenshots if DHCP is not working and Static doesn't work either?
Let's leave the modem out of the picture for now, it is not part of the problem since it is in bridge mode.
Can you post the firewall configuration? /etc/config/firewall


#9

Thanks again for your reply and interest.

To clarify, DHCP is working, PC gets proper IP, and default getaway and DNS both get 192.168.1.1.

I can't ping an outside IP (e.g. 8.8.8.8).

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option syn_flood '1'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option network ' '
	option input 'REJECT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config forwarding
	option dest 'wan'
	option src 'lan'

#10

Your wan firewall zone is not attached to any network. That will prevent forwarding from the LAN to the Internet. The default should work: option network 'wan'


#11

I agree with @mk24. The OP should add the PPPoE interface to the WAN Firewall Zone. It seems because it's not in the WAN zone, there isn't a rule that permits LAN to WAN traffic.


#12

Here is your culprit. In zone wan of firewall, there is no interface attached. This is why in the Interfaces screen the WAN and WAN6 interfaces have white colour instead of the red. Go to Interfaces-WAN-Firewall Settings tab and add the wan zone.


#13

Many thanks @trendy, @mk24 and @lleachii. Typing this using the connection. yooohoo :slight_smile:

I must say that even though OpenWrt is a bit too advanced for me, people are really helpful and supportive. Thanks!


#14

@mhegab If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)


closed #15

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.