[Solved] Interface not found

I am trying to add a port to my openvswitch using "ovs-vsctl add-port br-lan eth1.6" but I keep getting the error "Error detected while setting up 'eth1.6': could not open network device eth1.6 (No such device)."

I have set up this eth1.6 and it appears under interfaces in Luci but when I run ifconfig -a in the shell eth1.6 does not appear.
I tried ifup eth1.6 but again I'm met with an error "Interface eth1.6 not found".
I am really unsure as to what I'm doing wrong.
Here's my configuration in /etc/config/network
config interface 'lan4'
option ifname 'eth1.6'
option proto 'static'

Any help would be much appreciated, thank you!

It appears you don't mention what OpenWRT device you're using...from reading, you're attempting to make a VLAN 6 on Ethernet device eth1.

  • are you certain its not eth0?
  • your proto is noted is 'static' - do you have static configs for this interface, or did you merely omit them in the copy/paste?
  • here is a working config for a non-bridged VLAN (most WAN Interfaces in OpenWRT are configured like this):

config interface 'wan'
option ifname 'eth0.2'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option proto 'dhcp'

1 Like

Thank you for the reply I am using a tp-link tl-wr1043n v5 router.
It was eth0 I feel like such a fool haha. Thank you.
I was roughly following this online guide which uses eth1 http://blog.ljdelight.com/turning-tp-link-wr1043ndv2-1-router-into-openflow-enabled-switch/
Thank you so much

1 Like

No problem...you may wish to edit the title and add '[Solved]' to it. This will help others browsing the forums.