[SOLVED] Installing Luci on Archer A7 hardware

Hi - new here. I just got a TP-Link Archer A7 router and put the latest build on my device. The install process went without a hitch but now that I am trying to put LuCI on, I get the following error:

root@OpenWrt:/# opkg install luci
Installing luci (git-19.018.56187-68d3351-1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/mips_24kc/luci/luci_git-19.018.56187-68d3351-1_all.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci:
 * 	liblua5.1.5
 * opkg_install_cmd: Cannot install package luci.

I installed Lua on my device but that hasn't resolved the issue. I believe the version of liblua being installed now is liblua5.1.5-2.

Can someone please help?

Thanks much.

When you use one of the daily snapshots you need to install all the packages you need immediately, or the packages on the server will be out of sync with the ones on your router. If liblua is a standalone package you can try to reinstall it.

1 Like

Thank you for the response. I did install liblua, and just tried it again. It says that liblua ver 5.1.5-1 is already installed. The problem appears to be that LuCI is looking for liblua ver 5.1.5.

#opkg update
#opkg remove liblua
#opkg install * liblua
#opkg install luci
That's how I solved it.

@jiahaolin's solution will only work until there are libraries upgraded without a need to upgrade the corresponding dependent packages...this seems to be the OP's issue.

As @Per suggested, follow both steps:

  • Download and flash a new snapshot
  • Immediately install the packages you want

Thanks, all. I ended up flashing the sysupgrade snapshot and that fixed all of my issues.

1 Like

Glad you got it working.

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.