[Solved] Install OpenWrt on a Cubieboard Cubietruck

I have read the wiki and it said the cubietruck is supported and I found the download image which is named "openwrt-18.06.1-sunxi-cortexa7-sun7i-a20-cubietruck-squashfs-sdcard.img". I flashed it to a 8GB micro SD-card and put into my cubietruck with HDMI output and USB keyboard connected, it booted but I can only see two penguins on the HDMI output screen with a line said "Please press Enter to activate this console". I pressed Enter but nothing happened. Anybody has any ideas? Any hints are appreciated. Thanks.

Might try ssh-ing into the router.

Video and USB drivers aren't typically part of the "stock" distribution.

To see what packages are included, the manifest file can help. For example, https://downloads.openwrt.org/releases/18.06.1/targets/sunxi/cortexa7/openwrt-18.06.1-sunxi-cortexa7.manifest

1 Like

Hinted by Jeff I pointed my web browser to and connected to the OpenWrt on my Cubietruck configuration page. From here I started to configure it and installed a USB-Ethernet dongle and it worked as a firewall as intended. All good now. So even without the console you can still configure OpenWrt from the admin page. Cool.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.