[SOLVED] Incorrect image file error installing to WRT54GL

On trying to upgrade from OEM to LEDE on a Linksys WRT54GL, I get the error incorrect image file after clicking upgrade on the OEM firmware upgrade page. The file I'm using is openwrt-brcm-2.4-squashfs.trx which is the file from the HW Finder.

[EDIT] It's the wrong file. WRT54GL users should refer to the WRT54G product page for specifics. The proper file, after some digging, is v10.03 for WRT54G. I upgraded to v4.30.18 of the OEM firmware first, but this shouldn't be necessary. Someone should try to install it using another version to verify (it won't brick).

There's a very simple fix for this... Spend the price of 3 sandwiches to buy a piece of hardware with 10x the capabilities of your device and don't waste time.

From that thread the GL-MT300N seems worthwhile.

1 Like

First off, see https://openwrt.org/supported_devices/432_warning

I didn't know the WRT54GL was still supported. https://openwrt.org/toh/hwdata/linksys/linksys_wrt54gl suggests that it was last supported with the 10.03.1 release. That release is certainly insecure, by today's standards.

:+1: on a US$20 or less device being far more capable than the WRT54GL.

1 Like

I actually needed to flash one this weekend; but was not sure if it was safe to do so. From researching at: https://en.wikipedia.org/wiki/Linksys_WRT54G_series#WRT54GL

The WRT54GL is technically a reissue of the version 4 WRT54G.

The correct image therefore would be:


But I don't think you'll be happy with OpenWRT 17.01.4 running on a device with only 200 MHz CPU, 4 MB of Flash and 16 MB of RAM.

Hope this helps.

1 Like

I tried that one and it gives me Upgrade are failed! (yes, it is worded like that). Let me know if you get one to work.

One would think that there'd be a fork for the original hardware that started it all, especially since Linksys still manufactures it to this day.

OK, I just attempted to flash a Cisco Valet M10 with version 18.06. The 18.06 firmware image is too big (17.01 only has 200 KB remaining after flash anyway). The M10 (E1000) also has a 4 MB of flash. I had to SSH and use CLI to see the error.

I believe I'll run into a similar issue with the GL.

I have a WRTSL54GL (8 MB flash), version 18.06 installed with no issues. If this is the case, most 4 MB devices are no longer supported - non-LuCI builds might work (i.e. SNAPSHOT).

EDIT: My WRTSL54GS constantly crashes under WAN <> LAN traffic (I've only use these devices successfully for WiFi <> Wired client/bridging since Kamikaze), with or without offloading enabled (30/30 Mbps no offload, 62/62 Mbps with offload before crashing). It seems I may have to revert to 17.01.4 (which wasn't much better).

So, there isn't a built and flashable 17.01.4 firmware for this device?

@zephalis WRT54GL dataentry shows: http://downloads.openwrt.org/backfire/10.03.1/brcm-2.4/openwrt-brcm-2.4-squashfs.trx
-> Leads to error incorrect image file when flashed via Linksys GUI

Have you tried flashing this image via TFTP?

There is a reason why the dataentry shows 10.03.1. I'm pretty sure there was a discussion about those devices which lead to openwrt-brcm-2.4-squashfs.trx in the dataentry, but I don't have the time now to search for this.

1 Like

Thanks for your edit of the first post.
I would recommend to use recent openwrt code because of many security issues fixed between your installed openwrt 10.03 and recent code.
You have to note, that because of the low amount of ram (16MB on WRT54G) you would probably have problems with luci. So the WRT54G with 16MB of RAM should install just the "snapshot" builds that dont contain luci. They work fine on 16MB RAM devices so far.
The WRT54GS that have 32MB of RAM. If you can fit Luci on the ROM, that it should work fine. Otherwise also just use the snapshot builds to have latest security fixes.