[Solved] I can't start mwan3 service

#1

I have a TP LINK WR940N V4, i´m trying to start my mwan3 service but I have the following error:

root@OpenWrt:~# mwan3 status
Interface status:
 interface wan is offline and tracking is down
 interface wan2 is offline and tracking is down

Current ipv4 policies:

Current ipv6 policies:

Directly connected ipv4 networks:

Directly connected ipv6 networks:

Active ipv4 user rules:

Active ipv6 user rules:

root@OpenWrt:~# mwan3 start
Warning: mwan3 is global disabled. Usage: /etc/init.d/mwan3 start
root@OpenWrt:~#/etc/init.d/mwan3 start
/sbin/uci: Invalid argument
Warning: mwan3 is global disabled. Usage: /etc/init.d/mwan3 start
root@OpenWrt:~#

cat /etc/init.d/mwan3:

root@OpenWrt:~# cat /etc/init.d/mwan3 start
    #!/bin/sh /etc/rc.common

START=19

reload() {
        local enabled

        config_load mwan3
        config_get_bool enabled globals 'enabled' 0
        [ ${enabled} -gt 0 ] || {
                echo "Warning: mwan3 is global disabled. Usage: /etc/init.d/mwan3 start"
                exit 0
        }
        mwan3 restart
}

boot() {
        . /lib/config/uci.sh
        uci_toggle_state mwan3 globals enabled "1"
}

start() {
        . /lib/config/uci.sh
        uci_toggle_state mwan3 globals enabled "1"
        mwan3 start
}

stop() {
        . /lib/config/uci.sh
        uci_toggle_state mwan3 globals enabled "0"
        mwan3 stop
}

My another settings are perfectly configured, the image has been made by myself.

(I have the last firmware and package versions, with the mwan3 new dependence ip-full included)

#2

There is a missing couple of lines in /etc/config/mwan3
Add the lines:
config globals 'globals'
option enabled '1'

It should then start up OK.
I have done a pull request to fix this.

1 Like
#3

Niceeeee! it's working perfect now, thanks for your help dude!!!

#4

Hi Marcelo.
What version exactly are you using? did you experienced any further problems so far?, what is exactly the name of that "new dependency" that you mention early called 'ip-full' and what is for?.

Thanks.

#5

Hi bro, I'm using OpenWrt SNAPSHOT, r6305-8f24653; I already solve my problem:

-In first place, doing my own research, I compiled my OS again with ip-full dependency installed, It are allocated on network, same place as mwan3 package. I don't know what exactly ip-full does, but It works for me, on that time I found some info on the next topic: https://github.com/openwrt/packages/issues/5022.

-I also had to enable IPv6 for my build

-On the last step a guy from this forum helped me, I just have to include two lines at the top of the mwan3 config file:

config globals 'globals'
option enabled '1'

Since I did all these changes 4 months ago my mwan3 it's working perfectly!

Thanks for answering :slight_smile: