[Solved] How to clone MAC Address for 21.02.0?

Every time I use the cat command to show the configuration file, it does not succeed. The MAC Address is hidden. Am using Newifi 3 D2 @ 21.02.0

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd85:aeb7:0303::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.10'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '8.8.8.8'
        list dns '9.9.9.9'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        list dns '2606:4700:4700::1111'
        list dns '2001:4860:4860::8888'
        list dns '2620:fe::fe'

I want to edit the MAC Address of the WAN since I'm using PPPoE, but I cannot find the MAC Address information to edit it. What do I do?

1 Like

Post output of ip a command. You can mask or remove mac addresses

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP qlen 1000
    link/ether 20:76:93:52:8f:cb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::2276:93ff:fe52:8fcb/64 scope link
       valid_lft forever preferred_lft forever
3: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 20:76:93:52:8f:cb brd ff:ff:ff:ff:ff:ff
4: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 20:76:93:52:8f:cb brd ff:ff:ff:ff:ff:ff
5: lan2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 20:76:93:52:8f:cb brd ff:ff:ff:ff:ff:ff
6: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 20:76:93:52:8f:cb brd ff:ff:ff:ff:ff:ff
7: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc cake state UP qlen 1000
    link/ether 20:76:93:52:8f:cd brd ff:ff:ff:ff:ff:ff
    inet 10.57.128.215/20 brd 10.57.143.255 scope global wan
       valid_lft forever preferred_lft forever
    inet6 2404:3c00:2420:0:fffe:97ce:a43e:29f/128 scope global dynamic noprefixroute
       valid_lft 73352sec preferred_lft 40952sec
    inet6 fe80::2276:93ff:fe52:8fcd/64 scope link
       valid_lft forever preferred_lft forever
19: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 20:76:93:52:8f:cb brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.10/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 2404:3c00:242f:b160::1/60 scope global dynamic noprefixroute
       valid_lft 73352sec preferred_lft 40952sec
    inet6 fd85:aeb7:303::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::2276:93ff:fe52:8fcb/64 scope link
       valid_lft forever preferred_lft forever
20: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 20:76:93:52:8f:ca brd ff:ff:ff:ff:ff:ff
    inet6 fe80::2276:93ff:fe52:8fca/64 scope link
       valid_lft forever preferred_lft forever
21: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 20:76:93:52:8f:cc brd ff:ff:ff:ff:ff:ff
    inet6 fe80::2276:93ff:fe52:8fcc/64 scope link
       valid_lft forever preferred_lft forever
28: ifb4wan: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc cake state UNKNOWN qlen 32
    link/ether 72:db:12:44:a7:00 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::70db:12ff:fe44:a700/64 scope link
       valid_lft forever preferred_lft forever
uci -q delete network.wan_dev
uci set network.wan_dev="device"
uci set network.wan_dev.name="wan"
uci set network.wan_dev.macaddr="00:11:22:33:44:55"
uci commit network
/etc/init.d/network restart

I got it. Thanks. Alternatively, I could just use the LuCI Interface to change it.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.