[SOLVED] How do i install theme using LuCI

Hi Everyone,

I already have LuCI Bootstrap theme installed but I would like to get the Rosy theme without fetching the whole repo.
Is there a way to do that ?. And where do i find the feed.conf file or feeds.conf.default.

Thank you :slight_smile:.

Did u try

opkg update

and then

opkg install luci-theme-rosy

in console?

Sorry for replying late.
yes i did it says pkg_install_cmd: Cannot install package luci-theme-rosy..I didn't add src-git luci https://github.com/openwrt/luci.git do i have to ? i already have OpenWrt bootstrap theme installed, when i search for themes via LuCI WebUI i cant find the rosy theme.

Where do i add that line ?.

I am not sure if you are running into the same issue I ran into some time ago. The correct way is to update the lists and then install the required package as explained above. But in any case if you cant find a package it's possible to manually download it through wget. I also ran into this problem and had to manually download the Rosy theme for a router.

You can go to downloads.openwrt.org and find your router target then look into the packages folder and you should find it somewhere there. Then copy the link and do cd /tmp; wget 'link-to-ipk-file' ; opkg install luci-theme-rosy*.ipk.

Hopefully this way you can manually install it.

1 Like

In /etc/config/luci -

config internal 'themes'                       
        option Bootstrap '/luci-static/bootstrap'

Thanks for the suggestion i saw the package directory and didnt find the theme.

I should add this line replacing what ?

Which router do you have?

TP-Link Archer c20 AC750 V4

I am not sure what target it has but have a look here: http://downloads.openwrt.org/releases/18.06.2/packages/

Also I have checked a couple of targets from above link and not one target has the theme. Maybe it's just a bug?

Edit: luci-theme-rosy is available in snapshot packages but it's not available in release ones. It's possible that developer may have pulled it back from 18.06.2? You can download it from snapshot packages if you need it.

Yeah unless the theme is not officially. supported

I was able to find the theme under x86_x64

I actually don't know why you're showing the GitHub link. So I can't answer where to add or place that line.


If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.